wxs/expected/wms_cap.xml

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

wxs/expected/wms_cap.xml

Frank Warmerdam
Tom / Normand,

I'm trying to run some of the wxs tests before extending them for WCS 1.1.
(well I've already started to extend them)

When I do "run_test.py wms_simple.py" I get the following difference on
wms_cap.xml:

warmerda@gdal64[259]% diff {expected,result}/wms_cap.xml
86c86
<           <LegendURL width="20" height="10">
---
 >           <LegendURL width="70" height="23">
88c88
<              <OnlineResource xmlns:xlink="http://www.w3.org/1999/xlink"
xlink:type="simple"
xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=image/png"/>
---
 >              <OnlineResource xmlns:xlink="http://www.w3.org/1999/xlink"
xlink:type="simple"
xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=image/png&amp;STYLE=default"/>

Are these expected changes?  I'm guessing the "&amp;STYLE=default" change
relates to the style default changes?  What about the legend url?

Have either of you been running the msautotest/wxs suite lately?  It seems
a bit crufty.

Best regards,
--
---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, [hidden email]
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org
Reply | Threaded
Open this post in threaded view
|

Re: wxs/expected/wms_cap.xml

Kralidis,Tom [Ontario]
 

> -----Original Message-----
> From: UMN MapServer Developers List
> [mailto:[hidden email]] On Behalf Of Frank Warmerdam
> Sent: 22 January, 2008 11:02 PM
> To: [hidden email]
> Subject: [UMN_MAPSERVER-DEV] wxs/expected/wms_cap.xml
>
> Tom / Normand,
>
> I'm trying to run some of the wxs tests before extending them
> for WCS 1.1.
> (well I've already started to extend them)
>
> When I do "run_test.py wms_simple.py" I get the following
> difference on
> wms_cap.xml:
>
> warmerda@gdal64[259]% diff {expected,result}/wms_cap.xml
> 86c86
> <           <LegendURL width="20" height="10">
> ---
>  >           <LegendURL width="70" height="23">
> 88c88
> <              <OnlineResource
> xmlns:xlink="http://www.w3.org/1999/xlink"
> xlink:type="simple"
> xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&
amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=i
mage/png"/>
> ---
>  >              <OnlineResource
> xmlns:xlink="http://www.w3.org/1999/xlink"
> xlink:type="simple"
> xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&
amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=i
mage/png&amp;STYLE=default"/>
>
> Are these expected changes?  I'm guessing the
> "&amp;STYLE=default" change relates to the style default
> changes?  What about the legend url?
>

I get the same diff output.

These changes may be based on
http://trac.osgeo.org/mapserver/ticket/2435 and
http://trac.osgeo.org/mapserver/ticket/2437, but I will let Assefa
comment here before committing changes.

> Have either of you been running the msautotest/wxs suite
> lately?  It seems a bit crufty.
>

I'm using them for SOS testing (sos.map), but haven't figured out what's
the best way to test for XML POST support in SOS (and WFS for that
matter, suggestions?).  Haven't tested the others for awhile.  A
./run_test.py gives me a skip/success/fail rate of 0/141/24.

..Tom
Reply | Threaded
Open this post in threaded view
|

Re: wxs/expected/wms_cap.xml

Normand Savard
In reply to this post by Frank Warmerdam
Frank Warmerdam wrote:

> Tom / Normand,
>
> I'm trying to run some of the wxs tests before extending them for WCS
> 1.1.
> (well I've already started to extend them)
>
> When I do "run_test.py wms_simple.py" I get the following difference on
> wms_cap.xml:
>
> warmerda@gdal64[259]% diff {expected,result}/wms_cap.xml
> 86c86
> <           <LegendURL width="20" height="10">
> ---
> >           <LegendURL width="70" height="23">
> 88c88
> <              <OnlineResource
> xmlns:xlink="http://www.w3.org/1999/xlink" xlink:type="simple"
> xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=image/png"/>
>
> ---
> >              <OnlineResource
> xmlns:xlink="http://www.w3.org/1999/xlink" xlink:type="simple"
> xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=image/png&amp;STYLE=default"/>
>
>
> Are these expected changes?  I'm guessing the "&amp;STYLE=default" change
> relates to the style default changes?  What about the legend url?
>
> Have either of you been running the msautotest/wxs suite lately?  It
> seems
> a bit crufty.

Frank,

I didn't run it recently and just did it.  I got the same results as
you.  I may check them a little bit.

Norm
Reply | Threaded
Open this post in threaded view
|

Re: wxs/expected/wms_cap.xml

Yewondwossen Assefa
In reply to this post by Kralidis,Tom [Ontario]
>> warmerda@gdal64[259]% diff {expected,result}/wms_cap.xml
>> 86c86
>> <           <LegendURL width="20" height="10">
>> ---
>>  >           <LegendURL width="70" height="23">
>> 88c88
>> <              <OnlineResource
>> xmlns:xlink="http://www.w3.org/1999/xlink"
>> xlink:type="simple"
>> xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&
> amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=i
> mage/png"/>
>> ---
>>  >              <OnlineResource
>> xmlns:xlink="http://www.w3.org/1999/xlink"
>> xlink:type="simple"
>> xlink:href="http://localhost/path/to/wms_simple?version=1.1.1&
> amp;service=WMS&amp;request=GetLegendGraphic&amp;layer=road&amp;format=i
> mage/png&amp;STYLE=default"/>
>> Are these expected changes?  I'm guessing the
>> "&amp;STYLE=default" change relates to the style default
>> changes?  What about the legend url?
>>
>
> I get the same diff output.
>
> These changes may be based on
> http://trac.osgeo.org/mapserver/ticket/2435 and
> http://trac.osgeo.org/mapserver/ticket/2437, but I will let Assefa
> comment here before committing changes.
>

Tom,

  The legend url tests failures are related to the changes done in 2435
(accurate Calculation of legend size for WMS LegendURL). If you have it
modified, please commit it.

Best Regards,


--
----------------------------------------------------------------
Assefa Yewondwossen
Software Analyst

Email: [hidden email]
http://www.dmsolutions.ca/

Phone: (613) 565-5056 (ext 14)
Fax:   (613) 565-0925
----------------------------------------------------------------