wxgrass: ImportError: No module named aui

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

wxgrass: ImportError: No module named aui

Helmut Kudrnovsky
hi,

i`m using opensuse 10.2. on the opensuse-dvd there is python with wxGTK.

i`ve downloaded yesterday (2007-05-16) the grass6.3-cvs-snapshot and from svn the source of the new wxgrass-gui. i've installed the wxgrass with the help in the readme-file.

if i want to start the wx-gui with wxgrass& there is the following error message:

"GRASS 6.3.cvs (gk31):~ > wxgrass&
[1] 12728
GRASS 6.3.cvs (gk31):~ > Traceback (most recent call last):
  File "/usr/local/grass-6.3.cvs/etc/wx/wxgui.py", line 34, in <module>
    import wx.aui
ImportError: No module named aui"

i have no experience with python- and wx-related things.

maybe you have an idea what is missing?

thanks in advance
helli

-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-
helmut kudrnovsky
www.alectoria.at

_____________________________________________________________________
Der WEB.DE SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!
http://smartsurfer.web.de/?mc=100071&distributionid=000000000066

_______________________________________________
grassgui mailing list
[hidden email]
http://grass.itc.it/mailman/listinfo/grassgui
best regards
Helmut
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: wxgrass: ImportError: No module named aui

Michael Barton
Which version of wxPython (and wxGTK) are you using? You need 2.8+

Michael


On 6/16/07 4:33 PM, "Helmut Kudrnovsky" <[hidden email]> wrote:

> hi,
>
> i`m using opensuse 10.2. on the opensuse-dvd there is python with wxGTK.
>
> i`ve downloaded yesterday (2007-05-16) the grass6.3-cvs-snapshot and from svn
> the source of the new wxgrass-gui. i've installed the wxgrass with the help in
> the readme-file.
>
> if i want to start the wx-gui with wxgrass& there is the following error
> message:
>
> "GRASS 6.3.cvs (gk31):~ > wxgrass&
> [1] 12728
> GRASS 6.3.cvs (gk31):~ > Traceback (most recent call last):
>   File "/usr/local/grass-6.3.cvs/etc/wx/wxgui.py", line 34, in <module>
>     import wx.aui
> ImportError: No module named aui"
>
> i have no experience with python- and wx-related things.
>
> maybe you have an idea what is missing?
>
> thanks in advance
> helli
>
> -o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-o-
> helmut kudrnovsky
> www.alectoria.at
>
> _____________________________________________________________________
> Der WEB.DE SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!
> http://smartsurfer.web.de/?mc=100071&distributionid=000000000066
>
>

__________________________________________
Michael Barton, Professor of Anthropology
School of Human Evolution & Social Change
Center for Social Dynamics & Complexity
Arizona State University

phone: 480-965-6213
fax: 480-965-7671
www: http://www.public.asu.edu/~cmbarton


_______________________________________________
grassgui mailing list
[hidden email]
http://grass.itc.it/mailman/listinfo/grassgui
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: wxgrass: ImportError: No module named aui

Ongytenes
I wasn't able to get wxbanker to work (It was issuing the same error)  When I opened my synaptic package manager I saw that I had both 2.6 and 2.8 installed. I uninstalled 2.6 and wxbanker then started working.  
Loading...