vagrant provision (GIS.lab virtual mode)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

vagrant provision (GIS.lab virtual mode)

Ludmila
Hi, 

I would like to ask.. Is it currently possible to run 'vagrant provision' with Ansible 2?
Because when I run 'vagrant provision'  I get this error:

==> gislab_vagrant: Running provisioner: install (ansible)...
[DEPRECATION WARNING]: Instead of sudo/sudo_user, use become/become_user and 
make sure become_method is 'sudo' (default). This feature will be removed in a 
future release. Deprecation warnings can be disabled by setting 
deprecation_warnings=False in ansible.cfg.
 [WARNING]: Not prompting as we are not in interactive mode


PLAY ***************************************************************************

TASK [setup] *******************************************************************
ok: [gislab_vagrant]

TASK [installation-setup : Check Ansible version (< 2)] ************************
fatal: [gislab_vagrant]: FAILED! => {"assertion": "ansible_version.major < 2", "changed": false, "evaluated_to": false, "failed": true}

NO MORE HOSTS LEFT *************************************************************
to retry, use: --limit @system/gislab.retry

PLAY RECAP *********************************************************************
gislab_vagrant             : ok=1    changed=0    unreachable=0    failed=1   

Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

Current version of Ansible is 2.0.1.0. Many thanks in advance.

Ludmila

_______________________________________________
GIS.lab mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/gis.lab
Reply | Threaded
Open this post in threaded view
|

Re: vagrant provision (GIS.lab virtual mode)

Martin Landa
Hi,

2016-04-15 17:27 GMT+02:00 Ludmila Furtkevicova <[hidden email]>:
> I would like to ask.. Is it currently possible to run 'vagrant provision'
> with Ansible 2?

for the current version of GIS.lab you need to use ansible 1.9.
Ansible 2 is supported only in xenial branch. Ma

--
Martin Landa
http://geo.fsv.cvut.cz/gwiki/Landa
http://gismentors.cz/mentors/landa
_______________________________________________
GIS.lab mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/gis.lab
Reply | Threaded
Open this post in threaded view
|

Re: vagrant provision (GIS.lab virtual mode)

Ludmila
many thanks!

2016-04-15 18:26 GMT+02:00 Martin Landa <[hidden email]>:
Hi,

2016-04-15 17:27 GMT+02:00 Ludmila Furtkevicova <[hidden email]>:
> I would like to ask.. Is it currently possible to run 'vagrant provision'
> with Ansible 2?

for the current version of GIS.lab you need to use ansible 1.9.
Ansible 2 is supported only in xenial branch. Ma

--
Martin Landa
http://geo.fsv.cvut.cz/gwiki/Landa
http://gismentors.cz/mentors/landa


_______________________________________________
GIS.lab mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/gis.lab