spatialite layer does not show

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

spatialite layer does not show

Reginald
Hi qgis users,

I have a model in which i use a parcellayer. From this parcellayer I get the
selected features.
In order to obtain one geometry I convert from singlepart to multipart
geometry.
In order to query the layers that overlay this parcels I make a buffer of
-0.3m.
The last step the model does is import the result in a spatialite database.
The layer of this spatialite database is included in a qgis project where I
run my script that generates a large report.
The problem that I get is that sometimes the spatialite layer is shown on
the map, and sometimes it's not.
By moments the layer shows up at certain scale but when you zoom in or out
the layer disappears.
Should I add something to my model so that the buffered features keep
visible?

Regards,



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-User-f4125267.html
_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: spatialite layer does not show

Reginald
Update,

In the logmessages I found this message:

2018-12-19T13:34:13     WARNING    Kon geen stijlen laden uit
F:/QGIS/dev/notarisattest/inlichtingen.sqlite (Query: SELECT styleQML FROM
layer_styles WHERE f_table_schema IS NULL AND f_table_name='uittreksels' AND
f_geometry_column ='geom' ORDER BY CASE WHEN useAsDefault THEN 1 ELSE 2
END,update_time DESC LIMIT 1)

It says it can not load any style from the sqlite database.
Maybe I should save my style in the database?

Any idea?



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-User-f4125267.html
_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: spatialite layer does not show

Claas Leiner-2
In reply to this post by Reginald
Hi Reginald,

Sometimes a invalid spatialIndex is a reason, that spatialite layer does
not shown.

Open the DB-manager in QGIS
Klick of your database in the tree and and then open the SQL-Windows
(press F2).

execute this statement in the SQL-Windows of the DB-Manager:
select recoverspatialindex('tablename','geom');

after that execute:
select updatelayerstatistics('tablename');

tablename = name of the spatialite layer
geom = name of the geometry column

Claas


--
-----------------------------------------
GKG-Kassel - Dr.-Ing. Claas Leiner
QGIS-Support und mehr

Geodatenservice, Kartenwerkstatt &
GIS-Schule Kassel

Wilhelmshöher Allee 304 E
34131 Kassel
Tel. 0561/56013445
[hidden email]
http://www.gkg-kassel.de
----------------------------------------
Unterstützen Sie QGIS
QGIS-DE e.V. | http://qgis.de
_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: spatialite layer does not show

Reginald
Thanks for the reply,

Jay M Johnson advised me this link:

https://gis.stackexchange.com/questions/131996/shapefile-layers-in-qgis-dont-display-unless-i-zoom-out

Meanwhile I solved the problem by saving the features in a postgresql layer.

Regards,



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-User-f4125267.html
_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user