search layer not visible on map/ nicht sichtbar

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

search layer not visible on map/ nicht sichtbar

Karsten-3-2
Hi everyone,
 
working with mapbender3 I have configured a search (Flurstücksuche with PostNAS data). Overall this is working as expected, however the search results are not shown on teh map as highlight layer. I already had this working at one point earlier in the project but don't know which change made this break.
Would anyone have suggestions on how to debug this ?
 
Cheers
Karsten
--------------------------
 
Hallo Allerseits,
 
ich habe mit Mapbender3 eine Suche (Flurstücksuche mit PostNAS daten) konfiguriert die wie gewollt funktioniert. Allerdings erscheinen auf der Karte die Suchergebnisse nicht als Highlight Grafikebene. Ich hatte dies irgendwann einmal im projekt schon am laufen, weiß aber nicht welche Änderungen diese Funktionalität lahmgelegt haben kann.
Weiß jemand wie ich das am besten debuggen kann ? 

Grüße
Karsten
 

_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: search layer not visible on map/ nicht sichtbar

Astrid Emde (WhereGroup)
Hello Karsten,

you should use the app_dev.php mode and inspect the results with F12.

If I understand you right, you get a list of results listed in the
SearchRouter, but when you klick on the result it is not shown in the
map.

Often it is a problem of projection. SearchRouter is not able to
transform. So your SearchRouter has to provide the same projection as
the application.

Astrid

Am 2018-06-21 21:05, schrieb karsten:

> Hi everyone,
>
> working with mapbender3 I have configured a search (Flurstücksuche
> with PostNAS data). Overall this is working as expected, however the
> search results are not shown on teh map as highlight layer. I already
> had this working at one point earlier in the project but don't know
> which change made this break.
> Would anyone have suggestions on how to debug this ?
>
> Cheers
> Karsten
> --------------------------
>
> Hallo Allerseits,
>
> ich habe mit Mapbender3 eine Suche (Flurstücksuche mit PostNAS daten)
> konfiguriert die wie gewollt funktioniert. Allerdings erscheinen auf
> der Karte die Suchergebnisse nicht als Highlight Grafikebene. Ich
> hatte dies irgendwann einmal im projekt schon am laufen, weiß aber
> nicht welche Änderungen diese Funktionalität lahmgelegt haben kann.
> Weiß jemand wie ich das am besten debuggen kann ?
>
> Grüße
> Karsten
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

--
Mit freundlichen Grüßen

Astrid Emde
Senior GIS-Consultant

-----------------------------------
Aufwind durch Wissen!
Qualifizierte Open-Source-Schulungen
bei der www.foss-academy.com
-----------------------------------


  Astrid Emde
  WhereGroup GmbH & Co.KG
  Eifelstraße 7
  53119 Bonn
  Germany

  Fon: +49(0)228 90 90 38 - 22
  Fax: +49(0)228 90 90 38 - 11

  [hidden email]
  www.wheregroup.com

  Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: search layer not visible on map/ nichtsichtbar

Karsten-3-2
Hi Astrid,

>>> you should use the app_dev.php mode and inspect the results with F12.
>>>
Ok will do.

>>> If I understand you right, you get a list of results listed in the
SearchRouter, but when you klick on the result it is not shown in the
map.>>>
Yes correct.

>>> Often it is a problem of projection. SearchRouter is not able to
transform. So your SearchRouter has to provide the same projection as the
application.>>>
Great advice. While I am not aware though where the search router projection
can be set/configured I guess that is the projection the geometry from the
postgis search view delivers. Is that assumption correct ?

Cheers
Karsten




Am 2018-06-21 21:05, schrieb karsten:

> Hi everyone,
>
> working with mapbender3 I have configured a search (Flurstücksuche
> with PostNAS data). Overall this is working as expected, however the
> search results are not shown on teh map as highlight layer. I already
> had this working at one point earlier in the project but don't know
> which change made this break.
> Would anyone have suggestions on how to debug this ?
>
> Cheers
> Karsten
> --------------------------
>
> Hallo Allerseits,
>
> ich habe mit Mapbender3 eine Suche (Flurstücksuche mit PostNAS daten)
> konfiguriert die wie gewollt funktioniert. Allerdings erscheinen auf
> der Karte die Suchergebnisse nicht als Highlight Grafikebene. Ich
> hatte dies irgendwann einmal im projekt schon am laufen, weiß aber
> nicht welche Änderungen diese Funktionalität lahmgelegt haben kann.
> Weiß jemand wie ich das am besten debuggen kann ?
>
> Grüße
> Karsten
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

--
Mit freundlichen Grüßen

Astrid Emde
Senior GIS-Consultant

-----------------------------------
Aufwind durch Wissen!
Qualifizierte Open-Source-Schulungen
bei der www.foss-academy.com
-----------------------------------


  Astrid Emde
  WhereGroup GmbH & Co.KG
  Eifelstraße 7
  53119 Bonn
  Germany

  Fon: +49(0)228 90 90 38 - 22
  Fax: +49(0)228 90 90 38 - 11

  [hidden email]
  www.wheregroup.com

  Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users

_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users
Reply | Threaded
Open this post in threaded view
|

Re: search layer not visible on map/ nichtsichtbar

Karsten-3-2
In reply to this post by Astrid Emde (WhereGroup)
 
The no-show was indeed a projection problem. When I switched the map
projection everything worked fine. Also the search router provided
projection appears to be what the query view provides.

Now a follow up question comes to mind: in my project I have a Spatial
Reference System Selector with multiple entries. Given that the search
router does not reproject what would be a good solution to have the search
router still work when a user switches form the default projection?
My only idea was to come up with a PostGIS custom psql function that would
check the map projection and then accordingly reproject the search router
query ?
Any ideas what would work easiest?

Cheers
Karsten

 
-----Original Message-----
From: karsten [mailto:[hidden email]]
Sent: Friday, June 22, 2018 07:40
To: 'Mapbender User List'
Subject: RE: [Mapbender-users] search layer not visible on map/
nichtsichtbar

Hi Astrid,

>>> you should use the app_dev.php mode and inspect the results with
>>> F12. >>>
Ok will do.

>>> If I understand you right, you get a list of results listed in the
>>> SearchRouter, but when you klick on the result it is not shown in
>>> the map.>>>
Yes correct.

>>> Often it is a problem of projection. SearchRouter is not able to
>>> transform. So your SearchRouter has to provide the same projection
>>> as the application.>>>
Great advice. While I am not aware though where the search router projection
can be set/configured I guess that is the projection the geometry from the
postgis search view delivers. Is that assumption correct ?

Cheers
Karsten




Am 2018-06-21 21:05, schrieb karsten:

> Hi everyone,
>
> working with mapbender3 I have configured a search (Flurstücksuche
> with PostNAS data). Overall this is working as expected, however the
> search results are not shown on teh map as highlight layer. I already
> had this working at one point earlier in the project but don't know
> which change made this break.
> Would anyone have suggestions on how to debug this ?
>
> Cheers
> Karsten
> --------------------------
>
> Hallo Allerseits,
>
> ich habe mit Mapbender3 eine Suche (Flurstücksuche mit PostNAS daten)
> konfiguriert die wie gewollt funktioniert. Allerdings erscheinen auf
> der Karte die Suchergebnisse nicht als Highlight Grafikebene. Ich
> hatte dies irgendwann einmal im projekt schon am laufen, weiß aber
> nicht welche Änderungen diese Funktionalität lahmgelegt haben kann.
> Weiß jemand wie ich das am besten debuggen kann ?
>
> Grüße
> Karsten
> _______________________________________________
> Mapbender_users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_users

--
Mit freundlichen Grüßen

Astrid Emde
Senior GIS-Consultant

-----------------------------------
Aufwind durch Wissen!
Qualifizierte Open-Source-Schulungen
bei der www.foss-academy.com
-----------------------------------


  Astrid Emde
  WhereGroup GmbH & Co.KG
  Eifelstraße 7
  53119 Bonn
  Germany

  Fon: +49(0)228 90 90 38 - 22
  Fax: +49(0)228 90 90 38 - 11

  [hidden email]
  www.wheregroup.com

  Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users

_______________________________________________
Mapbender_users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_users