request_to_localhost

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

request_to_localhost

robert_1
Dear List,

i want to make a web-map-application (ms4w, chameleon) available for browser (and local client) requests (GetMap, GetCapabilities, GetFeatureInfo).

Using in Firefox the URL
http://localhost:8080/cgi-bin/mapserv.exe?VERSION=1.1.1.&SERVICE=WMS&Request=GetMap&LAYERS=NSG&FORMAT=image/png&map=C:/ms4w/apps/chameleon/samples/map/world_wms.map&FORMAT=image/png

response:
 <?xml version="1.0" encoding="ISO-8859-1" standalone="no" ?>
  <!DOCTYPE ServiceExceptionReport (View Source for full doctype...)>
- <ServiceExceptionReport version="1.1.1">
  <ServiceException>msOWSParseVersionString(): WMS server error. Invalid version (1.1.1.). OWS version must be in the format 'x.y' or 'x.y.z'</ServiceException>
  </ServiceExceptionReport>

the access.log states:
0.0.0.0 - - [03/Dec/2007:12:53:32 +0100] "GET /cgi-bin/mapserv.exe?VERSION=1.1.1.&SERVICE=WMS&Request=GetMap&LAYERS=NSG&FORMAT=image/png&map=C:/ms4w/apps/chameleon/samples/map/world_wms.map&FORMAT=image/png HTTP/1.1" 200 405

error.log:
        empty

Do I have to make some configuration at apache, mapserver?
The application works great but with cascading layers (http://localhost:8080/chameleon/samples/sample_ogc.phtml)!

Any ideas are welcome.
Thanks in advance,
Robert




-----------------------------------------
Robert Buchholz
Sachbearbeiter (Trainee)
Referat GIS-Zentrale
Seeburger Chaussee 2
Landesumweltamt Brandenburg
Postanschrift: 14476 Potsdam
Besucheranschrift: Seeburger Chaussee 2, 14476 Potsdam
Tel.: (033201)-442-127
Mail: [hidden email]
Internet: http://www.brandenburg.de/lua
Kein Zugang für elektronisch signierte sowie für verschlüsselte elektronische Daten.
-----------------------------------------

_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

AW: request_to_localhost

robert_1
Hey Andre,

I did find the right request for getmap to my localhost application!
http://localhost:8080/cgi-bin/mapserv.exe?VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&FORMAT=image/png&LAYERS=NSG&map=C:/ms4w/apps/chameleon/samples/map/world_wms.map&SRS=EPSG:25833&BBOX=3240000,5670000,3484000,5950000&WIDTH=450&HEIGHT=300&STYLES=default

This brings back a map in the browser.
But thanks a lot...that was quite motivating.

Robert
 

-----Ursprüngliche Nachricht-----
Von: Andre van Atten [mailto:[hidden email]]
Gesendet: Montag, 3. Dezember 2007 14:46
An: Buchholz, Robert
Betreff: RE: [ms4w-users] request_to_localhost

Robert,

Looks to me that you use a point to much. Use VERSION=1.1.1 instead of VERSION=1.1.1.

Andre

-----Oorspronkelijk bericht-----
Van: [hidden email] [mailto:[hidden email]] Namens Buchholz, Robert
Verzonden: maandag 3 december 2007 13:31
Aan: [hidden email]
Onderwerp: [ms4w-users] request_to_localhost

Dear List,

i want to make a web-map-application (ms4w, chameleon) available for browser (and local client) requests (GetMap, GetCapabilities, GetFeatureInfo).

Using in Firefox the URL
http://localhost:8080/cgi-bin/mapserv.exe?VERSION=1.1.1.&SERVICE=WMS&Request=GetMap&LAYERS=NSG&FORMAT=image/png&map=C:/ms4w/apps/chameleon/samples/map/world_wms.map&FORMAT=image/png

response:
 <?xml version="1.0" encoding="ISO-8859-1" standalone="no" ?>
  <!DOCTYPE ServiceExceptionReport (View Source for full doctype...)>
- <ServiceExceptionReport version="1.1.1">
  <ServiceException>msOWSParseVersionString(): WMS server error. Invalid version (1.1.1.). OWS version must be in the format 'x.y' or 'x.y.z'</ServiceException>
  </ServiceExceptionReport>

the access.log states:
0.0.0.0 - - [03/Dec/2007:12:53:32 +0100] "GET /cgi-bin/mapserv.exe?VERSION=1.1.1.&SERVICE=WMS&Request=GetMap&LAYERS=NSG&FORMAT=image/png&map=C:/ms4w/apps/chameleon/samples/map/world_wms.map&FORMAT=image/png HTTP/1.1" 200 405

error.log:
        empty

Do I have to make some configuration at apache, mapserver?
The application works great but with cascading layers (http://localhost:8080/chameleon/samples/sample_ogc.phtml)!

Any ideas are welcome.
Thanks in advance,
Robert




-----------------------------------------
Robert Buchholz
Sachbearbeiter (Trainee)
Referat GIS-Zentrale
Seeburger Chaussee 2
Landesumweltamt Brandenburg
Postanschrift: 14476 Potsdam
Besucheranschrift: Seeburger Chaussee 2, 14476 Potsdam
Tel.: (033201)-442-127
Mail: [hidden email]
Internet: http://www.brandenburg.de/lua
Kein Zugang für elektronisch signierte sowie für verschlüsselte elektronische Daten.
-----------------------------------------

_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users

_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

Re: request_to_localhost

Jeff McKenna-2
In reply to this post by robert_1
Check your 'VERSION=' parameter, you have an extra dot in it...it should
be 'VERSION=1.1.1&SERVICE=....'

-jeff




Buchholz, Robert wrote:

> Dear List,
>
> i want to make a web-map-application (ms4w, chameleon) available for browser (and local client) requests (GetMap, GetCapabilities, GetFeatureInfo).
>
> Using in Firefox the URL
> http://localhost:8080/cgi-bin/mapserv.exe?VERSION=1.1.1.&SERVICE=WMS&Request=GetMap&LAYERS=NSG&FORMAT=image/png&map=C:/ms4w/apps/chameleon/samples/map/world_wms.map&FORMAT=image/png
>
> response:
>  <?xml version="1.0" encoding="ISO-8859-1" standalone="no" ?>
>   <!DOCTYPE ServiceExceptionReport (View Source for full doctype...)>
> - <ServiceExceptionReport version="1.1.1">
>   <ServiceException>msOWSParseVersionString(): WMS server error. Invalid version (1.1.1.). OWS version must be in the format 'x.y' or 'x.y.z'</ServiceException>
>   </ServiceExceptionReport>
>
> the access.log states:
> 0.0.0.0 - - [03/Dec/2007:12:53:32 +0100] "GET /cgi-bin/mapserv.exe?VERSION=1.1.1.&SERVICE=WMS&Request=GetMap&LAYERS=NSG&FORMAT=image/png&map=C:/ms4w/apps/chameleon/samples/map/world_wms.map&FORMAT=image/png HTTP/1.1" 200 405
>
> error.log:
> empty
>
> Do I have to make some configuration at apache, mapserver?
> The application works great but with cascading layers (http://localhost:8080/chameleon/samples/sample_ogc.phtml)!
>
> Any ideas are welcome.
> Thanks in advance,
> Robert
>
>
>
--
Jeff McKenna
DM Solutions Group Inc.
http://www.dmsolutions.ca
_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

Re: request_to_localhost

Hernan Angelini
In reply to this post by robert_1
 
Version = 1.1.1. You must remove the last point
"version = 1.1.1&"
and quit the second FORMAT=image/png




_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users