r.hazard.flood is not running in windows7( Grass 6.5)

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

r.hazard.flood is not running in windows7( Grass 6.5)

SWAPAN GHOSH
Dear all,

I succesfully the module r.hazards.flood.py in windows xp but fail in windows 7.

Please help me.

Regards,

Swapan Ghosh

_______________________________________________
grass-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-dev
Reply | Threaded
Open this post in threaded view
|

Re: r.hazard.flood is not running in windows7( Grass 6.5)

madi
Hi Swapan,


On Sun, Jul 20, 2014 at 10:47 PM, Swapan Ghosh <[hidden email]> wrote:
Dear all,

I succesfully the module r.hazards.flood.py in windows xp but fail in windows 7.

how does it fail? do you get any error messages? do you have the dependencies installed (r.area) ?
which revision of grass are you using?
standalone or osgeo4w?
have you tried also running it on grass 6.4.4 and/or nightly build 7.0.0?

Please let us know.

cheers,
madi



--
Best regards,

Dr. Margherita DI LEO    
Scientific / technical project officer

European Commission - DG JRC 
Institute for Environment and Sustainability (IES)
Via Fermi, 2749
I-21027 Ispra (VA) - Italy - TP 261
       
Tel. +39 0332 78 3600   

Disclaimer: The views expressed are purely those of the writer and may not in any circumstance be regarded as stating an official position of the European Commission.

_______________________________________________
grass-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-dev
Reply | Threaded
Open this post in threaded view
|

Re: r.hazard.flood is not running in windows7( Grass 6.5)

Helmut Kudrnovsky
In reply to this post by SWAPAN GHOSH
SWAPAN GHOSH wrote
Dear all,

I succesfully the module r.hazards.flood.py in windows xp but fail in
windows 7.

Please help me.

Regards,

Swapan Ghosh

_______________________________________________
grass-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-dev
please provide more information how and what fails?

did you set the region right, e.g.

g.region -p -a rast=elevation@PERMANENT align=elevation@PERMANENT

tested here with

System Info
GRASS Version: 6.4.5svn                                                        
GRASS SVN Revision: 61153                                                      
GDAL/OGR: 1.11.0                                                                
PROJ4: Rel. 4.8.0, 6 March 2012                                                
Python: 2.7.4                                                                  
wxPython: 2.8.12.1                                                              
Platform: Windows-Vista-6.0.6002-SP2 (OSGeo4W)

(Mon Jul 21 11:47:06 2014)                                                      
r.hazard.flood --verbose map=elevation@PERMANENT flood=FLOOD mti=MTI  
[...]
Done.
(Mon Jul 21 11:47:25 2014) Befehl ausgeführt (18 Sek)

System Info                                                                    
GRASS Version: 7.0.0svn                                                        
GRASS SVN Revision: 61281                                                      
Erstellungsdatum: 2014-07-21                                                    
Build Platform: i686-pc-mingw32                                                
GDAL/OGR: 1.11.0                                                                
PROJ.4: 4.8.0                                                                  
GEOS: 3.4.2                                                                    
SQLite: 3.7.17                                                                  
Python: 2.7.4                                                                  
wxPython: 2.8.12.1                                                              
Platform: Windows-Vista-6.0.6002-SP2 (OSGeo4W)  

(Mon Jul 21 11:51:42 2014)                                                      
r.hazard.flood --verbose map=elevation@PERMANENT flood=FLOOD mti=MTI
[...]
Done.
(Mon Jul 21 11:51:57 2014) Befehl ausgeführt (15 Sek)

r.hazard.flood in winGRASS6.4.5svn and winGRASS7.0.0svn works.
best regards
Helmut
Reply | Threaded
Open this post in threaded view
|

Re: r.hazard.flood is not running in windows7( Grass 6.5)

SWAPAN GHOSH
Actually, it needs external python installation.
I solve it...........
but my question is that.........why we need external py install.....other wise get the following message
Inline image 1

Regards,

Swapan Ghosh


On Mon, Jul 21, 2014 at 3:28 PM, Helmut Kudrnovsky <[hidden email]> wrote:
SWAPAN GHOSH wrote
> Dear all,
>
> I succesfully the module r.hazards.flood.py in windows xp but fail in
> windows 7.
>
> Please help me.
>
> Regards,
>
> Swapan Ghosh
>
> _______________________________________________
> grass-dev mailing list

> grass-dev@.osgeo

> http://lists.osgeo.org/mailman/listinfo/grass-dev

please provide more information how and what fails?

did you set the region right, e.g.

g.region -p -a rast=elevation@PERMANENT align=elevation@PERMANENT

tested here with

System Info
GRASS Version: 6.4.5svn
GRASS SVN Revision: 61153
GDAL/OGR: 1.11.0
PROJ4: Rel. 4.8.0, 6 March 2012
Python: 2.7.4
wxPython: 2.8.12.1
Platform: Windows-Vista-6.0.6002-SP2 (OSGeo4W)

(Mon Jul 21 11:47:06 2014)
r.hazard.flood --verbose map=elevation@PERMANENT flood=FLOOD mti=MTI
[...]
Done.
(Mon Jul 21 11:47:25 2014) Befehl ausgeführt (18 Sek)

System Info
GRASS Version: 7.0.0svn
GRASS SVN Revision: 61281
Erstellungsdatum: 2014-07-21
Build Platform: i686-pc-mingw32
GDAL/OGR: 1.11.0
PROJ.4: 4.8.0
GEOS: 3.4.2
SQLite: 3.7.17
Python: 2.7.4
wxPython: 2.8.12.1
Platform: Windows-Vista-6.0.6002-SP2 (OSGeo4W)

(Mon Jul 21 11:51:42 2014)
r.hazard.flood --verbose map=elevation@PERMANENT flood=FLOOD mti=MTI
[...]
Done.
(Mon Jul 21 11:51:57 2014) Befehl ausgeführt (15 Sek)

r.hazard.flood in winGRASS6.4.5svn and winGRASS7.0.0svn works.



-----
best regards
Helmut
--
View this message in context: http://osgeo-org.1560.x6.nabble.com/r-hazard-flood-is-not-running-in-windows7-Grass-6-5-tp5152002p5152074.html
Sent from the Grass - Dev mailing list archive at Nabble.com.
_______________________________________________
grass-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-dev


_______________________________________________
grass-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-dev
Reply | Threaded
Open this post in threaded view
|

Re: r.hazard.flood is not running in windows7( Grass 6.5)

Helmut Kudrnovsky
>Actually, it needs external python installation.
>I solve it...........
>but my question is that.........why we need external py install.....other wise get the following message

first, please don't use winGRASS 6.5, it's some kind of abandoned and not meant for productive use.

so try winGRASS 6.4.5svn (latest stable in the 6.4-series) or winGRASS 7.0.0svn (first stable in the 7.0-series) first before installing an external python.

an external python isn't normally necessary, but sometimes there are some glitches with windows and python.

AFAICT the best thing is to use winGRASS within the OSGe4W-framework (http://trac.osgeo.org/osgeo4w/).

for example the tests mentioned before by me are done in the OSGe4W-framework without any external python installation.

in summary this isn't a r.hazard.flood issue, but a windows-python quirk ...
best regards
Helmut
Reply | Threaded
Open this post in threaded view
|

Re: r.hazard.flood is not running in windows7( Grass 6.5)

SWAPAN GHOSH
Dear all,

Thank you very much for the help.

Swapan


On Mon, Jul 21, 2014 at 4:29 PM, Helmut Kudrnovsky <[hidden email]> wrote:
>Actually, it needs external python installation.
>I solve it...........
>but my question is that.........why we need external py install.....other
wise get the following message

first, please don't use winGRASS 6.5, it's some kind of abandoned and not
meant for productive use.

so try winGRASS 6.4.5svn (latest stable in the 6.4-series) or winGRASS
7.0.0svn (first stable in the 7.0-series) first before installing an
external python.

an external python isn't normally necessary, but sometimes there are some
glitches with windows and python.

AFAICT the best thing is to use winGRASS within the OSGe4W-framework
(http://trac.osgeo.org/osgeo4w/).

for example the tests mentioned before by me are done in the
OSGe4W-framework without any external python installation.

in summary this isn't a r.hazard.flood issue, but a windows-python quirk ...



-----
best regards
Helmut
--
View this message in context: http://osgeo-org.1560.x6.nabble.com/r-hazard-flood-is-not-running-in-windows7-Grass-6-5-tp5152002p5152094.html
Sent from the Grass - Dev mailing list archive at Nabble.com.
_______________________________________________
grass-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-dev


_______________________________________________
grass-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-dev