problems with d.mon windows

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

problems with d.mon windows

Tyler Smith-2
Hi,

I've been having some problems interacting with graphics windows. I'm
using Grass version 7.2.0, installed from the Debian repository.
Starting from the command line this happens:

grass -text

GRASS 7.2.0 (ecozones):~ > d.mon start=wx0
GRASS 7.2.0 (ecozones):~ > Failed to import the site module
Traceback (most recent call last):
  File "/usr/lib/python3.5/site.py", line 580, in <module>
    main()
  File "/usr/lib/python3.5/site.py", line 566, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib/python3.5/site.py", line 287, in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib/python3.5/site.py", line 263, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib/python3.5/site.py", line 253, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib/python3.5/sysconfig.py", line 595, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib/python3.5/sysconfig.py", line 538, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib/python3.5/sysconfig.py", line 410, in _init_posix
    from _sysconfigdata import build_time_vars
  File "/usr/lib/python3.5/_sysconfigdata.py", line 6, in <module>
    from _sysconfigdata_m import *
ImportError: No module named '_sysconfigdata_m'

At this point, GRASS thinks wx0 is running:

GRASS 7.2.0 (ecozones):~ > d.mon -l
List of running monitors:
wx0

But I can't see it anywhere.

Yesterday I was able to get wx0 started, but I got strange and
inconsistent errors with the d.what.vect interface (i.e., clicking on
the icon in the window then clicking on a vector object in the window).
I can't reproduce that anymore as now I can't even get the monitor
started.

Have I broken something? How can I get my map windows back?

Thanks,

Tyler

--
plantarum.ca
_______________________________________________
grass-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: problems with d.mon windows

Tyler Smith-2
On Tue, May 2, 2017, at 12:05 PM, Tyler Smith wrote:

> I've been having some problems interacting with graphics windows. I'm
> using Grass version 7.2.0, installed from the Debian repository.
> Starting from the command line this happens:
>
> grass -text
>
> GRASS 7.2.0 (ecozones):~ > d.mon start=wx0
> GRASS 7.2.0 (ecozones):~ > Failed to import the site module
> Traceback (most recent call last):
>   File "/usr/lib/python3.5/site.py", line 580, in <module>
>     main()

Realizing that these are python errors, I recalled that I have installed
a non-Debian (i.e., miniconda) version of Python that sits at the front
of my path. Adding `export GRASS_PYTHON=python2.7` to my .bashrc seems
to correct this issue. I have both the Debian python3.5 and the
miniconda python3.5, but using either as the value of GRASS_PYTHON
causes problems.

So I have solved my own problem, unless there will be new issues arising
from using python2.7 instead of python3+?

Thanks for your patience.

Tyler
_______________________________________________
grass-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-user