[postgis] postgis build fails

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[postgis] postgis build fails

James Reid
hi ! Im trying to buils postgis 0.6.2 on posgresql-7.2b3 on a solaris 8 box with gcc and gmake - postgres is installed and working and Ive breated pl/pgsql but when I run a make on postgis it complains along the lines of the following:

postgis_ops.c: In function `ggeometry_compress':
postgis_ops.c:826: structure has no member named `pred'
postgis_ops.c:836: structure has no member named `pred'
postgis_ops.c:842: structure has no member named `pred'
postgis_ops.c:848: warning: assignment makes integer from pointer without a cast
postgis_ops.c:852: warning: assignment makes integer from pointer without a cast
postgis_ops.c: In function `ggeometry_consistent':
postgis_ops.c:876: structure has no member named `pred'
postgis_ops.c:881: structure has no member named `pred'
postgis_ops.c:887: structure has no member named `pred'
postgis_ops.c: In function `rtree_union':
postgis_ops.c:1060: structure has no member named `pred'
postgis_ops.c:1065: structure has no member named `pred'
postgis_ops.c: In function `rtree_penalty':
postgis_ops.c:1086: structure has no member named `pred'
postgis_ops.c:1086: structure has no member named `pred'
postgis_ops.c:1090: structure has no member named `pred'
postgis_ops.c: In function `rtree_picksplit':
postgis_ops.c:1130: structure has no member named `pred'
postgis_ops.c:1132: structure has no member named `pred'
postgis_ops.c:1177: structure has no member named `pred'
postgis_ops.c:1179: structure has no member named `pred'
postgis_ops.c:1183: structure has no member named `pred'
postgis_ops.c:1185: structure has no member named `pred'
postgis_ops.c:1223: structure has no member named `pred'
postgis_ops.c:1248: warning: assignment makes integer from pointer without a cast
postgis_ops.c:1249: warning: assignment makes integer from pointer without a cast
make: *** [postgis_ops.o] Error 1


any thoughts?

[hidden email]

"Every program has two purposes -- one for which it was written and another for which it wasn't. "


------------------------ Yahoo! Groups Sponsor ---------------------~-->
Unlimited calling with 3-way conferencing. Only $1/Mo.
with CrystalVoice! FREE trial. Click Here.
http://us.click.yahoo.com/Hb1xVB/HxbDAA/ySSFAA/PhFolB/TM
---------------------------------------------------------------------~->

To unsubscribe from this group, send an email to:
[hidden email]

 

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 



Reply | Threaded
Open this post in threaded view
|

RE: [postgis] postgis build fails

Norman Vine
James Reid writes:
>
>hi ! Im trying to buils postgis 0.6.2 on posgresql-7.2b3 on a
>solaris 8 box with gcc and gmake - postgres is installed and
>working and Ive breated pl/pgsql but when I run a make on
>postgis it complains along the lines of the following:

hmm... Aren't you rushing things a bit :-)

according to
http://postgis.refractions.net/docs/c55.html

"PostGIS 0.6 has been built and tested against PostgreSQL 7.1.2.
 ii will probably work with any of the 7.1.x versions.
 It will not work with any version prior to 7.1,
 or with version 7.2 (not yet released at date of writing).
 The next version, PostGIS 0.7, will work with PostgreSQL version 7.2."

Cheers

Norman

------------------------ Yahoo! Groups Sponsor ---------------------~-->
Unlimited calling with 3-way conferencing. Only $1/Mo.
with CrystalVoice! FREE trial. Click Here.
http://us.click.yahoo.com/Hb1xVB/HxbDAA/ySSFAA/PhFolB/TM
---------------------------------------------------------------------~->

To unsubscribe from this group, send an email to:
[hidden email]

 

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 



Reply | Threaded
Open this post in threaded view
|

RE: [postgis] postgis build fails

James Reid
as a sequel to my earlier problem building postgis... I'm now running postgresql 7.1.3. with postgis0.6.2 but on trying to load postgis.sql to my database i get the following:

ERROR:  OperatorDef: function 'postgis_gist_sel(opaque, oid, opaque, int4)' does not exist
ERROR:  OperatorDef: function 'postgis_gist_sel(opaque, oid, opaque, int4)' does not exist

can anybody help (with a thanks to Norman Vine for spotting my deliberate mistake in my earlier post!!)



E-mail: [hidden email]                  

"Every program has two purposes --
one for which it was written and another for which it wasn't. "


------------------------ Yahoo! Groups Sponsor ---------------------~-->
Unlimited PC-PC calling at Crystal Voice! - Only $1/Mo.
Download your free 30 day trial. Click here.
http://us.click.yahoo.com/Gb1xVB/GxbDAA/ySSFAA/PhFolB/TM
---------------------------------------------------------------------~->

To unsubscribe from this group, send an email to:
[hidden email]

 

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/