[postgis] Itemquery in postgis

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[postgis] Itemquery in postgis

Ross.Searle
Hi,

I'm trying to retrieve records from a large table in postgres through an
itemquery in mapserver. It appears as if mapserver doesn't utilise the index
for the table as the same query run directly in postgres takes approximately
1 sec whereas the same query through mapserver takes forever. Has anyone got
any clues as to what might be going on

Thanks
Ross


************************************************************************
The information in this e-mail together with any attachments is
intended only for the person or entity to which it is addressed
and may contain confidential and/or privileged material.

Any form of review, disclosure, modification, distribution
and/or publication of this e-mail message is prohibited.  

If you have received this message in error, you are asked to
inform the sender as quickly as possible and delete this message
and any copies of this message from your computer and/or your
computer system network.  
************************************************************************

------------------------ Yahoo! Groups Sponsor ---------------------~-->
FREE COLLEGE MONEY
CLICK HERE to search
600,000 scholarships!
http://us.click.yahoo.com/47cccB/4m7CAA/ySSFAA/PhFolB/TM
---------------------------------------------------------------------~->

To unsubscribe from this group, send an email to:
[hidden email]

 

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 



Reply | Threaded
Open this post in threaded view
|

Re: [postgis] Itemquery in postgis

Paul Ramsey-2
Hm, does it take literally "forever" or does it just take a very very
long time? An index on the attribute value you are searching is a good
idea too... itemquery is something we haven't tested, so I bet there is
something amiss in the code.

[hidden email] wrote:

>
> Hi,
>
> I'm trying to retrieve records from a large table in postgres through an
> itemquery in mapserver. It appears as if mapserver doesn't utilise the index
> for the table as the same query run directly in postgres takes approximately
> 1 sec whereas the same query through mapserver takes forever. Has anyone got
> any clues as to what might be going on
>
> Thanks
> Ross
>
> ************************************************************************
> The information in this e-mail together with any attachments is
> intended only for the person or entity to which it is addressed
> and may contain confidential and/or privileged material.
>
> Any form of review, disclosure, modification, distribution
> and/or publication of this e-mail message is prohibited.
>
> If you have received this message in error, you are asked to
> inform the sender as quickly as possible and delete this message
> and any copies of this message from your computer and/or your
> computer system network.
> ************************************************************************
>
>
> To unsubscribe from this group, send an email to:
> [hidden email]
>
>
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

------------------------ Yahoo! Groups Sponsor ---------------------~-->
Secure your servers with 128-bit SSL encryption! Grab your copy of VeriSign's FREE Guide: "Securing Your Web Site for Business." Get it Now!
http://us.click.yahoo.com/n7RbFC/zhwCAA/yigFAA/PhFolB/TM
---------------------------------------------------------------------~->

To unsubscribe from this group, send an email to:
[hidden email]

 

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/