ossimFeatherMosaic artifacts

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ossimFeatherMosaic artifacts

jono
Team OSSIM-

I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.

Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.

The data are obliques from an Applanix system.

Any thoughts?

Jon

------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer

feather_artifact.jpg (103K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ossimFeatherMosaic artifacts

Oscar Kramer
Jon,

Is it only ossimFeatherMosaic where you see that? Try with ossimBlendMosaic and change the tile size to see what happens.

Oscar



From: Jon Sellars <[hidden email]>
To: ossim users <[hidden email]>
Sent: Friday, September 23, 2016 10:31 AM
Subject: [OSSIM] ossimFeatherMosaic artifacts

Team OSSIM-

I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.

Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.

The data are obliques from an Applanix system.

Any thoughts?

Jon

------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer



------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ossimFeatherMosaic artifacts

Garrett Potts-5
In reply to this post by jono
Hello Jon:

Also,  if that happens it also could mean that the null pixel value is not thinking it’s not null for the tile overlap.  So the overlap is seen as a lowest value.  So, if this were a 256 color image then the other image is being perceived as a value of 1 and then that is getting blended and forcing a dark image maybe???


Take care

Garrett

> On Sep 23, 2016, at 10:31 AM, Jon Sellars <[hidden email]> wrote:
>
> Team OSSIM-
>
> I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.
>
> Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.
>
> The data are obliques from an Applanix system.
>
> Any thoughts?
>
> Jon
> <feather_artifact.jpg>------------------------------------------------------------------------------
> _______________________________________________
> www.ossim.org
> Ossim-developer mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ossimFeatherMosaic artifacts

jono
In reply to this post by Oscar Kramer
ossimBlendMosaic and ossimClosestToCenterCombiner seem to work. Did notice with those that if the tile_size: gets down to 32x32 a linear artifact and offset appears. See attached and note that isn't the intersection of the two images, that is an offset entirely with in one image outside of the area of overlap. At tile_size of 128x128 or 256x256 it disappears.

On Fri, Sep 23, 2016 at 11:19 AM, Oscar Kramer <[hidden email]> wrote:
Jon,

Is it only ossimFeatherMosaic where you see that? Try with ossimBlendMosaic and change the tile size to see what happens.

Oscar



From: Jon Sellars <[hidden email]>
To: ossim users <[hidden email]>
Sent: Friday, September 23, 2016 10:31 AM
Subject: [OSSIM] ossimFeatherMosaic artifacts

Team OSSIM-

I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.

Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.

The data are obliques from an Applanix system.

Any thoughts?

Jon

------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer




------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer

blend_mos_32x32_tiles.jpg (154K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ossimFeatherMosaic artifacts

jono
In reply to this post by Oscar Kramer
Here is a link to the images and geoms. I built overviews with ossim-img2rr.


Here is the DEM:


Here is the command:

ossim-orthoigen --geo --meters 0.5  --combiner-type ossimFeatherMosaic S2665146*.jpg mos_feather.tif -P ~/ossim/prefs


On Fri, Sep 23, 2016 at 11:19 AM, Oscar Kramer <[hidden email]> wrote:
Jon,

Is it only ossimFeatherMosaic where you see that? Try with ossimBlendMosaic and change the tile size to see what happens.

Oscar



From: Jon Sellars <[hidden email]>
To: ossim users <[hidden email]>
Sent: Friday, September 23, 2016 10:31 AM
Subject: [OSSIM] ossimFeatherMosaic artifacts

Team OSSIM-

I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.

Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.

The data are obliques from an Applanix system.

Any thoughts?

Jon

------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer




------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ossimFeatherMosaic artifacts

David Burken-2
Hi Jon,

Using jpegs could be problematic with nulls as Garrett mentioned...  You could use pixel flipper to fix then retry with maybe tiff format.

Dave


On 09/23/2016 01:56 PM, Jon Sellars wrote:
Here is a link to the images and geoms. I built overviews with ossim-img2rr.


Here is the DEM:


Here is the command:

ossim-orthoigen --geo --meters 0.5  --combiner-type ossimFeatherMosaic S2665146*.jpg mos_feather.tif -P ~/ossim/prefs


On Fri, Sep 23, 2016 at 11:19 AM, Oscar Kramer <[hidden email]> wrote:
Jon,

Is it only ossimFeatherMosaic where you see that? Try with ossimBlendMosaic and change the tile size to see what happens.

Oscar



From: Jon Sellars <[hidden email]>
To: ossim users <[hidden email]>
Sent: Friday, September 23, 2016 10:31 AM
Subject: [OSSIM] ossimFeatherMosaic artifacts

Team OSSIM-

I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.

Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.

The data are obliques from an Applanix system.

Any thoughts?

Jon

------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer





------------------------------------------------------------------------------


_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ossimFeatherMosaic artifacts

jono
Thanks all. I'll try this out next week and report back to the list.

Have a great weekend!

Jon

On Fri, Sep 23, 2016 at 2:51 PM, David Burken <[hidden email]> wrote:
Hi Jon,

Using jpegs could be problematic with nulls as Garrett mentioned...  You could use pixel flipper to fix then retry with maybe tiff format.

Dave


On 09/23/2016 01:56 PM, Jon Sellars wrote:
Here is a link to the images and geoms. I built overviews with ossim-img2rr.


Here is the DEM:


Here is the command:

ossim-orthoigen --geo --meters 0.5  --combiner-type ossimFeatherMosaic S2665146*.jpg mos_feather.tif -P ~/ossim/prefs


On Fri, Sep 23, 2016 at 11:19 AM, Oscar Kramer <[hidden email]> wrote:
Jon,

Is it only ossimFeatherMosaic where you see that? Try with ossimBlendMosaic and change the tile size to see what happens.

Oscar



From: Jon Sellars <[hidden email]>
To: ossim users <[hidden email]>
Sent: Friday, September 23, 2016 10:31 AM
Subject: [OSSIM] ossimFeatherMosaic artifacts

Team OSSIM-

I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.

Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.

The data are obliques from an Applanix system.

Any thoughts?

Jon

------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer





------------------------------------------------------------------------------


_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer



------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ossimFeatherMosaic artifacts

jono
In reply to this post by David Burken-2
Thanks all. Got a bit side tracked, but back on this now. I converted the JPEGs to TIF with GDAL and rescaled the range 10-255 so that there would be no pixels around zero. This resulted in the same behavior. Also went back to a circa ossim 1.7 version and see the same behavior there. 

This only seems to affect our oblique images. Is there something about the trapezoidal shape of the footprint that throws off the feather mosaic? The missing data are always at the top of the ortho-rectified frame, typically in one of the corners.

Thanks!

Jon 

On Fri, Sep 23, 2016 at 2:51 PM, David Burken <[hidden email]> wrote:
Hi Jon,

Using jpegs could be problematic with nulls as Garrett mentioned...  You could use pixel flipper to fix then retry with maybe tiff format.

Dave


On 09/23/2016 01:56 PM, Jon Sellars wrote:
Here is a link to the images and geoms. I built overviews with ossim-img2rr.


Here is the DEM:


Here is the command:

ossim-orthoigen --geo --meters 0.5  --combiner-type ossimFeatherMosaic S2665146*.jpg mos_feather.tif -P ~/ossim/prefs


On Fri, Sep 23, 2016 at 11:19 AM, Oscar Kramer <[hidden email]> wrote:
Jon,

Is it only ossimFeatherMosaic where you see that? Try with ossimBlendMosaic and change the tile size to see what happens.

Oscar



From: Jon Sellars <[hidden email]>
To: ossim users <[hidden email]>
Sent: Friday, September 23, 2016 10:31 AM
Subject: [OSSIM] ossimFeatherMosaic artifacts

Team OSSIM-

I have noticed in a couple of recent builds (linux and mac) that there are artifacts in the output from ossimFeatherMosaic. In the attached image I have the output from feather as a semi-transparent layer over the output from closest to center (the other combiners seem fine) so that the missing areas are apparent.

Have also noticed that the shape, size and location of the missing data changes when I change the tile_size: in my preferences.

The data are obliques from an Applanix system.

Any thoughts?

Jon

------------------------------------------------------------------------------

_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer





------------------------------------------------------------------------------


_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Loading...