[osgeo4w] #574: gdalbuildvrt fails handling wildcards under Win1 1803

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[osgeo4w] #574: gdalbuildvrt fails handling wildcards under Win1 1803

OSGeo4W
#574: gdalbuildvrt fails handling wildcards under Win1 1803
------------------------+---------------------------
Reporter:  Langlaeufer  |      Owner:  osgeo4w-dev@…
    Type:  defect       |     Status:  new
Priority:  major        |  Component:  Package
 Version:               |   Keywords:  GDAL,
------------------------+---------------------------
 After Spring update of Windows 10 (to r1803) gdalbuildvrt fails to handle
 wildcards.

 Behavior.
 computer 1: Programm is running without messages, no output is generated.
 computer 2: programm is running, showing error "missing file", result is
 generated but the first file of each folder is missing. The filename of
 the missing file was only 1 character from the filename of the missed
 file. It seams that a inclomplete string was created by processing the
 wildcard.

 affected version. GDAL comming with QGIS 3.0.x packagees

 it is not a GDAL bug. GISInternals x64 MSVC17 build of GDAL don't show
 this problem.
 I guess the library used for building GDAL binaries is not compatible with
 current version of windows 10.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/574>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #574: gdalbuildvrt fails handling wildcards under Win10 1803 (was: gdalbuildvrt fails handling wildcards under Win1 1803)

OSGeo4W
#574: gdalbuildvrt fails handling wildcards under Win10 1803
------------------------+----------------------------
Reporter:  Langlaeufer  |       Owner:  osgeo4w-dev@…
    Type:  defect       |      Status:  new
Priority:  major        |   Component:  Package
 Version:               |  Resolution:
Keywords:  GDAL,        |
------------------------+----------------------------

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/574#comment:1>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #574: gdalbuildvrt fails handling wildcards under Win10 1803

OSGeo4W
In reply to this post by OSGeo4W
#574: gdalbuildvrt fails handling wildcards under Win10 1803
------------------------+----------------------------
Reporter:  Langlaeufer  |       Owner:  osgeo4w-dev@…
    Type:  defect       |      Status:  new
Priority:  major        |   Component:  Package
 Version:               |  Resolution:
Keywords:  GDAL,        |
------------------------+----------------------------

Comment (by deezx):

 I have the same issue with gdalbuildvrt using Win10 (1803)

 On my machine building the VRT **fails only for the first file of the
 folder in wildcard matching**, other files in same folder are added to the
 VRT. So if I have four tiles in a foulder, the first file produces an
 error, but the other tree files are added. The first file fails, because
 the first filename matching the wildcard is **truncated to a single
 char**, e.g. if the file is **folder/abc.tif** the wildcard
 **folder/*.tif** produces the following error:

     ERROR 4: folder\a: No such file or directory
     Warning 1: Can't open folder\a. Skipping it

 Issue affects all current Windows versions of QGIS (2.18.21, 3.2.0) using
 GDAL 2.2.4 from OSGEO4W build, in Windows 10 (1803), 64bit.

 see:
 https://github.com/OSGeo/gdal/issues/568
 https://issues.qgis.org/issues/19192

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/574#comment:2>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #574: gdalbuildvrt fails handling wildcards under Win10 1803

OSGeo4W
In reply to this post by OSGeo4W
#574: gdalbuildvrt fails handling wildcards under Win10 1803
------------------------+----------------------------
Reporter:  Langlaeufer  |       Owner:  osgeo4w-dev@…
    Type:  defect       |      Status:  new
Priority:  major        |   Component:  Package
 Version:               |  Resolution:
Keywords:  GDAL,        |
------------------------+----------------------------

Comment (by hellik):

 Replying to [comment:2 deezx]:
 > I have the same issue with gdalbuildvrt using Win10 (1803)
 >
 > On my machine building the VRT **fails only for the first file of the
 folder in wildcard matching**, other files in same folder are added to the
 VRT. So if I have four tiles in a foulder, the first file produces an
 error, but the other tree files are added. The first file fails, because
 the first filename matching the wildcard is **truncated to a single
 char**, e.g. if the file is **folder/abc.tif** the wildcard
 **folder/*.tif** produces the following error:
 >
 >     ERROR 4: folder\a: No such file or directory
 >     Warning 1: Can't open folder\a. Skipping it
 >
 > Issue affects all current Windows versions of QGIS (2.18.21, 3.2.0)
 using GDAL 2.2.4 from OSGEO4W build, in Windows 10 (1803), 64bit.
 >
 > see:
 > https://github.com/OSGeo/gdal/issues/568
 > https://issues.qgis.org/issues/19192

 according to this [https://lists.osgeo.org/pipermail/gdal-
 dev/2011-February/027941.html mail]

 {{{
 SETARGV =       $(VCDIR)\lib\setargv.obj
 }}}

 has to be activated in nmake.opt.

 looking the
 [https://download.osgeo.org/osgeo4w/x86_64/release/gdal/gdal-2.2.4-1-src.tar.bz2
 GDAL's OSGeo4W receipe]

 ''nmake64.opt'':

 {{{
 [...]
 SETARGV                 = "$(VCDIR)\lib\amd64\setargv.obj"
 [...]
 }}}

 is activated OSGeo4W's GDAL.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/574#comment:3>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #574: gdalbuildvrt fails handling wildcards under Win10 1803

OSGeo4W
In reply to this post by OSGeo4W
#574: gdalbuildvrt fails handling wildcards under Win10 1803
------------------------+----------------------------
Reporter:  Langlaeufer  |       Owner:  osgeo4w-dev@…
    Type:  defect       |      Status:  closed
Priority:  major        |   Component:  Package
 Version:               |  Resolution:  fixed
Keywords:  GDAL,        |
------------------------+----------------------------
Changes (by jef):

 * status:  new => closed
 * resolution:   => fixed


Comment:

 Yes, the wildcard expansion is done by the runtime (crt) and apparently
 was broken for the 8bit mode (ie. when using main) with the windows
 update, but still works with 16bit (wmain; like GDAL 2.3 and master).
 Fixes in 2.2.4-2.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/574#comment:4>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #574: gdalbuildvrt fails handling wildcards under Win10 1803

OSGeo4W
In reply to this post by OSGeo4W
#574: gdalbuildvrt fails handling wildcards under Win10 1803
------------------------+----------------------------
Reporter:  Langlaeufer  |       Owner:  osgeo4w-dev@…
    Type:  defect       |      Status:  closed
Priority:  major        |   Component:  Package
 Version:               |  Resolution:  fixed
Keywords:  GDAL,        |
------------------------+----------------------------

Comment (by deezx):

 Thanks! I have tested 2.2.4-2 and it works for me!

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/574#comment:5>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev