[osgeo4w] #537: Installer does not update when running the installer from command line

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[osgeo4w] #537: Installer does not update when running the installer from command line

OSGeo4W
#537: Installer does not update when running the installer from command line
-------------------+---------------------------
Reporter:  Chau    |      Owner:  osgeo4w-dev@…
    Type:  defect  |     Status:  new
Priority:  major   |  Component:  Installer
 Version:          |   Keywords:
-------------------+---------------------------
 I have a batch script which I use to daily update my OSGeo installation
 which uses the following commands:

 {{{
 osgeo4w-setup-x86_64.exe ^
     --advanced ^
     --download ^
     --upgrade-also ^
     --autoaccept ^
     --quiet-mode
 }}}
 It seems to correctly download the updated packages but it fails to update
 them afterwards.

 Running the installer manually without selecting anything in the package
 screen and just continue completes the installation using the previously
 downloaded packages.

 I would expect the installer to automatically perform the installation
 after downloading the updated packages - at least that is what I expect
 the '--upgrade-also' to mean.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/537>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #537: Installer does not update when running the installer from command line

OSGeo4W
#537: Installer does not update when running the installer from command line
-------------------+----------------------------
Reporter:  Chau    |       Owner:  osgeo4w-dev@…
    Type:  defect  |      Status:  new
Priority:  major   |   Component:  Installer
 Version:          |  Resolution:
Keywords:          |
-------------------+----------------------------

Comment (by jef):

 `--download` switches from 'download & install' to 'download only'.  So
 leaving out removing it should help.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/537#comment:1>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #537: Installer does not update when running the installer from command line

OSGeo4W
In reply to this post by OSGeo4W
#537: Installer does not update when running the installer from command line
-------------------+----------------------------
Reporter:  Chau    |       Owner:  osgeo4w-dev@…
    Type:  defect  |      Status:  new
Priority:  major   |   Component:  Installer
 Version:          |  Resolution:
Keywords:          |
-------------------+----------------------------

Comment (by Chau):

 I thought the `--download` option was to force download from the internet
 and not local. The `--upgrade-also` kind of makes sense too in that
 regard: Download AND update.

 That aside I have tried removing the `--download` part and the installer
 upgraded my installation (which was already downloaded). I will test if
 both the download and upgrade works without the `--download` option when
 new upgraded packages arrives at OSGeo.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/537#comment:2>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #537: Installer does not update when running the installer from command line

OSGeo4W
In reply to this post by OSGeo4W
#537: Installer does not update when running the installer from command line
-------------------+----------------------------
Reporter:  Chau    |       Owner:  osgeo4w-dev@…
    Type:  defect  |      Status:  closed
Priority:  major   |   Component:  Installer
 Version:          |  Resolution:  fixed
Keywords:          |
-------------------+----------------------------
Changes (by jef):

 * status:  new => closed
 * resolution:   => fixed


Comment:

 `--upgrade-also` not only installs the selected packages, but also upgrade
 the already installed packages.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/537#comment:3>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev