[osgeo4w] #536: QGIS install with OSGeo4W issue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

[osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
#536: QGIS install with OSGeo4W issue
---------------------+-------------------------------
Reporter:  ghuby     |      Owner:  osgeo4w-dev@…
    Type:  defect    |     Status:  new
Priority:  critical  |  Component:  Package
 Version:            |   Keywords:  QGIS, QGIS-Common
---------------------+-------------------------------
 Hello,

 I tried to update a previous QGIS install made using OSGeo4W 64bits to
 2.18.9-1 release.

 Yet the installer fails to complete the install of the package qgis-common
 with a message saying that library gdal201.dll is missing. Now QGIS fails
 to start with the same message.

 This library is not in folder C:\OSGeo4W64\bin. In this folder, I could
 find gdal200.dll and gdal202.dll.

 The installed release of GDAL installed with OSGeo4W is 2.2.0-6.

 Could you please help finding what goes wrong? Did I miss something?

 Do not hesitate to ask if further information is required to understand
 the issue.

 Regards,
 Guillaume.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by jef):

 When did you try this?  The current version is 2.18.10-1.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:1>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by Guillaume Huby):

 Hello,

 It was last week. Yet I just tried with 2.18.10-1 (thanks for the update!)
 and had the same error.

 Is there some additionnal information I can provide?

 Thanks.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:2>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by jef):

 Not reproducable here.  What packages are you selecting?

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:3>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by Guillaume Huby):

 Good idea to have a look at all packages, I found a package named "Gdal
 2.0.1" that was not selected.

 I selected it and proceed to install.

 I had a new error message on qgis-common package (approximate translation
 from french):
 "Entry point of procedure ?mRunningFromBuildDir21810@QgsApplication@@0_NA
 could not be found in library of dynamic links
 C:\OSGEO4~1\apps\qgis\crssync.exe".

 Yet I could start QGIS but I have an error message:
 "Impossible to load PyQGIS [...]".

 UI starts and displays "QGIS 2.18.7" instead of QGIS 2.18.10.

 I selected (I list only main packages, the list is long):
 * gdal 2.2.0-6;
 * setup OSGeo4W 1.0.7-13;
 * shell OSGeo4W 1.0.1-2;
 * grass 7.2.1-1;
 * grass6 6.4.3-5;
 * qgis 2.18.10-1;
 * saga 2.1.2-2;
 * saga-ltr 2.3.2-1;
 * Many gdal packages with release 2.2.0-6;
 * Many QGIS packages with release 2.18.10-1.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:4>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by jef):

 You selected all those?   Selecting "qgis" should be enough.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:5>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by Guillaume Huby):

 I guess many came as dependencies. I use the shell and gdal for command
 line.

 I used saga and grass for tests purposes.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:6>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by Guillaume Huby):

 Hello,

 I made a complete uninstall completed by deleting all C:\OSGeo4W64 files
 and deleting all downloaded package files.

 I downloaded last setup file and make a new install selecting only qgis,
 gdal, setup and shell.

 Install completed without error and QGIS seems to work fine.

 Thanks for your help.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:7>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  new
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------

Comment (by Guillaume Huby):

 I would like to close issue, but I could not find the way to do it.

 Can anyone do it or explain me how to do it?

 Thanks.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:8>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
Reply | Threaded
Open this post in threaded view
|

Re: [osgeo4w] #536: QGIS install with OSGeo4W issue

OSGeo4W
In reply to this post by OSGeo4W
#536: QGIS install with OSGeo4W issue
------------------------------+----------------------------
Reporter:  Guillaume Huby     |       Owner:  osgeo4w-dev@…
    Type:  defect             |      Status:  closed
Priority:  critical           |   Component:  Package
 Version:                     |  Resolution:  worksforme
Keywords:  QGIS, QGIS-Common  |
------------------------------+----------------------------
Changes (by jef):

 * status:  new => closed
 * resolution:   => worksforme


Comment:

 Replying to [comment:8 Guillaume Huby]:
 > I would like to close issue, but I could not find the way to do it.

 > Can anyone do it or explain me how to do it?

 Unfold "Modify ticket", in "Action" tick "resolve as" and select
 "worksforme" and submit.
 But you might not have enough privileges to do that.

--
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/536#comment:9>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

_______________________________________________
osgeo4w-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev