no python support when installing QGIS 3.2 on ubuntu Bionic

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

no python support when installing QGIS 3.2 on ubuntu Bionic

Reginald
Hello,

When I try to install qgis 3.2 on Bionic I get following message after
installation:

PyQt4 kon niet worden geladen.
Python-ondersteuning wordt uitgeschakeld.


Traceback (most recent call last):
  File "", line 1, in
ImportError: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10'
not found (required by
/home/reginald/.local/lib/python3.6/site-packages/PyQt5/QtCore.so)


Python versie:
3.6.5 (default, Apr  1 2018, 05:46:30)
[GCC 7.3.0]

QGIS versie:
3.2.2-Bonn 'Bonn', 2684216

Python pad:
['/usr/share/qgis/python',
'/home/reginald/.local/share/QGIS/QGIS3/profiles/default/python',
'/home/reginald/.local/share/QGIS/QGIS3/profiles/default/python/plugins',
'/usr/share/qgis/python/plugins', '/usr/lib/python36.zip',
'/usr/lib/python3.6', '/usr/lib/python3.6/lib-dynload',
'/home/reginald/.local/lib/python3.6/site-packages',
'/usr/local/lib/python3.6/dist-packages', '/usr/lib/python3/dist-packages']

Any idea how to solve this without breaking ubuntu?

Regards,



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-User-f4125267.html
_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: no python support when installing QGIS 3.2 on ubuntu Bionic

Randal Hale
I noticed that - I believe you can do "sudo apt-get install python-qgis"
and it should work.

Randy


On 09/06/2018 02:57 PM, Reginald wrote:

> Hello,
>
> When I try to install qgis 3.2 on Bionic I get following message after
> installation:
>
> PyQt4 kon niet worden geladen.
> Python-ondersteuning wordt uitgeschakeld.
>
>
> Traceback (most recent call last):
>    File "", line 1, in
> ImportError: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10'
> not found (required by
> /home/reginald/.local/lib/python3.6/site-packages/PyQt5/QtCore.so)
>
>
> Python versie:
> 3.6.5 (default, Apr  1 2018, 05:46:30)
> [GCC 7.3.0]
>
> QGIS versie:
> 3.2.2-Bonn 'Bonn', 2684216
>
> Python pad:
> ['/usr/share/qgis/python',
> '/home/reginald/.local/share/QGIS/QGIS3/profiles/default/python',
> '/home/reginald/.local/share/QGIS/QGIS3/profiles/default/python/plugins',
> '/usr/share/qgis/python/plugins', '/usr/lib/python36.zip',
> '/usr/lib/python3.6', '/usr/lib/python3.6/lib-dynload',
> '/home/reginald/.local/lib/python3.6/site-packages',
> '/usr/local/lib/python3.6/dist-packages', '/usr/lib/python3/dist-packages']
>
> Any idea how to solve this without breaking ubuntu?
>
> Regards,
>
>
>
> --
> Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-User-f4125267.html
> _______________________________________________
> Qgis-user mailing list
> [hidden email]
> List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
> Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: no python support when installing QGIS 3.2 on ubuntu Bionic

Jürgen E. Fischer
In reply to this post by Reginald
Hi Reginald,

On Thu, 06. Sep 2018 at 11:57:49 -0700, Reginald wrote:
> Traceback (most recent call last):
>   File "", line 1, in
> ImportError: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10'
> not found (required by /home/reginald/.local/lib/python3.6/site-packages/PyQt5/QtCore.so)

Looks like you have an PyQt5 installed in your home directory that requires Qt
5.10 while bionic has Qt 5.9.


Jürgen

--
Jürgen E. Fischer           norBIT GmbH             Tel. +49-4931-918175-31
Dipl.-Inf. (FH)             Rheinstraße 13          Fax. +49-4931-918175-50
Software Engineer           D-26506 Norden             http://www.norbit.de
QGIS release manager (PSC)  Germany                    IRC: jef on FreeNode

norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
Rheinstrasse 13, 26506 Norden
GF: Jelto Buurman, HR: Amtsgericht Aurich HRB 100827
Datenschutzerklaerung: https://www.norbit.de/83/

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

signature.asc (844 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: no python support when installing QGIS 3.2 on ubuntu Bionic

Reginald
Yes, I probably will have to wait till the Beaver dies and I can upgrade.
By the way, python-qgis got installed but cannot function due to incorrect
bindings I guess...

Regards,



--
Sent from: http://osgeo-org.1560.x6.nabble.com/QGIS-User-f4125267.html
_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user