ms4w 3.1.4 mapcache

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ms4w 3.1.4 mapcache

hosain.moh00
hello there 
i active mapcache in ms4w 3.1.4 with it's introduction
and run successfully image in tmp folder , in example is openlayers2

but i'd like use mapcache ms4w via openlayers 3 and my code is below

                        new ol.layer.Tile({
                        title: 'Chabahar',    
                        source: new ol.source.TileWMS({
                        params: {
                                          'LAYERS': 'chabahar',
                                          'FORMAT': 'image/png',
                                          'TILED': true
                                     },
                        serverType: 'mapserver'
                                                       })
                                        })  ,


but no image save in tmp directory

do you have some offer?

thanks


_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: ms4w 3.1.4 mapcache

jmckenna
Administrator
Hello Hosain,

This was a very good question. I used your question, configured an
example, and added a wiki page for how to configure MS4W and MapCache in
OpenLayers 3 with my steps:
http://www.ms4w.com/trac/wiki/MapCacheOpenLayers3

You will notice the importance of configuring your <source> properly for
this WMS service in your mapcache.xml file; and also pointing to the
proper MapCache endpoint (/mapcache/) in your OpenLayers3 script.

Please (everyone) feel free to edit this wiki page with corrections,
notes, gotchyas, ideas, everything :)

Thanks for using MS4W.

-jeff


--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/




On 2016-05-19 3:17 AM, hosain mohammadi wrote:

> hello there
> i active mapcache in ms4w 3.1.4 with it's introduction
> and run successfully image in tmp folder , in example is openlayers2
>
> but i'd like use mapcache ms4w via openlayers 3 and my code is below
>
>                         new ol.layer.Tile({
>                         title: 'Chabahar',
>                         source: new ol.source.TileWMS({
>                         url:
> 'http://localhost:100/cgi-bin/mapserv.exe?map=D:/WEB_GIS/code_test/wms/HTML5Application/public_html/chabahar.map&',
>                         params: {
>                                           'LAYERS': 'chabahar',
>                                           'FORMAT': 'image/png',
>                                           'TILED': true
>                                      },
>                         serverType: 'mapserver'
>                                                        })
>                                         })  ,
>
>
> but no image save in tmp directory
>
> do you have some offer?
>
> thanks
>
>

_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users