mod_python "tilecache.py was not found on this server"

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

mod_python "tilecache.py was not found on this server"

markieta
Hi list,

I have a working TileCache cgi here: http://128.100.66.64/cgi-bin/tilecache/tilecache.cgi/1.0.0

but I am unable to run under mod_python: http://128.100.66.64/cgi-bin/tilecache/tilecache.py/1.0.0

httpd.conf
...
LoadModule python_module modules/mod_python.so
...
<Directory "/ms4w/Apache/cgi-bin/TileCache/">

    AddHandler cgi-script .cgi
    Options +ExecCGI

    AllowOverride None
    Order allow,deny
    Allow from all
    AddHandler python-program .py
    PythonHandler TileCache.Service
    PythonOption TileCacheConfig "/ms4w/Apache/cgi-bin/TileCache/tilecache.cfg"
    PythonDebug On
</Directory>


And yes, I've restarted the apache server.

Michael Markieta
GIS Consultant

5 Royal Street
Toronto Ontario Canada  M6N3Z3
416 833 5581  d 416 604 9647
www.spatialanalysis.ca
Find me on LinkedIn


_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache
Reply | Threaded
Open this post in threaded view
|

Re: mod_python "tilecache.py was not found on this server"

markieta
Fixed the problem, however it could be due to any number of the following changes I've made:

1. Installed the Visual C++ 2010 SP1Redistributable Package: http://www.microsoft.com/en-us/download/details.aspx?id=8328 (restart the machine!)
2. Modified the httpd.conf file slightly:

<Directory "/ms4w/Apache/cgi-bin/TileCache/">
    AddHandler cgi-script .cgi
    AddHandler python-program .py
    Options +ExecCGI
    AddHandler python-program .py
    PythonHandler TileCache.Service
    PythonOption TileCacheConfig "/ms4w/Apache/cgi-bin/TileCache/tilecache.cfg"
    PythonPath "['C:/ms4w/Apache/cgi-bin/TileCache'] + sys.path"
    PythonDebug On
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

Michael Markieta
GIS Consultant

5 Royal Street
Toronto Ontario Canada  M6N3Z3
<a href="tel:416%20833%205581" value="+14168335581" target="_blank">416 833 5581  d <a href="tel:416%20604%209647" value="+14166049647" target="_blank">416 604 9647
www.spatialanalysis.ca
Find me on LinkedIn



On Mon, Mar 11, 2013 at 11:27 PM, Michael Markieta <[hidden email]> wrote:
Hi list,

I have a working TileCache cgi here: http://128.100.66.64/cgi-bin/tilecache/tilecache.cgi/1.0.0

but I am unable to run under mod_python: http://128.100.66.64/cgi-bin/tilecache/tilecache.py/1.0.0

httpd.conf
...
LoadModule python_module modules/mod_python.so
...
<Directory "/ms4w/Apache/cgi-bin/TileCache/">

    AddHandler cgi-script .cgi
    Options +ExecCGI

    AllowOverride None
    Order allow,deny
    Allow from all
    AddHandler python-program .py
    PythonHandler TileCache.Service
    PythonOption TileCacheConfig "/ms4w/Apache/cgi-bin/TileCache/tilecache.cfg"
    PythonDebug On
</Directory>


And yes, I've restarted the apache server.

Michael Markieta
GIS Consultant

5 Royal Street
Toronto Ontario Canada  M6N3Z3
<a href="tel:416%20833%205581" value="+14168335581" target="_blank">416 833 5581  d <a href="tel:416%20604%209647" value="+14166049647" target="_blank">416 604 9647
www.spatialanalysis.ca
Find me on LinkedIn



_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache