mapserver with kml

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

mapserver with kml

Ivan Ogasawara
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

Seth G-2
Hi,

Your output image looks like a projection issue. Google Maps use the espg:3857 projection, but your request is asking for SRS=epsg:4326, maybe try changing this?
Also are you trying to return KML or display an image using KML as a data source? If you are trying to return KML you'd need to use WFS rather than WMS which only returns images.

Seth

--
web:http://geographika.co.uk
twitter: @geographika


On Thu, Dec 14, 2017, at 01:33 AM, Ivan Ogasawara wrote:

Dear all,

Anyone knows some tutorial to work with mapserver (wms) and kml?

I am trying to do it .. but with no success.

this is the local url used:


for image/png works fine (tested with leaflet).

Any tips?


Files:
* mapfiles:


Thanks!

My best regards,
Ivan

_______________________________________________
mapserver-users mailing list


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

jratike80
In reply to this post by Ivan Ogasawara

Hi,

 

When you work with WMS the first thing to do is to read the GetCapabilities.

In your case

 

http://172.17.0.2/?map=/maps/dengue-Rio-de-Janeiro.map&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

 

I used version 1.3.0 so that the response will open into the browser automatically.

For KML support you should see a line for KML like here

 

<GetMap>

<Format>image/png</Format>

<Format>application/vnd.google-earth.kml+xml</Format><Format>

 

Do you have KML in the list?  If you do not, try to add into your metadata

“wms_getmap_formatlist”

 

It is documented in http://mapserver.org/ogc/wms_server.html.  Did you just guess or is there somewhere wrong documentation about metadata item you have tried

# "wms_format" "image/png")

 

-Jukka Rahkonen-

 

 

However, you must explicitly add KML into WMS outputformats in the metadata. It seems that you have played with it because you have this line commented out:

 

        # "wms_format" "image/png"

 

 

 

 

Lähettäjä: mapserver-users [mailto:[hidden email]] Puolesta Ivan Ogasawara
Lähetetty: 14. joulukuuta 2017 2:34
Vastaanottaja: [hidden email]
Aihe: [mapserver-users] mapserver with kml

 

 

Dear all,

 

Anyone knows some tutorial to work with mapserver (wms) and kml?

 

I am trying to do it .. but with no success.

 

this is the local url used:

 

 

for image/png works fine (tested with leaflet).

 

Any tips?

 

Files:

* mapfiles:

 

Thanks!

 

My best regards,

Ivan

 

 


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

jratike80
In reply to this post by Seth G-2

Hi Seth,

 

KML is considered as an image format and it should work with WMS and with mode=map http://mapserver.gis.umn.edu/fr/development/rfc/ms-rfc-58.html

 

It seems that KML output has not been developed much since the initial implementation.

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users [mailto:[hidden email]] Puolesta Seth G
Lähetetty: 14. joulukuuta 2017 10:03
Vastaanottaja: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml

 

Hi,

 

Your output image looks like a projection issue. Google Maps use the espg:3857 projection, but your request is asking for SRS=epsg:4326, maybe try changing this?

Also are you trying to return KML or display an image using KML as a data source? If you are trying to return KML you'd need to use WFS rather than WMS which only returns images.

 

Seth

 

--

web:http://geographika.co.uk

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 01:33 AM, Ivan Ogasawara wrote:

 

Dear all,

 

Anyone knows some tutorial to work with mapserver (wms) and kml?

 

I am trying to do it .. but with no success.

 

this is the local url used:

 

 

for image/png works fine (tested with leaflet).

 

Any tips?

 

 

Files:

* mapfiles:

 

 

Thanks!

 

My best regards,

Ivan

 

_______________________________________________

mapserver-users mailing list

 


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

Seth G-2
Interesting!

From the WMS spec: "Graphic element formats include Scalable Vector Graphics (SVG; MIME type “image/svg+xml”) or Web Computer Graphics Metafile (WebCGM; MIME type “image/cgm;Version=4;ProfileId=WebCGM”) formats"

I wonder how many WMS clients would handle KML as a WMS. As it is XML then it would't be accessible from another domain in a web client. 

Ivan's problem looks to be a projection issue only.

Seth

--
web:http://geographika.co.uk
twitter: @geographika


On Thu, Dec 14, 2017, at 10:42 AM, Rahkonen Jukka (MML) wrote:

Hi Seth,

 

KML is considered as an image format and it should work with WMS and with mode=map http://mapserver.gis.umn.edu/fr/development/rfc/ms-rfc-58.html

 

It seems that KML output has not been developed much since the initial implementation.

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users [mailto:[hidden email]] Puolesta Seth G
Lähetetty: 14. joulukuuta 2017 10:03
Vastaanottaja: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml

 

Hi,

 

Your output image looks like a projection issue. Google Maps use the espg:3857 projection, but your request is asking for SRS=epsg:4326, maybe try changing this?

Also are you trying to return KML or display an image using KML as a data source? If you are trying to return KML you'd need to use WFS rather than WMS which only returns images.

 

Seth

 

--

web:http://geographika.co.uk

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 01:33 AM, Ivan Ogasawara wrote:

 

Dear all,

 

Anyone knows some tutorial to work with mapserver (wms) and kml?

 

I am trying to do it .. but with no success.

 

this is the local url used:

 

 

for image/png works fine (tested with leaflet).

 

Any tips?

 

 

Files:

* mapfiles:

 

 

Thanks!

 

My best regards,

Ivan

 

_______________________________________________

mapserver-users mailing list

 



_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

jratike80
In reply to this post by Ivan Ogasawara

Hi,

 

Geoservers have KML output enabled by default so you can have a try with clients.  Test-URL

http://demo.geo-solutions.it/geoserver/wms?REQUEST=GetMap&SERVICE=WMS&VERSION=1.1.1&WIDTH=1373&HEIGHT=840&LAYERS=topp%3Astates&TRANSPARENT=TRUE&FORMAT=application/vnd.google-earth.kml+xml&BBOX=-124.731422,19.49461526802622,-66.969849,54.83308673197378&SRS=EPSG:4326&STYLES=

 

WMS 1.3.0 does not say anything about GetMap formats, just that they must appear in GetCapabilities, and all formats that appear in GetCapabilities must also be usable.

 

-Jukka Rahkonen-

 

Lähettäjä: Seth G [mailto:[hidden email]]
Lähetetty: 14. joulukuuta 2017 14:56
Vastaanottaja: Rahkonen Jukka (MML) <[hidden email]>; [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml

 

Interesting!

 

From the WMS spec: "Graphic element formats include Scalable Vector Graphics (SVG; MIME type “image/svg+xml”) or Web Computer Graphics Metafile (WebCGM; MIME type “image/cgm;Version=4;ProfileId=WebCGM”) formats"

 

I wonder how many WMS clients would handle KML as a WMS. As it is XML then it would't be accessible from another domain in a web client. 

 

Ivan's problem looks to be a projection issue only.

 

Seth

 

--

web:http://geographika.co.uk

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 10:42 AM, Rahkonen Jukka (MML) wrote:

Hi Seth,

 

KML is considered as an image format and it should work with WMS and with mode=map http://mapserver.gis.umn.edu/fr/development/rfc/ms-rfc-58.html

 

It seems that KML output has not been developed much since the initial implementation.

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users [[hidden email]] Puolesta Seth G
Lähetetty: 14. joulukuuta 2017 10:03
Vastaanottaja: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml

 

Hi,

 

Your output image looks like a projection issue. Google Maps use the espg:3857 projection, but your request is asking for SRS=epsg:4326, maybe try changing this?

Also are you trying to return KML or display an image using KML as a data source? If you are trying to return KML you'd need to use WFS rather than WMS which only returns images.

 

Seth

 

--

web:http://geographika.co.uk

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 01:33 AM, Ivan Ogasawara wrote:

 

Dear all,

 

Anyone knows some tutorial to work with mapserver (wms) and kml?

 

I am trying to do it .. but with no success.

 

this is the local url used:

 

 

for image/png works fine (tested with leaflet).

 

Any tips?

 

 

Files:

* mapfiles:

 

 

Thanks!

 

My best regards,

Ivan

 

_______________________________________________

mapserver-users mailing list

 

 


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

Ivan Ogasawara
Dear all, thanks :)

Carlo Ruiz,


Actually, in my case, the input should be shapefile and the outputs gtiff,png and kml.




Jukka Rahkonen, 

> I used version 1.3.0 so that the response will open into the browser automatically.

Great! I changed to v 1.3.0 too

this is my new url request:


> Do you have KML in the list?

yes. Full GetCapabilities xml here: https://pastebin.com/z2myYc5m

> Did you just guess or is there somewhere wrong documentation about metadata item you have tried # "wms_format" "image/png")

I saw it at some page ... but I think I haven't seen any difference (I don't remember so well) .. so I commented this option.

> However, you must explicitly add KML into WMS outputformats in the metadata. It seems that you have played with it because you have this line commented out:

OK .. I added `wms_getmap_formatlist` parameter. I also added `wms_formatlist` to metadata layer

I also change SRS=EPSG:4326 to CRS=CRS:84



Seth,

> Ivan's problem looks to be a projection issue only.

I also added crs:84 .. but the result is the same .. 

KML by specification uses only a single projection, EPSG:4326 (http://www.gdal.org/drv_kml.html)

My shapefile is defined as epsg:4326 too 

The png output works fine ... maybe something in kml conversion is doing wrong ...  


The log about kml request is here: https://pastebin.com/iP4h0wXx



Ivan Ogasawara

2017-12-14 10:08 GMT-04:00 Rahkonen Jukka (MML) <[hidden email]>:

Hi,

 

Geoservers have KML output enabled by default so you can have a try with clients.  Test-URL

http://demo.geo-solutions.it/geoserver/wms?REQUEST=GetMap&SERVICE=WMS&VERSION=1.1.1&WIDTH=1373&HEIGHT=840&LAYERS=topp%3Astates&TRANSPARENT=TRUE&FORMAT=application/vnd.google-earth.kml+xml&BBOX=-124.731422,19.49461526802622,-66.969849,54.83308673197378&SRS=EPSG:4326&STYLES=

 

WMS 1.3.0 does not say anything about GetMap formats, just that they must appear in GetCapabilities, and all formats that appear in GetCapabilities must also be usable.

 

-Jukka Rahkonen-

 

Lähettäjä: Seth G [mailto:[hidden email]]
Lähetetty: 14. joulukuuta 2017 14:56
Vastaanottaja: Rahkonen Jukka (MML) <[hidden email]>; [hidden email]


Aihe: Re: [mapserver-users] mapserver with kml

 

Interesting!

 

From the WMS spec: "Graphic element formats include Scalable Vector Graphics (SVG; MIME type “image/svg+xml”) or Web Computer Graphics Metafile (WebCGM; MIME type “image/cgm;Version=4;ProfileId=WebCGM”) formats"

 

I wonder how many WMS clients would handle KML as a WMS. As it is XML then it would't be accessible from another domain in a web client. 

 

Ivan's problem looks to be a projection issue only.

 

Seth

 

--

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 10:42 AM, Rahkonen Jukka (MML) wrote:

Hi Seth,

 

KML is considered as an image format and it should work with WMS and with mode=map http://mapserver.gis.umn.edu/fr/development/rfc/ms-rfc-58.html

 

It seems that KML output has not been developed much since the initial implementation.

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users [[hidden email]] Puolesta Seth G
Lähetetty: 14. joulukuuta 2017 10:03
Vastaanottaja: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml

 

Hi,

 

Your output image looks like a projection issue. Google Maps use the espg:3857 projection, but your request is asking for SRS=epsg:4326, maybe try changing this?

Also are you trying to return KML or display an image using KML as a data source? If you are trying to return KML you'd need to use WFS rather than WMS which only returns images.

 

Seth

 

--

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 01:33 AM, Ivan Ogasawara wrote:

 

Dear all,

 

Anyone knows some tutorial to work with mapserver (wms) and kml?

 

I am trying to do it .. but with no success.

 

this is the local url used:

 

 

for image/png works fine (tested with leaflet).

 

Any tips?

 

 

Files:

* mapfiles:

 

 

Thanks!

 

My best regards,

Ivan

 

_______________________________________________

mapserver-users mailing list

 

 


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

jratike80

Hi,


The name of the format in the GetCapabilities is

<Format>application/vnd.google-earth.kml+xml</Format>

Use that.


I have never used CRS:84 as CRS and I don't know if it really works. You can stay in WMS version 1.1.1 and SRS=EPSG:4326. Verify first with image/png that GetMap returns a map.


Read 

http://www.mapserver.org/optimization/debugging.html, add MS_ERRORFILE and DEBUG 5 and see what you get.


-Jukka Rahkonen-



Lähettäjä: Ivan Ogasawara <[hidden email]>
Lähetetty: 14. joulukuuta 2017 18:35
Vastaanottaja: Rahkonen Jukka (MML)
Kopio: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml
 
Dear all, thanks :)

Carlo Ruiz,


Actually, in my case, the input should be shapefile and the outputs gtiff,png and kml.




Jukka Rahkonen, 

> I used version 1.3.0 so that the response will open into the browser automatically.

Great! I changed to v 1.3.0 too

this is my new url request:


> Do you have KML in the list?

yes. Full GetCapabilities xml here: https://pastebin.com/z2myYc5m

> Did you just guess or is there somewhere wrong documentation about metadata item you have tried # "wms_format" "image/png")

I saw it at some page ... but I think I haven't seen any difference (I don't remember so well) .. so I commented this option.

> However, you must explicitly add KML into WMS outputformats in the metadata. It seems that you have played with it because you have this line commented out:

OK .. I added `wms_getmap_formatlist` parameter. I also added `wms_formatlist` to metadata layer

I also change SRS=EPSG:4326 to CRS=CRS:84



Seth,

> Ivan's problem looks to be a projection issue only.

I also added crs:84 .. but the result is the same .. 

KML by specification uses only a single projection, EPSG:4326 (http://www.gdal.org/drv_kml.html)

My shapefile is defined as epsg:4326 too 

The png output works fine ... maybe something in kml conversion is doing wrong ...  


The log about kml request is here: https://pastebin.com/iP4h0wXx



Ivan Ogasawara

2017-12-14 10:08 GMT-04:00 Rahkonen Jukka (MML) <[hidden email]>:

Hi,

 

Geoservers have KML output enabled by default so you can have a try with clients.  Test-URL

http://demo.geo-solutions.it/geoserver/wms?REQUEST=GetMap&SERVICE=WMS&VERSION=1.1.1&WIDTH=1373&HEIGHT=840&LAYERS=topp%3Astates&TRANSPARENT=TRUE&FORMAT=application/vnd.google-earth.kml+xml&BBOX=-124.731422,19.49461526802622,-66.969849,54.83308673197378&SRS=EPSG:4326&STYLES=

 

WMS 1.3.0 does not say anything about GetMap formats, just that they must appear in GetCapabilities, and all formats that appear in GetCapabilities must also be usable.

 

-Jukka Rahkonen-

 

Lähettäjä: Seth G [mailto:[hidden email]]
Lähetetty: 14. joulukuuta 2017 14:56
Vastaanottaja: Rahkonen Jukka (MML) <[hidden email]>; [hidden email]


Aihe: Re: [mapserver-users] mapserver with kml

 

Interesting!

 

From the WMS spec: "Graphic element formats include Scalable Vector Graphics (SVG; MIME type “image/svg+xml”) or Web Computer Graphics Metafile (WebCGM; MIME type “image/cgm;Version=4;ProfileId=WebCGM”) formats"

 

I wonder how many WMS clients would handle KML as a WMS. As it is XML then it would't be accessible from another domain in a web client. 

 

Ivan's problem looks to be a projection issue only.

 

Seth

 

--

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 10:42 AM, Rahkonen Jukka (MML) wrote:

Hi Seth,

 

KML is considered as an image format and it should work with WMS and with mode=map http://mapserver.gis.umn.edu/fr/development/rfc/ms-rfc-58.html

 

It seems that KML output has not been developed much since the initial implementation.

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users [[hidden email]] Puolesta Seth G
Lähetetty: 14. joulukuuta 2017 10:03
Vastaanottaja: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml

 

Hi,

 

Your output image looks like a projection issue. Google Maps use the espg:3857 projection, but your request is asking for SRS=epsg:4326, maybe try changing this?

Also are you trying to return KML or display an image using KML as a data source? If you are trying to return KML you'd need to use WFS rather than WMS which only returns images.

 

Seth

 

--

twitter: @geographika

 

 

On Thu, Dec 14, 2017, at 01:33 AM, Ivan Ogasawara wrote:

 

Dear all,

 

Anyone knows some tutorial to work with mapserver (wms) and kml?

 

I am trying to do it .. but with no success.

 

this is the local url used:

 

 

for image/png works fine (tested with leaflet).

 

Any tips?

 

 

Files:

* mapfiles:

 

 

Thanks!

 

My best regards,

Ivan

 

_______________________________________________

mapserver-users mailing list

 

 


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

Ivan Ogasawara

The name of the format in the GetCapabilities is

<Format>application/vnd.google-earth.kml+xml</Format>

Use that.


yes .. this format is in my GetMap/Format  

  <Format>application/vnd.google-earth.kml+xml</Format>

using this format name in url result this error:

  msWMSLoadGetMapParams(): Image handling error. Unsupported output format (application/vnd.google-earth.kml xml).

I think I should use the same value defined on OUTPUTFORMAT/NAME


I have never used CRS:84 as CRS and I don't know if it really works. You can stay in WMS version 1.1.1 and SRS=EPSG:4326. Verify first with image/png that GetMap returns a map.


I have no problem with image/png format  (using 1.1.1 or 1.3.0)

Read 

http://www.mapserver.org/optimization/debugging.html, add MS_ERRORFILE and DEBUG 5 and see what you get.


 These parameter are already defined:

    CONFIG 'ON_MISSING_DATA' 'IGNORE'
    CONFIG 'PROJ_LIB' './conf/'
    CONFIG      "MS_ERRORFILE" "/var/log/mapserver.log"
    CONFIG      "CPL_DEBUG" "ON"
    CONFIG      "PROJ_DEBUG" "ON"
    DEBUG       5

but I couldn't find any important information in the log file ( https://pastebin.com/iP4h0wXx)


this is the proj_lib/conf/ file : https://pastebin.com/AFNKC88Z

My best regards,
Ivan

_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

jratike80
If it is WMS standard compliant it must accept the advertized mime type. That said our KML implementation is not necessarily compliant. There may also be some trouble with parsing the request because + is changed into space. But perhaps it is OK to do so for the query string.

-Jukka Rahkonen-

Lähettäjä: [hidden email]
Lähetetty: ‎14.‎12.‎2017 21:03
Vastaanottaja: [hidden email]
Kopio: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml

The name of the format in the GetCapabilities is

<Format>application/vnd.google-earth.kml+xml</Format>

Use that.


yes .. this format is in my GetMap/Format  

  <Format>application/vnd.google-earth.kml+xml</Format>

using this format name in url result this error:

  msWMSLoadGetMapParams(): Image handling error. Unsupported output format (application/vnd.google-earth.kml xml).

I think I should use the same value defined on OUTPUTFORMAT/NAME


I have never used CRS:84 as CRS and I don't know if it really works. You can stay in WMS version 1.1.1 and SRS=EPSG:4326. Verify first with image/png that GetMap returns a map.


I have no problem with image/png format  (using 1.1.1 or 1.3.0)

Read 

http://www.mapserver.org/optimization/debugging.html, add MS_ERRORFILE and DEBUG 5 and see what you get.


 These parameter are already defined:

    CONFIG 'ON_MISSING_DATA' 'IGNORE'
    CONFIG 'PROJ_LIB' './conf/'
    CONFIG      "MS_ERRORFILE" "/var/log/mapserver.log"
    CONFIG      "CPL_DEBUG" "ON"
    CONFIG      "PROJ_DEBUG" "ON"
    DEBUG       5

but I couldn't find any important information in the log file ( https://pastebin.com/iP4h0wXx)


this is the proj_lib/conf/ file : https://pastebin.com/AFNKC88Z

My best regards,
Ivan

_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

Stephen Woodbridge
In reply to this post by Ivan Ogasawara
Ivan,

The "+" char in the URL is interpreted as a space you have to ecapce
this as %2B

But you should be able to give the OUTPUTFORMAT block an NAME "kml" and
give that the appropriate parameters like:

         EXTENSION "kml"
         MIMETYPE "application/vnd.google-earth.kml+xml"

and whatever other parameters are needed, then request the format "kml"

-Steve W

On 12/14/2017 2:03 PM, Ivan Ogasawara wrote:

>     The name of the format in the GetCapabilities is
>
>     <Format>application/vnd.google-earth.kml+xml</Format>
>
>     Use that.
>
>
> yes .. this format is in my GetMap/Format
>
>    <Format>application/vnd.google-earth.kml+xml</Format>
>
> using this format name in url result this error:
>
>    msWMSLoadGetMapParams(): Image handling error. Unsupported output
> format (application/vnd.google-earth.kml xml).
>
> I think I should use the same value defined on OUTPUTFORMAT/NAME
>
>
>     I have never used CRS:84 as CRS and I don't know if it
>     really works. You can stay in WMS version 1.1.1 and SRS=EPSG:4326.
>     Verify first with image/png that GetMap returns a map.
>
>
> I have no problem with image/png format  (using 1.1.1 or 1.3.0)
>
>     Read
>
>     http://www.mapserver.org/optimization/debugging.html,
>     <http://www.mapserver.org/optimization/debugging.html> add
>     MS_ERRORFILE and DEBUG 5 and see what you get.
>
>
>   These parameter are already defined:
>
>      CONFIG 'ON_MISSING_DATA' 'IGNORE'
>      CONFIG 'PROJ_LIB' './conf/'
>      CONFIG      "MS_ERRORFILE" "/var/log/mapserver.log"
>      CONFIG      "CPL_DEBUG" "ON"
>      CONFIG      "PROJ_DEBUG" "ON"
>      DEBUG       5
>
> but I couldn't find any important information in the log file
> (https://pastebin.com/iP4h0wXx <https://pastebin.com/iP4h0wXx>)
>
>
> this is the proj_lib/conf/ file : https://pastebin.com/AFNKC88Z
>
> My best regards,
> Ivan
>
>
> _______________________________________________
> mapserver-users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapserver-users
>


---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

Ivan Ogasawara
Hi Stephen,

2017-12-14 15:44 GMT-04:00 Stephen Woodbridge <[hidden email]>:
The "+" char in the URL is interpreted as a space you have to ecapce this as %2B

You're right, thanks .. but there is the same issue ...  


But you should be able to give the OUTPUTFORMAT block an NAME "kml" and give that the appropriate parameters like:

        EXTENSION "kml"
        MIMETYPE "application/vnd.google-earth.kml+xml"

and whatever other parameters are needed, then request the format "kml"

yes .. this is the kml outputformat that I am using:

OUTPUTFORMAT
      NAME "kml"
      DRIVER KML
      MIMETYPE "application/vnd.google-earth.kml+xml"
      IMAGEMODE RGBA
      EXTENSION "kml"
      FORMATOPTION 'ATTACHMENT=RIO_DE_JANEIRO.kml'
    END



_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

Ivan Ogasawara
Dear all,

I think the problem is related to this: 

I changed the image width/height ratio and works fine too!

thanks so much!

2017-12-14 18:00 GMT-04:00 Ivan Ogasawara <[hidden email]>:
Hi Stephen,

2017-12-14 15:44 GMT-04:00 Stephen Woodbridge <[hidden email]>:
The "+" char in the URL is interpreted as a space you have to ecapce this as %2B

You're right, thanks .. but there is the same issue ...  


But you should be able to give the OUTPUTFORMAT block an NAME "kml" and give that the appropriate parameters like:

        EXTENSION "kml"
        MIMETYPE "application/vnd.google-earth.kml+xml"

and whatever other parameters are needed, then request the format "kml"

yes .. this is the kml outputformat that I am using:

OUTPUTFORMAT
      NAME "kml"
      DRIVER KML
      MIMETYPE "application/vnd.google-earth.kml+xml"
      IMAGEMODE RGBA
      EXTENSION "kml"
      FORMATOPTION 'ATTACHMENT=RIO_DE_JANEIRO.kml'
    END




_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver with kml

jratike80

Hi,


There is a dark side in closing Mapserver issues just because they are old and still not fixed. Good that you managed to find that closed issue and kame your KML output to work. I am going to re-open the issue and add a link into this mail thread.


-Jukka Rahkonen-


Lähettäjä: mapserver-users <[hidden email]> käyttäjän puolestaIvan Ogasawara <[hidden email]>
Lähetetty: 16. joulukuuta 2017 1:06
Vastaanottaja: Stephen Woodbridge
Kopio: [hidden email]
Aihe: Re: [mapserver-users] mapserver with kml
 
Dear all,

I think the problem is related to this: 

I changed the image width/height ratio and works fine too!

thanks so much!

2017-12-14 18:00 GMT-04:00 Ivan Ogasawara <[hidden email]>:
Hi Stephen,

2017-12-14 15:44 GMT-04:00 Stephen Woodbridge <[hidden email]>:
The "+" char in the URL is interpreted as a space you have to ecapce this as %2B

You're right, thanks .. but there is the same issue ...  


But you should be able to give the OUTPUTFORMAT block an NAME "kml" and give that the appropriate parameters like:

        EXTENSION "kml"
        MIMETYPE "application/vnd.google-earth.kml+xml"

and whatever other parameters are needed, then request the format "kml"

yes .. this is the kml outputformat that I am using:

OUTPUTFORMAT
      NAME "kml"
      DRIVER KML
      MIMETYPE "application/vnd.google-earth.kml+xml"
      IMAGEMODE RGBA
      EXTENSION "kml"
      FORMATOPTION 'ATTACHMENT=RIO_DE_JANEIRO.kml'
    END




_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users