mapserver 4.8.3 errorsing libgd 2.0.16 (or higher) from ....

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

mapserver 4.8.3 errorsing libgd 2.0.16 (or higher) from ....

DamienZINS
Hi

I must translate a SOLARIS version in CENTOS 7 OS version
Above i put all versions sourve that i use

In the file configure from mapserver 4.8.3, for me $IS_GD2 will be never
true
then compilation stop with
configure: error: Could not find gd.h or libgd.a/libgd.so in
/gmao/old/install.  Make sure GD 2.0.16 or higher is compiled before calling
configure. You may also get this error if you didn't specify the appropriate
location for one of GD's dependencies (freetype, libpng, libjpeg or
libiconv).

Somebody know why ?

ac_cv_lib_gd_gdFontCacheSetup=no
fi
rm -f conftest.err conftest.$ac_objext \
      conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
echo "$as_me:$LINENO: result: $ac_cv_lib_gd_gdFontCacheSetup" >&5
echo "${ECHO_T}$ac_cv_lib_gd_gdFontCacheSetup" >&6
if test $ac_cv_lib_gd_gdFontCacheSetup = yes; then
  IS_GD2="true"
fi
    GD_NEED_ICONV_LIB="$ICONV_LIB"
  fi

  if test -n "$GD_INCLUDE" -a -n "$GD_LIBDIR" -a "$IS_GD2" = "true"; then
      GD_INC=-I$GD_INCLUDE
      GD_LIB="-L$GD_LIBDIR -lgd"
      GD_XTRA_LIBS="$GD_XTRA_LIBS $GD_NEED_ICONV_LIB"
      echo "$as_me:$LINENO: result:         using libgd 2.0.16 (or higher)
from $GD_LIB $GD_XTRA_LIBS" >&5
echo "${ECHO_T}        using libgd 2.0.16 (or higher) from $GD_LIB
$GD_XTRA_LIBS" >&6


informations CentOS :
[root@localhost mapserver-4.8.3]# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)

informations versions sources compiled :
[root@localhost old]# grep installation install.log

>>>>>>>>>> installation de freetype-2.8 <<<<<<<<<<
>>>>>>>>>> installation de zlib-1.2.11 <<<<<<<<<<
>>>>>>>>>> installation de libpng-1.6.32 <<<<<<<<<<
>>>>>>>>>> installation de proj-4.9.3 <<<<<<<<<<
>>>>>>>>>> installation de jpegsrc.v9b <<<<<<<<<<
>>>>>>>>>> installation de libiconv-1.15 <<<<<<<<<<
>>>>>>>>>> installation de libgd-2.2.5 <<<<<<<<<<
>>>>>>>>>> installation de gdal-2.2.1 <<<<<<<<<<
>>>>>>>>>> installation de apr-1.6.2 <<<<<<<<<<
>>>>>>>>>> installation de apr-util-1.6.0 <<<<<<<<<<
>>>>>>>>>> installation de pcre-8.41 <<<<<<<<<<
>>>>>>>>>> installation de httpd-2.4.27 <<<<<<<<<<
>>>>>>>>>> installation de tomcat-connectors-1.2.42-src <<<<<<<<<<
>>>>>>>>>> installation de php-4.4.2 <<<<<<<<<<
checking for Oracle (OCI8) support using ORACLE_HOME installation... no
| distribution in the file LICENSE.  By continuing this installation |
| the installation process at this point.                            |
>>>>>>>>>> installation de mapserver-4.8.3 <<<<<<<<<<




--
Sent from: http://osgeo-org.1560.x6.nabble.com/Mapserver-User-f4226646.html
_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver 4.8.3 errorsing libgd 2.0.16 (or higher) from ....

Dan Little-2
Have you installed the headers for GD? And depending on the complexity of your Mapfiles, it might be a good time to move to a newer version of MapServer.  There have been a number of significant improvements since 4.8.3.

On Tue, Mar 6, 2018 at 4:26 AM, DamienZINS <[hidden email]> wrote:
Hi

I must translate a SOLARIS version in CENTOS 7 OS version
Above i put all versions sourve that i use

In the file configure from mapserver 4.8.3, for me $IS_GD2 will be never
true
then compilation stop with
configure: error: Could not find gd.h or libgd.a/libgd.so in
/gmao/old/install.  Make sure GD 2.0.16 or higher is compiled before calling
configure. You may also get this error if you didn't specify the appropriate
location for one of GD's dependencies (freetype, libpng, libjpeg or
libiconv).

Somebody know why ?

ac_cv_lib_gd_gdFontCacheSetup=no
fi
rm -f conftest.err conftest.$ac_objext \
      conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
echo "$as_me:$LINENO: result: $ac_cv_lib_gd_gdFontCacheSetup" >&5
echo "${ECHO_T}$ac_cv_lib_gd_gdFontCacheSetup" >&6
if test $ac_cv_lib_gd_gdFontCacheSetup = yes; then
  IS_GD2="true"
fi
    GD_NEED_ICONV_LIB="$ICONV_LIB"
  fi

  if test -n "$GD_INCLUDE" -a -n "$GD_LIBDIR" -a "$IS_GD2" = "true"; then
      GD_INC=-I$GD_INCLUDE
      GD_LIB="-L$GD_LIBDIR -lgd"
      GD_XTRA_LIBS="$GD_XTRA_LIBS $GD_NEED_ICONV_LIB"
      echo "$as_me:$LINENO: result:         using libgd 2.0.16 (or higher)
from $GD_LIB $GD_XTRA_LIBS" >&5
echo "${ECHO_T}        using libgd 2.0.16 (or higher) from $GD_LIB
$GD_XTRA_LIBS" >&6


informations CentOS :
[root@localhost mapserver-4.8.3]# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)

informations versions sources compiled :
[root@localhost old]# grep installation install.log
>>>>>>>>>> installation de freetype-2.8 <<<<<<<<<<
>>>>>>>>>> installation de zlib-1.2.11 <<<<<<<<<<
>>>>>>>>>> installation de libpng-1.6.32 <<<<<<<<<<
>>>>>>>>>> installation de proj-4.9.3 <<<<<<<<<<
>>>>>>>>>> installation de jpegsrc.v9b <<<<<<<<<<
>>>>>>>>>> installation de libiconv-1.15 <<<<<<<<<<
>>>>>>>>>> installation de libgd-2.2.5 <<<<<<<<<<
>>>>>>>>>> installation de gdal-2.2.1 <<<<<<<<<<
>>>>>>>>>> installation de apr-1.6.2 <<<<<<<<<<
>>>>>>>>>> installation de apr-util-1.6.0 <<<<<<<<<<
>>>>>>>>>> installation de pcre-8.41 <<<<<<<<<<
>>>>>>>>>> installation de httpd-2.4.27 <<<<<<<<<<
>>>>>>>>>> installation de tomcat-connectors-1.2.42-src <<<<<<<<<<
>>>>>>>>>> installation de php-4.4.2 <<<<<<<<<<
checking for Oracle (OCI8) support using ORACLE_HOME installation... no
| distribution in the file LICENSE.  By continuing this installation |
| the installation process at this point.                            |
>>>>>>>>>> installation de mapserver-4.8.3 <<<<<<<<<<




--
Sent from: http://osgeo-org.1560.x6.nabble.com/Mapserver-User-f4226646.html
_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver 4.8.3 errorsing libgd 2.0.16 (or higher) from ....

Lime, Steve D (MNIT)

I would agree on the updating. We aren’t patching 4 or 5 anymore. Oldest version I’d recommend it 6.4.x…

 

From: mapserver-users [mailto:[hidden email]] On Behalf Of Dan Little
Sent: Tuesday, March 06, 2018 1:47 PM
To: DamienZINS <[hidden email]>
Cc: [hidden email]
Subject: Re: [mapserver-users] mapserver 4.8.3 errorsing libgd 2.0.16 (or higher) from ....

 

Have you installed the headers for GD? And depending on the complexity of your Mapfiles, it might be a good time to move to a newer version of MapServer.  There have been a number of significant improvements since 4.8.3.

 

On Tue, Mar 6, 2018 at 4:26 AM, DamienZINS <[hidden email]> wrote:

Hi

I must translate a SOLARIS version in CENTOS 7 OS version
Above i put all versions sourve that i use

In the file configure from mapserver 4.8.3, for me $IS_GD2 will be never
true
then compilation stop with
configure: error: Could not find gd.h or libgd.a/libgd.so in
/gmao/old/install.  Make sure GD 2.0.16 or higher is compiled before calling
configure. You may also get this error if you didn't specify the appropriate
location for one of GD's dependencies (freetype, libpng, libjpeg or
libiconv).

Somebody know why ?

ac_cv_lib_gd_gdFontCacheSetup=no
fi
rm -f conftest.err conftest.$ac_objext \
      conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
echo "$as_me:$LINENO: result: $ac_cv_lib_gd_gdFontCacheSetup" >&5
echo "${ECHO_T}$ac_cv_lib_gd_gdFontCacheSetup" >&6
if test $ac_cv_lib_gd_gdFontCacheSetup = yes; then
  IS_GD2="true"
fi
    GD_NEED_ICONV_LIB="$ICONV_LIB"
  fi

  if test -n "$GD_INCLUDE" -a -n "$GD_LIBDIR" -a "$IS_GD2" = "true"; then
      GD_INC=-I$GD_INCLUDE
      GD_LIB="-L$GD_LIBDIR -lgd"
      GD_XTRA_LIBS="$GD_XTRA_LIBS $GD_NEED_ICONV_LIB"
      echo "$as_me:$LINENO: result:         using libgd 2.0.16 (or higher)
from $GD_LIB $GD_XTRA_LIBS" >&5
echo "${ECHO_T}        using libgd 2.0.16 (or higher) from $GD_LIB
$GD_XTRA_LIBS" >&6


informations CentOS :
[root@localhost mapserver-4.8.3]# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)

informations versions sources compiled :
[root@localhost old]# grep installation install.log
>>>>>>>>>> installation de freetype-2.8 <<<<<<<<<<
>>>>>>>>>> installation de zlib-1.2.11 <<<<<<<<<<
>>>>>>>>>> installation de libpng-1.6.32 <<<<<<<<<<
>>>>>>>>>> installation de proj-4.9.3 <<<<<<<<<<
>>>>>>>>>> installation de jpegsrc.v9b <<<<<<<<<<
>>>>>>>>>> installation de libiconv-1.15 <<<<<<<<<<
>>>>>>>>>> installation de libgd-2.2.5 <<<<<<<<<<
>>>>>>>>>> installation de gdal-2.2.1 <<<<<<<<<<
>>>>>>>>>> installation de apr-1.6.2 <<<<<<<<<<
>>>>>>>>>> installation de apr-util-1.6.0 <<<<<<<<<<
>>>>>>>>>> installation de pcre-8.41 <<<<<<<<<<
>>>>>>>>>> installation de httpd-2.4.27 <<<<<<<<<<
>>>>>>>>>> installation de tomcat-connectors-1.2.42-src <<<<<<<<<<
>>>>>>>>>> installation de php-4.4.2 <<<<<<<<<<
checking for Oracle (OCI8) support using ORACLE_HOME installation... no
| distribution in the file LICENSE.  By continuing this installation |
| the installation process at this point.                            |
>>>>>>>>>> installation de mapserver-4.8.3 <<<<<<<<<<




--
Sent from: http://osgeo-org.1560.x6.nabble.com/Mapserver-User-f4226646.html
_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users

 


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver 4.8.3 errorsing libgd 2.0.16 (or higher) from ....

DamienZINS
In reply to this post by Dan Little-2
Thanks but

what do you mean by : "Have you installed the headers for GD?" ?

to move to a newer version of MapServer: which one 7.07
 the question is : which is the good version MapServer for the others
sources installation

>>>>>>>>>> installation de freetype-2.8 <<<<<<<<<<
>>>>>>>>>> installation de zlib-1.2.11 <<<<<<<<<<
>>>>>>>>>> installation de libpng-1.6.32 <<<<<<<<<<
>>>>>>>>>> installation de proj-4.9.3 <<<<<<<<<<
>>>>>>>>>> installation de jpegsrc.v9b <<<<<<<<<<
>>>>>>>>>> installation de libiconv-1.15 <<<<<<<<<<
>>>>>>>>>> installation de libgd-2.2.5 <<<<<<<<<<
>>>>>>>>>> installation de gdal-2.2.1 <<<<<<<<<<
>>>>>>>>>> installation de apr-1.6.2 <<<<<<<<<<
>>>>>>>>>> installation de apr-util-1.6.0 <<<<<<<<<<
>>>>>>>>>> installation de pcre-8.41 <<<<<<<<<<
>>>>>>>>>> installation de httpd-2.4.27 <<<<<<<<<<
>>>>>>>>>> installation de tomcat-connectors-1.2.42-src <<<<<<<<<<
>>>>>>>>>> installation de php-4.4.2 <<<<<<<<<<





--
Sent from: http://osgeo-org.1560.x6.nabble.com/Mapserver-User-f4226646.html
_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: mapserver 4.8.3 errorsing libgd 2.0.16 (or higher) from ....

Dan Little-2
I believe on RedHat-centric systems it's the "-devel" pacakges.  I don't remember if it's "gd2-devel" or "libgd2-devel" but those would contain the gd.h file.

That looks like a VERY OLD set of installed software. PHP 4.4.2 is potentially even unsafe to be using on the server.

On Tue, Mar 6, 2018 at 1:58 PM, DamienZINS <[hidden email]> wrote:
Thanks but

what do you mean by : "Have you installed the headers for GD?" ?

to move to a newer version of MapServer: which one 7.07
 the question is : which is the good version MapServer for the others
sources installation
>>>>>>>>>> installation de freetype-2.8 <<<<<<<<<<
>>>>>>>>>> installation de zlib-1.2.11 <<<<<<<<<<
>>>>>>>>>> installation de libpng-1.6.32 <<<<<<<<<<
>>>>>>>>>> installation de proj-4.9.3 <<<<<<<<<<
>>>>>>>>>> installation de jpegsrc.v9b <<<<<<<<<<
>>>>>>>>>> installation de libiconv-1.15 <<<<<<<<<<
>>>>>>>>>> installation de libgd-2.2.5 <<<<<<<<<<
>>>>>>>>>> installation de gdal-2.2.1 <<<<<<<<<<
>>>>>>>>>> installation de apr-1.6.2 <<<<<<<<<<
>>>>>>>>>> installation de apr-util-1.6.0 <<<<<<<<<<
>>>>>>>>>> installation de pcre-8.41 <<<<<<<<<<
>>>>>>>>>> installation de httpd-2.4.27 <<<<<<<<<<
>>>>>>>>>> installation de tomcat-connectors-1.2.42-src <<<<<<<<<<
>>>>>>>>>> installation de php-4.4.2 <<<<<<<<<<





--
Sent from: http://osgeo-org.1560.x6.nabble.com/Mapserver-User-f4226646.html
_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users


_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users