installation error node themesConfig.js

Previous Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

installation error node themesConfig.js

Steve.Toutant
hi,
I'm trying to install qwc2 on ubuntu 16.04 and get the following error after yarn start

node themesConfig.js
/var/www/html/qwc2-demo-app/themesConfig.js:42
    let bboxw = extent[2] - extent[0];
    ^^^

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
    at exports.runInThisContext (vm.js:53:16)
    at Module._compile (module.js:374:25)
    at Object.Module._extensions..js (module.js:417:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Function.Module.runMain (module.js:442:10)
    at startup (node.js:136:18)
    at node.js:966:3

I know nothing about node and yarn, I just follow the recipe. Is there something I can do or it is a bug
thanks!


_______________________________________________
qgis-qwc2 mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-qwc2
Reply | Threaded
Open this post in threaded view
|

Re: installation error node themesConfig.js

Richard Duivenvoorde
Hi Steve,

looks like my problem:

https://github.com/qgis/qwc2-demo-app/issues/10

for me in Debian the Node version was just too old.

see the issue on how to install a newer version, after that it just
worked...

Regards,

Richard Duivenvoorde

On 18-01-17 17:00, [hidden email] wrote:

> hi,
> I'm trying to install qwc2 on ubuntu 16.04 and get the following error
> after yarn start
>
> node themesConfig.js
> /var/www/html/qwc2-demo-app/themesConfig.js:42
>     let bboxw = extent[2] - extent[0];
>     ^^^
>
> SyntaxError: Block-scoped declarations (let, const, function, class) not
> yet supported outside strict mode
>     at exports.runInThisContext (vm.js:53:16)
>     at Module._compile (module.js:374:25)
>     at Object.Module._extensions..js (module.js:417:10)
>     at Module.load (module.js:344:32)
>     at Function.Module._load (module.js:301:12)
>     at Function.Module.runMain (module.js:442:10)
>     at startup (node.js:136:18)
>     at node.js:966:3
>
> I know nothing about node and yarn, I just follow the recipe. Is there
> something I can do or it is a bug
> thanks!
>
>
>
> _______________________________________________
> qgis-qwc2 mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/qgis-qwc2
>

_______________________________________________
qgis-qwc2 mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-qwc2
Reply | Threaded
Open this post in threaded view
|

installation error node themesConfig.js

Burghardt.Scholle
In reply to this post by Steve.Toutant

Hi Steve,

 

i’ve successfully installed qwc2 on Ubuntu 16.04. I used the ppa [1] for nodejs and [2] for yarn. With this ppa’s I get the version 7.4.0 for node, 4.0.5 for npm and 0.19.1 for yarn and the installation of qwc2 works.

 

Hope this helps.

 

Regards

Burghardt

 

[1] http://tecadmin.net/install-latest-nodejs-npm-on-ubuntu/#

[2] https://yarnpkg.com/en/docs/install#linux-tab

 

 

Von: qgis-qwc2 [[hidden email]] Im Auftrag von [hidden email]
Gesendet: Mittwoch, 18. Januar 2017 17:00
An: [hidden email]
Betreff: [qgis-qwc2] installation error node themesConfig.js

 

hi,
I'm trying to install qwc2 on ubuntu 16.04 and get the following error after yarn start

node themesConfig.js
/var/www/html/qwc2-demo-app/themesConfig.js:42
    let bboxw = extent[2] - extent[0];
    ^^^

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
    at exports.runInThisContext (vm.js:53:16)
    at Module._compile (module.js:374:25)
    at Object.Module._extensions..js (module.js:417:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Function.Module.runMain (module.js:442:10)
    at startup (node.js:136:18)
    at node.js:966:3

I know nothing about node and yarn, I just follow the recipe. Is there something I can do or it is a bug
thanks!


_______________________________________________
qgis-qwc2 mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-qwc2
Reply | Threaded
Open this post in threaded view
|

Re: installation error node themesConfig.js

Steve.Toutant
Thanks, the installation works.






De :        <[hidden email]>
A :        <[hidden email]>
Date :        2017-01-19 01:29
Objet :        [qgis-qwc2]  installation error node themesConfig.js
Envoyé par :        "qgis-qwc2" <[hidden email]>




Hi Steve,
 
i’ve successfully installed qwc2 on Ubuntu 16.04. I used the ppa [1] for nodejs and [2] for yarn. With this ppa’s I get the version 7.4.0 for node, 4.0.5 for npm and 0.19.1 for yarn and the installation of qwc2 works.
 
Hope this helps.
 
Regards
Burghardt
 
[1] http://tecadmin.net/install-latest-nodejs-npm-on-ubuntu/#
[2] https://yarnpkg.com/en/docs/install#linux-tab
 
 
Von: qgis-qwc2 [[hidden email]] Im Auftrag von Steve.Toutant@...
Gesendet:
Mittwoch, 18. Januar 2017 17:00
An:
[hidden email]
Betreff:
[qgis-qwc2] installation error node themesConfig.js

 
hi,
I'm trying to install qwc2 on ubuntu 16.04 and get the following error after yarn start


node themesConfig.js

/var/www/html/qwc2-demo-app/themesConfig.js:42

   let bboxw = extent[2] - extent[0];

   ^^^


SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode

   at exports.runInThisContext (vm.js:53:16)

   at Module._compile (module.js:374:25)

   at Object.Module._extensions..js (module.js:417:10)

   at Module.load (module.js:344:32)

   at Function.Module._load (module.js:301:12)

   at Function.Module.runMain (module.js:442:10)

   at startup (node.js:136:18)

   at node.js:966:3


I know nothing about node and yarn, I just follow the recipe. Is there something I can do or it is a bug

thanks!
_______________________________________________
qgis-qwc2 mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-qwc2


_______________________________________________
qgis-qwc2 mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/qgis-qwc2