i.pca gives error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

i.pca gives error

Martin van Brakel
Hi list,

i am processing plenty of modis subsets into a group called "pca"

when using WinGRASS it gives an error

GRASS 7.0.svn> i.pca --overwrite input=pca output_prefix=_msub
Computing covariance matrix...
 100%
ERROR: No non-null values
GRASS 7.0.svn>


can anybody help please?

Martin

_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: i.pca gives error

Markus Neteler
On Fri, Apr 4, 2014 at 1:47 PM, Martin van Brakel
<[hidden email]> wrote:

> Hi list,
>
> i am processing plenty of modis subsets into a group called "pca"
>
> when using WinGRASS it gives an error
>
> GRASS 7.0.svn> i.pca --overwrite input=pca output_prefix=_msub
> Computing covariance matrix...
>  100%
> ERROR: No non-null values
> GRASS 7.0.svn>

Did you set the computational region to the map beforehand?

g.region rast=pca -p

then
i.pca ...

See also:
http://grasswiki.osgeo.org/wiki/Computational_region
Since we currently have issues on the server (slow), see also the wiki
mirror at:
http://grass.fsv.cvut.cz/wiki-mirror/index.php/Computational_region

hope this helps
Markus
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: i.pca gives error

Martin van Brakel
that helps but it breaks there...


GRASS 7.0.svn> i.pca --overwrite input=pca output_prefix=_msub
Computing covariance matrix...
 100%
Calculating principal components...
 100%
Rescaling to range 0,255...
 100%
Eigen values, (vectors), and [percent importance]:
GRASS 7.0.svn>


On Fri, Apr 4, 2014 at 5:44 PM, Markus Neteler <[hidden email]> wrote:
On Fri, Apr 4, 2014 at 1:47 PM, Martin van Brakel
<[hidden email]> wrote:
> Hi list,
>
> i am processing plenty of modis subsets into a group called "pca"
>
> when using WinGRASS it gives an error
>
> GRASS 7.0.svn> i.pca --overwrite input=pca output_prefix=_msub
> Computing covariance matrix...
>  100%
> ERROR: No non-null values
> GRASS 7.0.svn>

Did you set the computational region to the map beforehand?

g.region rast=pca -p

then
i.pca ...

See also:
http://grasswiki.osgeo.org/wiki/Computational_region
Since we currently have issues on the server (slow), see also the wiki
mirror at:
http://grass.fsv.cvut.cz/wiki-mirror/index.php/Computational_region

hope this helps
Markus


_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: i.pca gives error

Markus Neteler
On Fri, Apr 4, 2014 at 2:43 PM, Martin van Brakel
<[hidden email]> wrote:

> that helps but it breaks there...
>
>
> GRASS 7.0.svn> i.pca --overwrite input=pca output_prefix=_msub
> Computing covariance matrix...
>  100%
> Calculating principal components...
>  100%
> Rescaling to range 0,255...
>  100%
> Eigen values, (vectors), and [percent importance]:
> GRASS 7.0.svn>

Please try (just for fun) to not use the leading "_" in the prefix parameter.

Please also post the output of

g.version -g

Markus
_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: i.pca gives error

Martin van Brakel

The problem appeared to be the extent and the pixel resolution, g.region rast=file solved it, thanks

Martin



On Fri, Apr 4, 2014 at 6:17 PM, Markus Neteler <[hidden email]> wrote:
On Fri, Apr 4, 2014 at 2:43 PM, Martin van Brakel
<[hidden email]> wrote:
> that helps but it breaks there...
>
>
> GRASS 7.0.svn> i.pca --overwrite input=pca output_prefix=_msub
> Computing covariance matrix...
>  100%
> Calculating principal components...
>  100%
> Rescaling to range 0,255...
>  100%
> Eigen values, (vectors), and [percent importance]:
> GRASS 7.0.svn>

Please try (just for fun) to not use the leading "_" in the prefix parameter.

Please also post the output of

g.version -g

Markus


_______________________________________________
grass-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/grass-user