i.cluster module problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

i.cluster module problem

Marta Fernandez

Good morning,

I´m Marta, researcher from Vigo University. We were trying classify a band set (7 bands), so we introduced it in i.cluster module and leave the configuration options by default. The console returns the following error "Number of insufficient sample points, please run again and choose a larger sample size." We try to change the size of the sampling interval, but it returns an error “ERROR: Value (s) of sampling intervals (50,50) not supported". we have also tried to express these values in another way, and testing with values of greater and lesser magnitude.

Could you tell me what the error is?

Thank you,


Marta Fernandez



_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web
Reply | Threaded
Open this post in threaded view
|

Re: i.cluster module problem

Moritz Lennert
Am 15.02.2018 12:43 schrieb Marta Fernandez:

> Good morning,
>
> I´m Marta, researcher from Vigo University. We were trying classify a
> band set (7 bands), so we introduced it in i.cluster module and leave
> the configuration options by default. The console returns the
> following error "Number of insufficient sample points, please run
> again and choose a larger sample size." We try to change the size of
> the sampling interval, but it returns an error “ERROR: Value (s) of
> sampling intervals (50,50) not supported". we have also tried to
> express these values in another way, and testing with values of
> greater and lesser magnitude.
>
> Could you tell me what the error is?

What are your region settings ?

g.region -p

compared to your input data:

r.info OneInputBand ?

Moritz
_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web
Reply | Threaded
Open this post in threaded view
|

Re: i.cluster module problem

Moritz Lennert
[Please always keep discussions on the mailing list]

On 15/02/18 15:27, Marta Fernandez wrote:

> Thank you for respond so fast.
>
> Input data: (1 from 7)
>
> | Map:      composite.1@Marta              Date: Thu Feb 15 09:31:14
> 2018    |
>
> | Mapset:   Marta                          Login of Creator:
> Marta           |
>
> | Location:
> prueba                                                           |
>
> | DataBase:
> C:\Users\Marta\grass                                             |
>
> | Title:    
> composite.1                                                      |
>
> | Timestamp:
> none                                                            |
>
> |----------------------------------------------------------------------------|
>
> |                                                                            
> |
>
> |   Type of Map:  raster               Number of Categories:
> 0               |
>
> |   Data Type:    
> FCELL                                                      |
>
> |   Rows:        
> 6686                                                       |
>
> |   Columns:      11422                        
>                                |
>
> |   Total Cells:  
> 76367492                                                   |
>
> |        Projection: UTM (zone
> 29)                                           |
>
> |            N: 4725034.75771    S: 4724499.87771   Res:  0.08
>                |
>
> |            E: 553994.32785    W: 553080.56785   Res:  
> 0.08                 |
>
> |   Range of data:    min = 0.06990715  max =
> 0.6211307                      |
>
> |                                                                            
> |
>
> |   Data
> Description:                                                        |
>
> |    generado por
> r.in.gdal                                                  |
>
> |                                                                            
> |
>
> |   Comments:  
>                                                                |
>
> |    r.in.gdal -k
> input="A:\Marta\Documents\uforest\pruebas\pruebas_clasi\   |
>
> |    ficacion_habitats\clasificacion_nosupervisada_grass\composite.tif"
> o\   |
>
> |    utput="composite" memory=300 offset=0
> num_digits=0                      |
>
> |                                                                            
> |
>
> +----------------------------------------------------------------------------+
>
> Region data:
>
> (Thu Feb 15 15:25:37 2018)
>
> g.region -p
>
> projection: 1 (UTM)
>
> zone:       29
>
> datum:      wgs84
>
> ellipsoid:  wgs84
>
> north:      4725034.75771
>
> south:      4724499.79771
>
> west:       553080.56785
>
> east:       553994.32785
>
> nsres:      0.08
>
> ewres:      0.08
>
> rows:       6687
>
> cols:       11422
>
> cells:      76378914
>
> (Thu Feb 15 15:25:37 2018) Comando finalizado (0 segundos)
>
> Marta Fernández Álvarez
> Grupo de Investigación CI5 – Lab. Ingeniería Cartográfica
> EI Forestal-Universidad de Vigo
>
> *De: *Moritz Lennert <mailto:[hidden email]>
> *Enviado: *jueves, 15 de febrero de 2018 14:58
> *Para: *Marta Fernandez <mailto:[hidden email]>
> *CC: *[hidden email] <mailto:[hidden email]>
> *Asunto: *Re: [GRASS-web] i.cluster module problem
>
> Am 15.02.2018 12:43 schrieb Marta Fernandez:
>
>  > Good morning,
>
>  >
>
>  > I´m Marta, researcher from Vigo University. We were trying classify a
>
>  > band set (7 bands), so we introduced it in i.cluster module and leave
>
>  > the configuration options by default. The console returns the
>
>  > following error "Number of insufficient sample points, please run
>
>  > again and choose a larger sample size." We try to change the size of
>
>  > the sampling interval, but it returns an error “ERROR: Value (s) of
>
>  > sampling intervals (50,50) not supported". we have also tried to
>
>  > express these values in another way, and testing with values of
>
>  > greater and lesser magnitude.
>
>  >
>
>  > Could you tell me what the error is?
>
> What are your region settings ?
>
> g.region -p
>
> compared to your input data:
>
> r.info OneInputBand ?
>

Ok. Region does not seem to be the issue.

Can you give us the precise manner in which you called i.cluster ? And
the content of the group you use ? This might also help understand where
the error after giving a sample size comes from.

Moritz



_______________________________________________
grass-web mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-web