grid funkyness with 2.4RC3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

grid funkyness with 2.4RC3

Bart van den Eijnden (OSGIS)-2
Hi list,

we still experience grid funkyness with 2.4RC3, see:

http://www.osgis.nl/download/gridfunkyness.png

I've tracked down the boundingboxes of the tilecache requests, starting at
upperleft (1) and going down to lowerright (9):

1  2  3
4  5  6
7  8  9

1: BBOX=-50000,479200.467643,39600.233821,568800.701464
2: BBOX=-50000,658400.935286,308400.935286,1016801.870572
3: BBOX=129200.467643,479200.467643,218800.701464,568800.701464
4: BBOX=-50000,479200.467643,39600.233821,568800.701464
5: BBOX=-50000,300000,308400.935286,658400.935286
6: BBOX=129200.467643,389600.233821,218800.701464,479200.467643
7: BBOX=93360.374114,461280.420879,111280.420879,479200.467643
8: tile failed loading (white pixel)
9: BBOX=129200.467643,461280.420879,147120.514407,479200.467643

but have no idea on how to tackle this problem. Any ideas highly
appreciated.

Best regards,
Bart

--
Bart van den Eijnden
OSGIS, Open Source GIS
http://www.osgis.nl





_______________________________________________
Users mailing list
[hidden email]
http://openlayers.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: grid funkyness with 2.4RC3

Bart van den Eijnden (OSGIS)-2
Some more info on this problem. It can only be reproduced in Internet
Explorer (we use 6) and not in Firefox.

There are 2 baselayers in the application: one WMS untiled and one tiled WMS
layer pointing to TileCache.

To reproduce we have to:
1) set WMS.Untiled as baselayer
2) zoom out
3) before the baselayer appears, switch the baselayer

Hopefully this rings a bell.

Best regards,
Bart

--
Bart van den Eijnden
OSGIS, Open Source GIS
http://www.osgis.nl


--------- Oorspronkelijk bericht --------
Van: Bart van den Eijnden OSGIS <[hidden email]>
Naar: [hidden email] <[hidden email]>
Onderwerp: [OpenLayers-Users] grid funkyness with 2.4RC3
Datum: 08/05/07 05:53

> Hi list,
>
> we still experience grid funkyness with 2.4RC3, see:
>
> http://www.osgis.nl/download/gridfunkyness.png
>
> I've tracked down the boundingboxes of the tilecache requests, starting at
> upperleft (1) and going down to lowerright (9):
>
> 1  2  3
> 4  5  6
> 7  8  9
>
> 1: BBOX=-50000,479200.467643,39600.233821,568800.701464
> 2: BBOX=-50000,658400.935286,308400.935286,1016801.870572
> 3: BBOX=129200.467643,479200.467643,218800.701464,568800.701464
> 4: BBOX=-50000,479200.467643,39600.233821,568800.701464
> 5: BBOX=-50000,300000,308400.935286,658400.935286
> 6: BBOX=129200.467643,389600.233821,218800.701464,479200.467643
> 7: BBOX=93360.374114,461280.420879,111280.420879,479200.467643
> 8: tile failed loading (white pixel)
> 9: BBOX=129200.467643,461280.420879,147120.514407,479200.467643
>
> but have no idea on how to tackle this problem. Any ideas highly
> appreciated.
>
> Best regards,
> Bart
>
> --
> Bart van den Eijnden
> OSGIS, Open Source GIS
> http://www.osgis.nl
>
>
>
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://openlayers.org/mailman/listinfo/users
>
>



_______________________________________________
Users mailing list
[hidden email]
http://openlayers.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: grid funkyness with 2.4RC3

Erik Uzureau-3
Hi Bart,

Is this problem still happening in 2.4 release?

Could you make an example html so that this would
be easier to test?

Erik

On 5/8/07, Bart van den Eijnden (OSGIS) <[hidden email]> wrote:

> Some more info on this problem. It can only be reproduced in Internet
> Explorer (we use 6) and not in Firefox.
>
> There are 2 baselayers in the application: one WMS untiled and one tiled WMS
> layer pointing to TileCache.
>
> To reproduce we have to:
> 1) set WMS.Untiled as baselayer
> 2) zoom out
> 3) before the baselayer appears, switch the baselayer
>
> Hopefully this rings a bell.
>
> Best regards,
> Bart
>
> --
> Bart van den Eijnden
> OSGIS, Open Source GIS
> http://www.osgis.nl
>
>
> --------- Oorspronkelijk bericht --------
> Van: Bart van den Eijnden OSGIS <[hidden email]>
> Naar: [hidden email] <[hidden email]>
> Onderwerp: [OpenLayers-Users] grid funkyness with 2.4RC3
> Datum: 08/05/07 05:53
>
> > Hi list,
> >
> > we still experience grid funkyness with 2.4RC3, see:
> >
> > http://www.osgis.nl/download/gridfunkyness.png
> >
> > I've tracked down the boundingboxes of the tilecache requests, starting at
> > upperleft (1) and going down to lowerright (9):
> >
> > 1  2  3
> > 4  5  6
> > 7  8  9
> >
> > 1: BBOX=-50000,479200.467643,39600.233821,568800.701464
> > 2: BBOX=-50000,658400.935286,308400.935286,1016801.870572
> > 3: BBOX=129200.467643,479200.467643,218800.701464,568800.701464
> > 4: BBOX=-50000,479200.467643,39600.233821,568800.701464
> > 5: BBOX=-50000,300000,308400.935286,658400.935286
> > 6: BBOX=129200.467643,389600.233821,218800.701464,479200.467643
> > 7: BBOX=93360.374114,461280.420879,111280.420879,479200.467643
> > 8: tile failed loading (white pixel)
> > 9: BBOX=129200.467643,461280.420879,147120.514407,479200.467643
> >
> > but have no idea on how to tackle this problem. Any ideas highly
> > appreciated.
> >
> > Best regards,
> > Bart
> >
> > --
> > Bart van den Eijnden
> > OSGIS, Open Source GIS
> > http://www.osgis.nl
> >
> >
> >
> >
> >
> > _______________________________________________
> > Users mailing list
> > [hidden email]
> > http://openlayers.org/mailman/listinfo/users
> >
> >
>
>
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://openlayers.org/mailman/listinfo/users
>
_______________________________________________
Users mailing list
[hidden email]
http://openlayers.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: grid funkyness with 2.4RC3

Bart van den Eijnden (OSGIS)-2
Hi Erik,

it was still happening but we found a workaround, which I had already
used before:

http://trac.openlayers.org/ticket/504

Best regards,
Bart

Erik Uzureau schreef:

> Hi Bart,
>
> Is this problem still happening in 2.4 release?
>
> Could you make an example html so that this would
> be easier to test?
>
> Erik
>
> On 5/8/07, Bart van den Eijnden (OSGIS) <[hidden email]> wrote:
>> Some more info on this problem. It can only be reproduced in Internet
>> Explorer (we use 6) and not in Firefox.
>>
>> There are 2 baselayers in the application: one WMS untiled and one
>> tiled WMS
>> layer pointing to TileCache.
>>
>> To reproduce we have to:
>> 1) set WMS.Untiled as baselayer
>> 2) zoom out
>> 3) before the baselayer appears, switch the baselayer
>>
>> Hopefully this rings a bell.
>>
>> Best regards,
>> Bart
>>
>> --
>> Bart van den Eijnden
>> OSGIS, Open Source GIS
>> http://www.osgis.nl
>>
>>
>> --------- Oorspronkelijk bericht --------
>> Van: Bart van den Eijnden OSGIS <[hidden email]>
>> Naar: [hidden email] <[hidden email]>
>> Onderwerp: [OpenLayers-Users] grid funkyness with 2.4RC3
>> Datum: 08/05/07 05:53
>>
>> > Hi list,
>> >
>> > we still experience grid funkyness with 2.4RC3, see:
>> >
>> > http://www.osgis.nl/download/gridfunkyness.png
>> >
>> > I've tracked down the boundingboxes of the tilecache requests,
>> starting at
>> > upperleft (1) and going down to lowerright (9):
>> >
>> > 1  2  3
>> > 4  5  6
>> > 7  8  9
>> >
>> > 1: BBOX=-50000,479200.467643,39600.233821,568800.701464
>> > 2: BBOX=-50000,658400.935286,308400.935286,1016801.870572
>> > 3: BBOX=129200.467643,479200.467643,218800.701464,568800.701464
>> > 4: BBOX=-50000,479200.467643,39600.233821,568800.701464
>> > 5: BBOX=-50000,300000,308400.935286,658400.935286
>> > 6: BBOX=129200.467643,389600.233821,218800.701464,479200.467643
>> > 7: BBOX=93360.374114,461280.420879,111280.420879,479200.467643
>> > 8: tile failed loading (white pixel)
>> > 9: BBOX=129200.467643,461280.420879,147120.514407,479200.467643
>> >
>> > but have no idea on how to tackle this problem. Any ideas highly
>> > appreciated.
>> >
>> > Best regards,
>> > Bart
>> >
>> > --
>> > Bart van den Eijnden
>> > OSGIS, Open Source GIS
>> > http://www.osgis.nl
>> >
>> >
>> >
>> >
>> >
>> > _______________________________________________
>> > Users mailing list
>> > [hidden email]
>> > http://openlayers.org/mailman/listinfo/users
>> >
>> >
>>
>>
>>
>> _______________________________________________
>> Users mailing list
>> [hidden email]
>> http://openlayers.org/mailman/listinfo/users
>>
>
>


--
Bart van den Eijnden
OSGIS, Open Source GIS
[hidden email]
http://www.osgis.nl

_______________________________________________
Users mailing list
[hidden email]
http://openlayers.org/mailman/listinfo/users