google/ve panning issue

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

google/ve panning issue

John Cole X
Playing around with the 2.5 examples, I noticed that when panning on the
google or ve examples, the base layer goes white if you pan more than aprox
30% of the image quickly.

Loading the same 2.4 examples, this doesn't happen.  I tried IE7, FF2 and
SafariWin.

Is this expected behavior?

John

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.488 / Virus Database: 269.14.8/1066 - Release Date: 10/12/2007
11:10 AM
 
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the sender. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail.
_______________________________________________
Dev mailing list
[hidden email]
http://openlayers.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: google/ve panning issue

Christopher Schmidt-2
On Fri, Oct 12, 2007 at 10:10:40AM -0500, John Cole wrote:
> Playing around with the 2.5 examples, I noticed that when panning on the
> google or ve examples, the base layer goes white if you pan more than aprox
> 30% of the image quickly.
>
> Loading the same 2.4 examples, this doesn't happen.  I tried IE7, FF2 and
> SafariWin.

You got this to *not* happen in 2.4? I'm amazed -- this has always been
a problem as far as I'm aware. See:

http://gmaps.eactive.org/testmove.html
http://groups.google.co.in/group/Google-Maps-API/browse_thread/thread/3cab18706cb51efd

which address this issue as far as Google Maps is concerned.

VE suffers a number of different problems, that have a similar effect --
some of which are improved by the changes proposed in
http://trac.openlayers.org/ticket/1053 but which have not yet been
codified into a patch.

Can you share exactly what you're doing to make it work in 2.4?

Regards,
--
Christopher Schmidt
MetaCarta
_______________________________________________
Dev mailing list
[hidden email]
http://openlayers.org/mailman/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: google/ve panning issue

John Cole X
In reply to this post by John Cole X
Hmmmm... I'm afraid that I just ran the example.  I did have an older 2.4
rc, and the release apparently throws a JS error.  I was under the
impression that this was a new issue, since I haven't seen it in 2.3 or the
2.4 rc we were using.

John

-----Original Message-----
From: Christopher Schmidt [mailto:[hidden email]]
Sent: Friday, October 12, 2007 10:59 AM
To: John Cole
Cc: [hidden email]
Subject: Re: [OpenLayers-Dev] google/ve panning issue

On Fri, Oct 12, 2007 at 10:10:40AM -0500, John Cole wrote:
> Playing around with the 2.5 examples, I noticed that when panning on the
> google or ve examples, the base layer goes white if you pan more than
aprox
> 30% of the image quickly.
>
> Loading the same 2.4 examples, this doesn't happen.  I tried IE7, FF2 and
> SafariWin.

You got this to *not* happen in 2.4? I'm amazed -- this has always been
a problem as far as I'm aware. See:

http://gmaps.eactive.org/testmove.html
http://groups.google.co.in/group/Google-Maps-API/browse_thread/thread/3cab18
706cb51efd

which address this issue as far as Google Maps is concerned.

VE suffers a number of different problems, that have a similar effect --
some of which are improved by the changes proposed in
http://trac.openlayers.org/ticket/1053 but which have not yet been
codified into a patch.

Can you share exactly what you're doing to make it work in 2.4?

Regards,
--
Christopher Schmidt
MetaCarta

No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.488 / Virus Database: 269.14.8/1066 - Release Date: 10/12/2007
11:10 AM
 

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.488 / Virus Database: 269.14.8/1066 - Release Date: 10/12/2007
11:10 AM
 
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the sender. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail.
_______________________________________________
Dev mailing list
[hidden email]
http://openlayers.org/mailman/listinfo/dev