geoserver + tilecache + openlayers seeded overlay in epsg:900913

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

geoserver + tilecache + openlayers seeded overlay in epsg:900913

Soraia Ferreira
Hi, My problem is that i'm not beeing able to seed my layer with tilecache. The scenario is a mashup in OL that uses Bing Maps as basemap (with sphericalMercator property equal true). I have a GeoServer instance configured and serving a layer in EPSG:900913. -- tilecache.cfg -- [buildings] type=WMSLayer url=http://my_url:8080/geoserver/wms?transparent=true layers=buildings srs=EPSG:900913 bbox=-20037508.34,-20037508.34,20037508.34,20037508.34 resolutions=156543.0339,78271.51695,39135.758475,19567.8792375,9783.93961875,4891.969809375,2445.9849046875,1222.99245234375,611.496226171875,305.7481130859375,152.87405654296876,76.43702827148438,38.21851413574219,19.109257067871095,9.554628533935547,4.777314266967774,2.388657133483887,1.1943285667419434,0.5971642833709717,0.29858214168548586 debug=off extension=png extent_type=loose -- My tilecache runs under mod_python and if i request in OL application, the script tilecache.py shows me the layer properly (bbox and maxResolution are the same in tilecache cfg and OL app). The issue is when I try to seed it... I have attempded to use GoogleDisk, with no success, so the cache would be saved using Google's X/Y/Z structure Params like tms_type=google are worthless Why is tilecache.py able to show me the layer correctly the layer on top of google and when i run the utility tilecache_seed.py ain't. I basically, want to display a pre-seeded layer on top of bing maps or google maps using OpenLayers as client. Please elucidate me Appreciated -- Soraia Ferreira