geoserver on weblogic

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

geoserver on weblogic

Imran Rajjad
I`m trying to deploy on WebLogic 10.3, are the instruction on
http://geoserver.org/display/GEOSDOC/Deploy+in+Weblogic mandatory or
we can skip them?

--
I.R

------------------------------------------------------------------------------
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver on weblogic

aaime
Imran Rajjad ha scritto:
> I`m trying to deploy on WebLogic 10.3, are the instruction on
> http://geoserver.org/display/GEOSDOC/Deploy+in+Weblogic mandatory or
> we can skip them?

Those instructions are what has been left to us from the people
that tried and succeeded in making GeoServer work in WebLogic.
That's all we know (don't think any of the developers normally
deploys to WebLogic).

Cheers
Andrea



--
Andrea Aime
OpenGeo - http://opengeo.org
Expert service straight from the developers.

------------------------------------------------------------------------------
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver on weblogic

Don Vollmer
Imran,
I too am planning on deploying to Weblogic 10.3.  Before I get started I was wondering if you could share any lessons learned while you where doing same.
 
Thanks for any pointeres in advance.

--Don


[hidden email]



----- Original Message ----
From: Andrea Aime <[hidden email]>
To: Imran Rajjad <[hidden email]>
Cc: Geoserver-users <[hidden email]>
Sent: Wed, April 28, 2010 5:09:18 AM
Subject: Re: [Geoserver-users] geoserver on weblogic

Imran Rajjad ha scritto:
> I`m trying to deploy on WebLogic 10.3, are the instruction on
> http://geoserver.org/display/GEOSDOC/Deploy+in+Weblogic mandatory or
> we can skip them?

Those instructions are what has been left to us from the people
that tried and succeeded in making GeoServer work in WebLogic.
That's all we know (don't think any of the developers normally
deploys to WebLogic).

Cheers
Andrea



--
Andrea Aime
OpenGeo - http://opengeo.org
Expert service straight from the developers.

------------------------------------------------------------------------------
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users


------------------------------------------------------------------------------
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver on weblogic

Imran Rajjad
Yea I tried deploying it on Web-Logic 11g on  Solaris 10 , no luck
yet. It has been giving me a PermGem error which has got something to
do with Memory allocation. I did follow the instruction on the page,
though I`m still on it, I will surely post if Im able to deploy it.

On Tue, May 4, 2010 at 8:12 PM, Don Vollmer <[hidden email]> wrote:

> Imran,
> I too am planning on deploying to Weblogic 10.3.  Before I get started I was wondering if you could share any lessons learned while you where doing same.
>
> Thanks for any pointeres in advance.
>
> --Don
>
>
> [hidden email]
>
>
>
> ----- Original Message ----
> From: Andrea Aime <[hidden email]>
> To: Imran Rajjad <[hidden email]>
> Cc: Geoserver-users <[hidden email]>
> Sent: Wed, April 28, 2010 5:09:18 AM
> Subject: Re: [Geoserver-users] geoserver on weblogic
>
> Imran Rajjad ha scritto:
>> I`m trying to deploy on WebLogic 10.3, are the instruction on
>> http://geoserver.org/display/GEOSDOC/Deploy+in+Weblogic mandatory or
>> we can skip them?
>
> Those instructions are what has been left to us from the people
> that tried and succeeded in making GeoServer work in WebLogic.
> That's all we know (don't think any of the developers normally
> deploys to WebLogic).
>
> Cheers
> Andrea
>
>
>
> --
> Andrea Aime
> OpenGeo - http://opengeo.org
> Expert service straight from the developers.
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Geoserver-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geoserver-users
>
>



--
I.R

------------------------------------------------------------------------------
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver on weblogic

Imran Rajjad
May 4, 2010 10:43:16 PM
it.geosolutions.imageio.gdalframework.GDALUtilities loadGDAL
WARNING: Native library load failed.java.lang.UnsatisfiedLinkError: no
gdaljni in java.library.path

I think the GDAL plugin is causing problems.and I thought it was
included in GS 1.7.7. Do I need to manually include it and set a Path?

regards,


On Wed, May 5, 2010 at 9:21 AM, Imran Rajjad <[hidden email]> wrote:

> Yea I tried deploying it on Web-Logic 11g on  Solaris 10 , no luck
> yet. It has been giving me a PermGem error which has got something to
> do with Memory allocation. I did follow the instruction on the page,
> though I`m still on it, I will surely post if Im able to deploy it.
>
> On Tue, May 4, 2010 at 8:12 PM, Don Vollmer <[hidden email]> wrote:
>> Imran,
>> I too am planning on deploying to Weblogic 10.3.  Before I get started I was wondering if you could share any lessons learned while you where doing same.
>>
>> Thanks for any pointeres in advance.
>>
>> --Don
>>
>>
>> [hidden email]
>>
>>
>>
>> ----- Original Message ----
>> From: Andrea Aime <[hidden email]>
>> To: Imran Rajjad <[hidden email]>
>> Cc: Geoserver-users <[hidden email]>
>> Sent: Wed, April 28, 2010 5:09:18 AM
>> Subject: Re: [Geoserver-users] geoserver on weblogic
>>
>> Imran Rajjad ha scritto:
>>> I`m trying to deploy on WebLogic 10.3, are the instruction on
>>> http://geoserver.org/display/GEOSDOC/Deploy+in+Weblogic mandatory or
>>> we can skip them?
>>
>> Those instructions are what has been left to us from the people
>> that tried and succeeded in making GeoServer work in WebLogic.
>> That's all we know (don't think any of the developers normally
>> deploys to WebLogic).
>>
>> Cheers
>> Andrea
>>
>>
>>
>> --
>> Andrea Aime
>> OpenGeo - http://opengeo.org
>> Expert service straight from the developers.
>>
>> ------------------------------------------------------------------------------
>> _______________________________________________
>> Geoserver-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geoserver-users
>>
>>
>
>
>
> --
> I.R
>



--
I.R

------------------------------------------------------------------------------
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver on weblogic

Justin Deoliveira
This warning can be ignored. It just means the gdal extensions could not
find the native gdal libs on the library path. Those formats that
reuqire it will simply be disabled.

As for the PermGen error I would recheck your memory settings and
increase the PermGen space being used by your container if it is set to
the default.

-Justin

On 5/5/10 12:44 AM, Imran Rajjad wrote:

> May 4, 2010 10:43:16 PM
> it.geosolutions.imageio.gdalframework.GDALUtilities loadGDAL
> WARNING: Native library load failed.java.lang.UnsatisfiedLinkError: no
> gdaljni in java.library.path
>
> I think the GDAL plugin is causing problems.and I thought it was
> included in GS 1.7.7. Do I need to manually include it and set a Path?
>
> regards,
>
>
> On Wed, May 5, 2010 at 9:21 AM, Imran Rajjad<[hidden email]>  wrote:
>> Yea I tried deploying it on Web-Logic 11g on  Solaris 10 , no luck
>> yet. It has been giving me a PermGem error which has got something to
>> do with Memory allocation. I did follow the instruction on the page,
>> though I`m still on it, I will surely post if Im able to deploy it.
>>
>> On Tue, May 4, 2010 at 8:12 PM, Don Vollmer<[hidden email]>  wrote:
>>> Imran,
>>> I too am planning on deploying to Weblogic 10.3.  Before I get started I was wondering if you could share any lessons learned while you where doing same.
>>>
>>> Thanks for any pointeres in advance.
>>>
>>> --Don
>>>
>>>
>>> [hidden email]
>>>
>>>
>>>
>>> ----- Original Message ----
>>> From: Andrea Aime<[hidden email]>
>>> To: Imran Rajjad<[hidden email]>
>>> Cc: Geoserver-users<[hidden email]>
>>> Sent: Wed, April 28, 2010 5:09:18 AM
>>> Subject: Re: [Geoserver-users] geoserver on weblogic
>>>
>>> Imran Rajjad ha scritto:
>>>> I`m trying to deploy on WebLogic 10.3, are the instruction on
>>>> http://geoserver.org/display/GEOSDOC/Deploy+in+Weblogic mandatory or
>>>> we can skip them?
>>>
>>> Those instructions are what has been left to us from the people
>>> that tried and succeeded in making GeoServer work in WebLogic.
>>> That's all we know (don't think any of the developers normally
>>> deploys to WebLogic).
>>>
>>> Cheers
>>> Andrea
>>>
>>>
>>>
>>> --
>>> Andrea Aime
>>> OpenGeo - http://opengeo.org
>>> Expert service straight from the developers.
>>>
>>> ------------------------------------------------------------------------------
>>> _______________________________________________
>>> Geoserver-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/geoserver-users
>>>
>>>
>>
>>
>>
>> --
>> I.R
>>
>
>
>


--
Justin Deoliveira
OpenGeo - http://opengeo.org
Enterprise support for open source geospatial.

------------------------------------------------------------------------------
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver on weblogic

sipayne
In reply to this post by Don Vollmer
Hi Andrea

The link to the WebLogic instructions for GeoServer doesn't work any more.  Do you know where they are, currently it leads to the home page of the 2.1 documentation.

thanks

Simon Payne