geoserver admin on websphere / wms issue without JAI

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

geoserver admin on websphere / wms issue without JAI

Gerald Estadieu-2
Hi,

I am working for a utility company where we are trying
to evaluate the possibility to use geoserver as a
geospatial server and integrates spatial data/map in
our internal web applications(customer related,
maintenance) and make it as our main GIS.

Our environment currently is:
- Websphere 5.1 on RedHat
- Informix database as well as PostGIS

I deployed geoserver on websphere and it works, I mean
the GetCapabilities for WFS and WMS are there and
seems valid.
However I still have a small issue:
when I connect to http://localhost/geoserver and after
login I cannot see any
of the menu, I have instead the following message
(sorry it is based on
WebSphere in french).
[ServletException in:/WEB-INF/pages/actionator.jsp]
/WEB-INF/pages/actionator.jsp(34,50) L'attribut .short
n'a pas de valeur.'
(translation: the attribute .short has no value), the
same problem for .label.
It is the same for all *tor.jsp pages.
Exactly the same problem occurs with Geoserver1.3RC1
or Geoserver 1.2.

Any ideas on this? I search JIRA but could not find
any answer.
I have not installed JAI lib so I understand that WMS
cannot generate
bitmap files but it looks like even in 1.3 (I tried
the mapbuilder demo
in data/mbdemo/) it does not generate a bitmap image,
anything I miss
there (when trying to get the svg file I've got:
<ServiceException
code="">javax/media/jai/util/Range</ServiceException>
</ServiceExceptionReport>
)? Of course I have the GetCapabilities sending back
xml file in
both WFS and WMS.
If I need to install JAI, any idea where I should put
it on websphere?
Thx a lot,
Gerald


       

       
               
___________________________________________________________________________
Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger
Téléchargez cette version sur http://fr.messenger.yahoo.com


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver admin on websphere / wms issue without JAI

Alessio Fabiani
I think that the problem is caused by the Applicationresources_fr.properties

This file should contain all the messages in the French language, if a
resource is missing you get an error like this.

Solutions:
1)
change Applicationresources_fr.properties like
Applicationresources.properties if you need the French version of
GeoServer

2)
delete Applicationresources_fr.properties if you want use only the
english(default) version


On 6/15/05, Gerald Estadieu <[hidden email]> wrote:

> Hi,
>
> I am working for a utility company where we are trying
> to evaluate the possibility to use geoserver as a
> geospatial server and integrates spatial data/map in
> our internal web applications(customer related,
> maintenance) and make it as our main GIS.
>
> Our environment currently is:
> - Websphere 5.1 on RedHat
> - Informix database as well as PostGIS
>
> I deployed geoserver on websphere and it works, I mean
> the GetCapabilities for WFS and WMS are there and
> seems valid.
> However I still have a small issue:
> when I connect to http://localhost/geoserver and after
> login I cannot see any
> of the menu, I have instead the following message
> (sorry it is based on
> WebSphere in french).
> [ServletException in:/WEB-INF/pages/actionator.jsp]
> /WEB-INF/pages/actionator.jsp(34,50) L'attribut .short
> n'a pas de valeur.'
> (translation: the attribute .short has no value), the
> same problem for .label.
> It is the same for all *tor.jsp pages.
> Exactly the same problem occurs with Geoserver1.3RC1
> or Geoserver 1.2.
>
> Any ideas on this? I search JIRA but could not find
> any answer.
> I have not installed JAI lib so I understand that WMS
> cannot generate
> bitmap files but it looks like even in 1.3 (I tried
> the mapbuilder demo
> in data/mbdemo/) it does not generate a bitmap image,
> anything I miss
> there (when trying to get the svg file I've got:
> <ServiceException
> code="">javax/media/jai/util/Range</ServiceException>
> </ServiceExceptionReport>
> )? Of course I have the GetCapabilities sending back
> xml file in
> both WFS and WMS.
> If I need to install JAI, any idea where I should put
> it on websphere?
> Thx a lot,
> Gerald
>
>
>
>
>
>
> ___________________________________________________________________________
> Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger
> Téléchargez cette version sur http://fr.messenger.yahoo.com
>
>
> -------------------------------------------------------
> SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
> from IBM. Find simple to follow Roadmaps, straightforward articles,
> informative Webcasts and more! Get everything you need to get up to
> speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
> _______________________________________________
> Geoserver-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geoserver-users
>


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. <a href="http://ads.osdn.com/?ad_idt77&alloc_id492&op=click">http://ads.osdn.com/?ad_idt77&alloc_id492&op=click
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver admin on websphere / wms issue without JAI

Gerald Estadieu-2
In reply to this post by Gerald Estadieu-2
Hi all,

I come back on the first issue first:
We finally identify the problem with a Websphere expert: it is a bug in WebSphere 5.1 (we tried also 5.2 and it is the same). The workaround is the following,
within *.jsp files whenever we have something similar to:
<%  }
    else {
%>             
          <html:link style="action"
                     forward="<%= forward %>"
                     titleKey='<%=forward+".short"%>'>
            <bean:message key='<%=forward+".label"%>'/>
          </html:link>
<%  }

we have modified it this way:
<%  }
    else {
        String sht = forward+".short";
    String lab = forward+".label";

%>             
          <html:link style="action"
                     forward="<%= forward %>"
                     titleKey='<%=sht %>'>
            <bean:message key='<%=lab %>'/>
          </html:link>
<%  }
Ok, I know it is not very clean but at least the web admin works fine on websphere. I would like to recommend developers to find a workaround to integrate it in GeoServer or if you have any contact with IBM guys to report this bug, in our side we are trying to find someone but it is not that easy within such big organization!
Thx to everybody for your help and great work.
Regards,
Gerald

Gerald Estadieu wrote:
Hi Alessio,
thanks for your answer. I have tried already to delete
the french file and use the english one but still
can't get the correct page...
I simply installed the default .war file so I do not
expect these properties files to be corrupted. I will
try to copy those from a windows installation.

Beside this the image generation is now working fine
without JAI for WMS.
Gerald
--- Alessio Fabiani [hidden email] a
écrit :

  
I think that the problem is caused by the
Applicationresources_fr.properties

This file should contain all the messages in the
French language, if a
resource is missing you get an error like this.

Solutions:
1) 
change Applicationresources_fr.properties like
Applicationresources.properties if you need the
French version of
GeoServer

2)
delete Applicationresources_fr.properties if you
want use only the
english(default) version


On 6/15/05, Gerald Estadieu [hidden email] wrote:
    
Hi,

I am working for a utility company where we are
      
trying
    
to evaluate the possibility to use geoserver as a
geospatial server and integrates spatial data/map
      
in
    
our internal web applications(customer related,
maintenance) and make it as our main GIS.

Our environment currently is:
- Websphere 5.1 on RedHat
- Informix database as well as PostGIS

I deployed geoserver on websphere and it works, I
      
mean
    
the GetCapabilities for WFS and WMS are there and
seems valid.
However I still have a small issue:
when I connect to http://localhost/geoserver and
      
after
    
login I cannot see any
of the menu, I have instead the following message
(sorry it is based on
WebSphere in french).
[ServletException
      
in:/WEB-INF/pages/actionator.jsp]
    
/WEB-INF/pages/actionator.jsp(34,50) L'attribut
      
.short
    
n'a pas de valeur.'
(translation: the attribute .short has no value),
      
the
    
same problem for .label.
It is the same for all *tor.jsp pages.
Exactly the same problem occurs with
      
Geoserver1.3RC1
    
or Geoserver 1.2.

Any ideas on this? I search JIRA but could not
      
find
    
any answer.
I have not installed JAI lib so I understand that
      
WMS
    
cannot generate
bitmap files but it looks like even in 1.3 (I
      
tried
    
the mapbuilder demo
in data/mbdemo/) it does not generate a bitmap
      
image,
    
anything I miss
there (when trying to get the svg file I've got:
<ServiceException

      
code="">javax/media/jai/util/Range</ServiceException>
  
</ServiceExceptionReport>
)? Of course I have the GetCapabilities sending
      
back
    
xml file in
both WFS and WMS.
If I need to install JAI, any idea where I should
      
put
    
it on websphere?
Thx a lot,
Gerald







      
___________________________________________________________________________
  
Appel audio GRATUIT partout dans le monde avec le
      
nouveau Yahoo! Messenger
    
Téléchargez cette version sur
      
http://fr.messenger.yahoo.com
    

      
-------------------------------------------------------
  
SF.Net email is sponsored by: Discover Easy Linux
      
Migration Strategies
    
from IBM. Find simple to follow Roadmaps,
      
straightforward articles,
    
informative Webcasts and more! Get everything you
      
need to get up to
    
speed, fast.
      
http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
  
_______________________________________________
Geoserver-users mailing list
[hidden email]

      
https://lists.sourceforge.net/lists/listinfo/geoserver-users
  



	

	
		
___________________________________________________________________________ 
Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger 
Téléchargez cette version sur http://fr.messenger.yahoo.com


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users