geoserver 2.6.1 likely XML error, not starting after computer reboot [SOLVED]

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

geoserver 2.6.1 likely XML error, not starting after computer reboot [SOLVED]

Parhjin
This post was updated on .
edit: found the culprits. Somehow a whole bunch of xml files in data_dir\security\filter ALL became containing only NUL. I replaced those files with clean copies from another installation of geoserver, restarted the geoserver service and we're back in business.
Thanks to all who replied.

------------------------------------------------------------------------------

Hi, I realise this is a very old version of geoserver and there are a lot of
changes by now, but I would appreciate if anybody could point me in the
right direction.. I have done quite a lot of googling, but in the first
place, this seems like a rare problem and the specifics are always different
for most cases.

1) I have geoserver 2.6.1 with java 1.8.0_25 (installed in folders
Java\jre1.8.0_25 and Java\jre8) on a server running Windows Server 2012 R2
Standard. Some OSM data are in an MS SQL server referenced from inside
Geoserver.
2) This setup was running perfectly fine for years, so there is no problem
with the configuration.
3) A recent reboot of the system made the geoserver maps unavailable, an
even the administration pages, both remotely and on the server itself.
4) The error was the famous "HTTP ERROR: 503 SERVICE_UNAVAILABLE". This
indicates the jetty server (and java) is running, but the geoserver could
not start. A check with the windows services indicates the geoserver service
is running. Restarting the geoserver service or rebooting the server did not
solve the problem.
5) Checking through the wrapper.log I think I found the relevant lines (with
some additional lines before and after for context):

INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms/*] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate/*] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 2019-05-23 20:29:16.995::WARN:
Failed startup of context
org.mortbay.jetty.webapp.WebAppContext@1087a7b{/geoserver,file:/C:/Program%20Files%20(x86)/GeoServer%202.6.1/webapps/geoserver/}
INFO   | jvm 1    | 2019/05/23 20:29:16 | java.lang.RuntimeException:
com.thoughtworks.xstream.io.StreamException:  : only whitespace content
allowed before start tag and not \u0 (position: START_DOCUMENT seen \u0...
@1:1)
INFO   | jvm 1    | 2019/05/23 20:29:16 | at
org.geoserver.security.GeoServerSecurityManager.onApplicationEvent(GeoServerSecurityManager.java:335)
INFO   | jvm 1    | 2019/05/23 20:29:16 | at
org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:97)
INFO   | jvm 1    | 2019/05/23 20:29:16 | at
org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:327)
INFO   | jvm 1    | 2019/05/23 20:29:16 | at
org.geoserver.platform.GeoServerContextLoaderListener.contextInitialized(GeoServerContextLoaderListener.java:26)
INFO   | jvm 1    | 2019/05/23 20:29:16 | at
org.mortbay.jetty.handler.ContextHandler.startContext(ContextHandler.java:540)


6) some more googling tells me that this is because an XML file being read
is not formatted properly. Because everything was working fine before, I
guess that this file was corrupted somehow. But I could not find the
affected file.

7) comparing with the log from a normal start up on the same machine tells
me that the affected part is probably the security section (but I still
could not find the affected file, if it is really that problem):

INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms/*] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate/*] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - AuthenticationCache Initialized with 1000 Max
Entries, 300 seconds idle time, 600 seconds time to live and 3 concurrency
level
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - AuthenticationCache Eviction Task created to run
every 600 seconds
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - Start reloading user/grous for service named default
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - Reloading user/groups successful for service named
default
INFO   | jvm 1    | 2019/05/02 15:17:36 | 2019-05-02 15:17:36.354::INFO:
Opened C:\Program Files (x86)\GeoServer 2.6.1\logs\2019_05_02.request.log


8) how do I proceed from here? short of reinstalling the whole thing with
the latest version (that opens a can with some worms, like migrating the
data over and configuring everything again)

Thanks in advance for any advice.
rgds
PJ



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-User-f3786390.html


_______________________________________________
Geoserver-users mailing list

Please make sure you read the following two resources before posting to this list:
- Earning your support instead of buying it, but Ian Turton: http://www.ianturton.com/talks/foss4g.html#/
- The GeoServer user list posting guidelines: http://geoserver.org/comm/userlist-guidelines.html

If you want to request a feature or an improvement, also see this: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer


Geoserver-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: geoserver 2.6.1 likely XML error, not starting after computer reboot

Ian Turton
Your best bet is to restore your data directory from yesterday's backup.

Ian

On Fri, 24 May 2019 at 08:55, Parhjin <[hidden email]> wrote:
Hi, I realise this is a very old version of geoserver and there are a lot of
changes by now, but I would appreciate if anybody could point me in the
right direction.. I have done quite a lot of googling, but in the first
place, this seems like a rare problem and the specifics are always different
for most cases.

1) I have geoserver 2.6.1 with java 1.8.0_25 (installed in folders
Java\jre1.8.0_25 and Java\jre8) on a server running Windows Server 2012 R2
Standard. Some OSM data are in an MS SQL server referenced from inside
Geoserver.
2) This setup was running perfectly fine for years, so there is no problem
with the configuration.
3) A recent reboot of the system made the geoserver maps unavailable, an
even the administration pages, both remotely and on the server itself.
4) The error was the famous "HTTP ERROR: 503 SERVICE_UNAVAILABLE". This
indicates the jetty server (and java) is running, but the geoserver could
not start. A check with the windows services indicates the geoserver service
is running. Restarting the geoserver service or rebooting the server did not
solve the problem.
5) Checking through the wrapper.log I think I found the relevant lines (with
some additional lines before and after for context):

INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms/*] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 23 May 20:29:16 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate/*] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/23 20:29:16 | 2019-05-23 20:29:16.995::WARN:
Failed startup of context
org.mortbay.jetty.webapp.WebAppContext@1087a7b{/geoserver,file:/C:/Program%20Files%20(x86)/GeoServer%202.6.1/webapps/geoserver/}
INFO   | jvm 1    | 2019/05/23 20:29:16 | java.lang.RuntimeException:
com.thoughtworks.xstream.io.StreamException:  : only whitespace content
allowed before start tag and not \u0 (position: START_DOCUMENT seen \u0...
@1:1)
INFO   | jvm 1    | 2019/05/23 20:29:16 |       at
org.geoserver.security.GeoServerSecurityManager.onApplicationEvent(GeoServerSecurityManager.java:335)
INFO   | jvm 1    | 2019/05/23 20:29:16 |       at
org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:97)
INFO   | jvm 1    | 2019/05/23 20:29:16 |       at
org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:327)
INFO   | jvm 1    | 2019/05/23 20:29:16 |       at
org.geoserver.platform.GeoServerContextLoaderListener.contextInitialized(GeoServerContextLoaderListener.java:26)
INFO   | jvm 1    | 2019/05/23 20:29:16 |       at
org.mortbay.jetty.handler.ContextHandler.startContext(ContextHandler.java:540)


6) some more googling tells me that this is because an XML file being read
is not formatted properly. Because everything was working fine before, I
guess that this file was corrupted somehow. But I could not find the
affected file.

7) comparing with the log from a normal start up on the same machine tells
me that the affected part is probably the security section (but I still
could not find the affected file, if it is really that problem):

INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/wms/*] onto handler 'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:35 | 02 May 15:17:35 INFO
[ows.OWSHandlerMapping] - Mapped URL path [/animate/*] onto handler
'dispatcher'
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - AuthenticationCache Initialized with 1000 Max
Entries, 300 seconds idle time, 600 seconds time to live and 3 concurrency
level
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - AuthenticationCache Eviction Task created to run
every 600 seconds
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - Start reloading user/grous for service named default
INFO   | jvm 1    | 2019/05/02 15:17:36 | 02 May 15:17:36 INFO
[geoserver.security] - Reloading user/groups successful for service named
default
INFO   | jvm 1    | 2019/05/02 15:17:36 | 2019-05-02 15:17:36.354::INFO:
Opened C:\Program Files (x86)\GeoServer 2.6.1\logs\2019_05_02.request.log


8) how do I proceed from here? short of reinstalling the whole thing with
the latest version (that opens a can with some worms, like migrating the
data over and configuring everything again)

Thanks in advance for any advice.
rgds
PJ



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoServer-User-f3786390.html


_______________________________________________
Geoserver-users mailing list

Please make sure you read the following two resources before posting to this list:
- Earning your support instead of buying it, but Ian Turton: http://www.ianturton.com/talks/foss4g.html#/
- The GeoServer user list posting guidelines: http://geoserver.org/comm/userlist-guidelines.html

If you want to request a feature or an improvement, also see this: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer


[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users


--
Ian Turton


_______________________________________________
Geoserver-users mailing list

Please make sure you read the following two resources before posting to this list:
- Earning your support instead of buying it, but Ian Turton: http://www.ianturton.com/talks/foss4g.html#/
- The GeoServer user list posting guidelines: http://geoserver.org/comm/userlist-guidelines.html

If you want to request a feature or an improvement, also see this: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer


[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users