[gdal-dev] transformation failure from WGS 84 to GRS 1980

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] transformation failure from WGS 84 to GRS 1980

Saulteau Don

Afternoon!

I recently upgraded to gdal 2.2.2 from 2.1 on linux and when I try to use ogr2ogr to append/update an existing table in PostgreSQL/PostGIS the command fails because it can't apply a transformation.

The command works fine in gdal 2.1.

The command I'm using is:

ogr2ogr -update -append -gt unlimited -progress -f PostgreSQL pg:"host=sfngis dbname=witaskewin" input_tlus_pts.shp -nln fn_sfn.sfn_tlus_flg_pt -lco GEOMETRY_NAME=geom -s_srs "EPSG:4326" -t_srs "EPSG:3005" -dim 2

The first part of the error says:

ERROR 6: Failed to initialize PROJ.4 with `+proj=longlat +datum=WGS84 +no_defs'.
unknown elliptical parameter name
ERROR 1: Failed to create coordinate transformation between the
following coordinate systems.  This may be because they
are not transformable, or because projection services
(PROJ.4 DLL/.so) could not be loaded.

Here's the details on the source and target projections:

ERROR 1: Source:
GEOGCS["WGS 84",
    DATUM["WGS_1984",
        SPHEROID["WGS 84",6378137,298.257223563,
            AUTHORITY["EPSG","7030"]],
        AUTHORITY["EPSG","6326"]],
    PRIMEM["Greenwich",0,
        AUTHORITY["EPSG","8901"]],
    UNIT["degree",0.0174532925199433,
        AUTHORITY["EPSG","9122"]],
    AUTHORITY["EPSG","4326"]]
ERROR 1: Target:
PROJCS["NAD83 / BC Albers",
    GEOGCS["NAD83",
        DATUM["North_American_Datum_1983",
            SPHEROID["GRS 1980",6378137,298.257222101,
                AUTHORITY["EPSG","7019"]],
            TOWGS84[0,0,0,0,0,0,0],
            AUTHORITY["EPSG","6269"]],
        PRIMEM["Greenwich",0,
            AUTHORITY["EPSG","8901"]],
        UNIT["degree",0.0174532925199433,
            AUTHORITY["EPSG","9122"]],
        AUTHORITY["EPSG","4269"]],
    PROJECTION["Albers_Conic_Equal_Area"],
    PARAMETER["standard_parallel_1",50],
    PARAMETER["standard_parallel_2",58.5],
    PARAMETER["latitude_of_center",45],
    PARAMETER["longitude_of_center",-126],
    PARAMETER["false_easting",1000000],
    PARAMETER["false_northing",0],
    UNIT["metre",1,
        AUTHORITY["EPSG","9001"]],
    AXIS["Easting",EAST],
    AXIS["Northing",NORTH],
    AUTHORITY["EPSG","3005"]]

It looks like gdal is able to find libproj.so:

% ldd /usr/lib/libgdal.so | grep proj
        libproj.so.12 => /usr/lib/libproj.so.12 (0x00007f1e67458000)

-- 
Kind regards,

Donovan

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: transformation failure from WGS 84 to GRS 1980

Andre Joost
Am 09.11.2017 um 20:52 schrieb Donovan Cameron:
> Afternoon!
>
> I recently upgraded to gdal 2.2.2 from 2.1 on linux and when I try to
> use ogr2ogr to append/update an existing table in PostgreSQL/PostGIS the
> command fails because it can't apply a transformation.
>
> The command works fine in gdal 2.1.
>

Where did you get gdal 2.2.2 from? I don't see it in any Ubuntu or
Ubuntugis package.

Greetings,
André Joost


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: transformation failure from WGS 84 to GRS 1980

Saulteau Don
I'm running Arch Linux :)

On Nov 10, 2017 01:08, "Andre Joost" <[hidden email]> wrote:
Am 09.11.2017 um 20:52 schrieb Donovan Cameron:
Afternoon!

I recently upgraded to gdal 2.2.2 from 2.1 on linux and when I try to
use ogr2ogr to append/update an existing table in PostgreSQL/PostGIS the
command fails because it can't apply a transformation.

The command works fine in gdal 2.1.


Where did you get gdal 2.2.2 from? I don't see it in any Ubuntu or Ubuntugis package.

Greetings,
André Joost


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: transformation failure from WGS 84 to GRS 1980

Andre Joost
Am 11.11.2017 um 08:45 schrieb Saulteau Don:
> I'm running Arch Linux :)
>

I don't have that running, but looking at
https://www.archlinux.org/packages/?sort=&q=gdal&maintainer=&flagged=

I see a package 2.2.2-2 from 2017-11-09 and a package 2.2.2-3 from today.

Maybe the packaging went wrong on their side.

Greetings,
André Joost


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: transformation failure from WGS 84 to GRS 1980

Saulteau Don
I noticed that qgis built against the version I'm running also asks for the transformation.

Maybe something to do with the differing ellipsoids.

On Nov 11, 2017 08:06, "Andre Joost" <[hidden email]> wrote:
Am 11.11.2017 um 08:45 schrieb Saulteau Don:
I'm running Arch Linux :)


I don't have that running, but looking at https://www.archlinux.org/packages/?sort=&q=gdal&maintainer=&flagged=

I see a package 2.2.2-2 from 2017-11-09 and a package 2.2.2-3 from today.

Maybe the packaging went wrong on their side.


Greetings,
André Joost


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev