[gdal-dev] gdal 2.3.0 with openjpeg 2.3 support

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] gdal 2.3.0 with openjpeg 2.3 support

Donato.AIRAGHI
Hi,

I'm trying to compile 
Gdal 2.3.0  on Centos 6.9 where compiled openjpeg 2.3.0  

I get :
....
Kakadu support:            no
JasPer support:            no
OpenJPEG support:          no
ECW support:               no
MrSID support:             yes
......

On the same system with gdal 2.2.2 and openjpeg 2.3.0  I get 
.....
Kakadu support:            no
JasPer support:            no
OpenJPEG support:          yes
ECW support:               no
MrSID support:             yes
...


This the configure line :

./configure --with-python=yes  --with-pg=/usr/pgsql-9.3/bin/pg_config --with-geos=yes --with-curl=/usr/bin/curl-config --with-mrsid=/opt/MrSID/Raster_DSDK/ --with-jp2mrsid=no --with-mrsid_lidar=/opt/MrSID/Lidar_DSDK/ --with-sqlite3 --with-podofo=yes --with-hdf4=/opt/HDF/hdf-4.2.13 --with-hdf5=/opt/HDF/hdf-5.1.8.21 --with-openjpeg=/usr/local --with-jasper=no --with-ecw=no --with-threads --with-spatialite=yes


Could you please help me finding an explanation to this behaviour ?
Thanks,




 

Donato Airaghi

  

System Administrator

Serco s.p.a


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: gdal 2.3.0 with openjpeg 2.3 support

Even Rouault-2
On mercredi 13 juin 2018 15:59:24 CEST [hidden email] wrote:

> Hi,
>
> I'm trying to compile
> Gdal 2.3.0  on Centos 6.9 where compiled openjpeg 2.3.0
>
> I get :
> ....
> Kakadu support:            no
> JasPer support:            no
> OpenJPEG support:          no
> ECW support:               no
> MrSID support:             yes
> ......
>
> On the same system with gdal 2.2.2 and openjpeg 2.3.0  I get
> .....
> Kakadu support:            no
> JasPer support:            no
> OpenJPEG support:          yes
> ECW support:               no
> MrSID support:             yes
> ...
>
>
> This the configure line :
>
> ./configure --with-python=yes  --with-pg=/usr/pgsql-9.3/bin/pg_config
> --with-geos=yes --with-curl=/usr/bin/curl-config
> --with-mrsid=/opt/MrSID/Raster_DSDK/ --with-jp2mrsid=no
> --with-mrsid_lidar=/opt/MrSID/Lidar_DSDK/ --with-sqlite3 --with-podofo=yes
> --with-hdf4=/opt/HDF/hdf-4.2.13 --with-hdf5=/opt/HDF/hdf-5.1.8.21
> --with-openjpeg=/usr/local --with-jasper=no --with-ecw=no --with-threads
> --with-spatialite=yes
>
>
> Could you please help me finding an explanation to this behaviour ?

Donato,

You probably need to install pkg-config since it is required now in GDAL 2.3
to detect openjpeg. Previous GDAL versions had a painful manual way of
detecting openjpeg that has been simpilfied in GDAL 2.3 configure code.

If I look for openjp2 in the config.log file generated by configure, here are
the relevant lines:

configure:27477: $PKG_CONFIG --exists --print-errors "libopenjp2 >= 2.1.0"
configure:27480: $? = 0
configure:27495: $PKG_CONFIG --exists --print-errors "libopenjp2 >= 2.1.0"
configure:27498: $? = 0
configure:27534: result: yes
configure:27544: checking for opj_setup_decoder in -lopenjp2
configure:27569: gcc -o conftest -DHAVE_AVX_AT_COMPILE_TIME -
DHAVE_SSSE3_AT_COMPILE_TIME -DHAVE_SSE_AT_COMPILE_TIME -fPIC  -g -DDEBUG -
ftrapv -fvisibility=hidden   conftest.c -lopenjp2  -lopenjp2 >&5
configure:27569: $? = 0
configure:27578: result: yes

Even

--
Spatialys - Geospatial professional services
http://www.spatialys.com
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: gdal 2.3.0 with openjpeg 2.3 support

Donato.AIRAGHI

Hi Even,Vincent,

is true, the problem is pkg-config
On my Centos 6 is  already installed  version 0.23  that is the official release in Cento 6 repository.
With this release (0.23) the var PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/ does not work

If I compile pkgconfig 0.29.1 i can get
.....
 OpenJPEG support:          yes
...

but with  make command  I get there errors on libcurl:
......
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_multi_info_read'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_slist_append'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_multi_add_handle'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_easy_perform'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_multi_perform'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_multi_cleanup'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_easy_init'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_easy_cleanup'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_multi_remove_handle'
/home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to `curl_easy_setopt'
............


I'm compiling pkgconfig with:
./configure --prefix=/usr --with-internal-glib --disable-host-tool


Do you know an option or solution for compile pkgconfig avoiding these errors on curl?
There are notes for compile GDAL 2.3.0 on Centos 6 with openjpeg support?

Thanks a lot, guys







Donato Airaghi

System Administrator
Serco s.p.a - JRC Ispra

________________________________________
From: Even Rouault [[hidden email]]
Sent: 13 June 2018 18:16
To: [hidden email]
Cc: AIRAGHI Donato (JRC-ISPRA-EXT)
Subject: Re: [gdal-dev] gdal 2.3.0 with openjpeg 2.3 support

On mercredi 13 juin 2018 15:59:24 CEST [hidden email] wrote:

> Hi,
>
> I'm trying to compile
> Gdal 2.3.0  on Centos 6.9 where compiled openjpeg 2.3.0
>
> I get :
> ....
> Kakadu support:            no
> JasPer support:            no
> OpenJPEG support:          no
> ECW support:               no
> MrSID support:             yes
> ......
>
> On the same system with gdal 2.2.2 and openjpeg 2.3.0  I get
> .....
> Kakadu support:            no
> JasPer support:            no
> OpenJPEG support:          yes
> ECW support:               no
> MrSID support:             yes
> ...
>
>
> This the configure line :
>
> ./configure --with-python=yes  --with-pg=/usr/pgsql-9.3/bin/pg_config
> --with-geos=yes --with-curl=/usr/bin/curl-config
> --with-mrsid=/opt/MrSID/Raster_DSDK/ --with-jp2mrsid=no
> --with-mrsid_lidar=/opt/MrSID/Lidar_DSDK/ --with-sqlite3 --with-podofo=yes
> --with-hdf4=/opt/HDF/hdf-4.2.13 --with-hdf5=/opt/HDF/hdf-5.1.8.21
> --with-openjpeg=/usr/local --with-jasper=no --with-ecw=no --with-threads
> --with-spatialite=yes
>
>
> Could you please help me finding an explanation to this behaviour ?

Donato,

You probably need to install pkg-config since it is required now in GDAL 2.3
to detect openjpeg. Previous GDAL versions had a painful manual way of
detecting openjpeg that has been simpilfied in GDAL 2.3 configure code.

If I look for openjp2 in the config.log file generated by configure, here are
the relevant lines:

configure:27477: $PKG_CONFIG --exists --print-errors "libopenjp2 >= 2.1.0"
configure:27480: $? = 0
configure:27495: $PKG_CONFIG --exists --print-errors "libopenjp2 >= 2.1.0"
configure:27498: $? = 0
configure:27534: result: yes
configure:27544: checking for opj_setup_decoder in -lopenjp2
configure:27569: gcc -o conftest -DHAVE_AVX_AT_COMPILE_TIME -
DHAVE_SSSE3_AT_COMPILE_TIME -DHAVE_SSE_AT_COMPILE_TIME -fPIC  -g -DDEBUG -
ftrapv -fvisibility=hidden   conftest.c -lopenjp2  -lopenjp2 >&5
configure:27569: $? = 0
configure:27578: result: yes

Even

--
Spatialys - Geospatial professional services
http://www.spatialys.com
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: gdal 2.3.0 with openjpeg 2.3 support

Even Rouault-2
On mercredi 20 juin 2018 09:48:13 CEST [hidden email] wrote:

> Hi Even,Vincent,
>
> is true, the problem is pkg-config
> On my Centos 6 is  already installed  version 0.23  that is the official
> release in Cento 6 repository. With this release (0.23) the var
> PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/ does not work
>
> If I compile pkgconfig 0.29.1 i can get
> .....
>  OpenJPEG support:          yes
> ...
>
> but with  make command  I get there errors on libcurl:
> ......
> /home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to
> `curl_multi_info_read' /home/software/gdal-2.3.0/.libs/libgdal.so:
> undefined reference to `curl_slist_append'
> /home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to
> `curl_multi_add_handle' /home/software/gdal-2.3.0/.libs/libgdal.so:
> undefined reference to `curl_easy_perform'
> /home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to
> `curl_multi_perform' /home/software/gdal-2.3.0/.libs/libgdal.so: undefined
> reference to `curl_multi_cleanup'
> /home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to
> `curl_easy_init' /home/software/gdal-2.3.0/.libs/libgdal.so: undefined
> reference to `curl_easy_cleanup'
> /home/software/gdal-2.3.0/.libs/libgdal.so: undefined reference to
> `curl_multi_remove_handle' /home/software/gdal-2.3.0/.libs/libgdal.so:
> undefined reference to `curl_easy_setopt' ............
>

Is CURL still found by GDAL ./configure ? It looks like no. There shouldn't be
normally any interference between openjpeg / pkgconfig and curl, since
openjpeg doesn't use curl, and curl detection is unrelated to pkgconfig

--
Spatialys - Geospatial professional services
http://www.spatialys.com
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev