[gdal-dev] Segfault when accessing vpf dqyarea

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Segfault when accessing vpf dqyarea

Mike Swope

So using Ubuntu 16.04, and Ubuntu gis-unstable ppa, which has gdal 2.2.2. 

Sample data

https://dnc.nga.mil/DNC/library.php?c=C12

Direct link

https://dnc.nga.mil/DNCSiteContent/StaticFiles/data12/vpf/coa12f.zip

I can do an ogrinfo gltp:/vrf/path/DNC12/COA12F

and get all the layers. I can pick any layer to get further info on, except dqyarea@dqy(*)_area, where it then segfaults. I'm unsure if this is a bug or on how it was packaged.

Of note, gdal 2.2.0 (from qgis 2.18.9) on Windows reads dqyarea fine. 

Any tips on how to read the layer?

-Mike


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Segfault when accessing vpf dqyarea

Even Rouault-2

Mike,

 

I could replicate. The issue is not in GDAL, but in the underlying ogdi library. Ubuntu 16.04 ships with ogdi 3.2.0-beta2. With final ogdi 3.2.0 (available in Ubuntu zesty), the crash no longer occurs.

 

Compiling ogdi from source for modern distributions is a bit of a pain. You could probably try building from the source package of ogdi in ubuntu 16.04 and substituting the ogdi-3.2.0.tar.gz toogdi-dfsg_3.2.0~beta2.orig.tar.gz

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev