Opinions on script naming (I also tought to ogrcat.py to reflect the similarity with the Unix cat
utility used to concatenate files), option naming, etc.. are welcome
ogrmerge.py is good name for the script.
I would rename -overwrite_lyr into -overwrite_layer. It pays only two letters, "layer" is already used in other parameters, and users would understand with less thinking what it means.