[gdal-dev] Problem building GDAL with GEOS on Cygwin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Problem building GDAL with GEOS on Cygwin

Roberto Ribeiro
Hello list, I'm trying to build GDAL 2.3 on Cygwin, and have been running amok with the GEOS option. I present the correct path for the geos_config file during ./configure, it does not throw any error, but after configuration is done, GEOS support is marked as "no". And, sure enough, while the script runs:

    libwebp not found - WEBP support disabled
    checking for bin... no
    checking for sfcgal-config... no

This shows that it did find the file, else it'd show "checking for geos-config", but it's not finding the bin dir (which is the same one where geos_config is). How might I fix this?

P.S.: it's GEOS 3.6.3, compiled with cygwin, working.

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Problem building GDAL with GEOS on Cygwin

Marco Atzeri
On 5/30/2018 1:04 AM, Roberto Ribeiro wrote:

> Hello list, I'm trying to build GDAL 2.3 on Cygwin, and have been
> running amok with the GEOS option. I present the correct path for the
> geos_config file during ./configure, it does not throw any error, but
> after configuration is done, GEOS support is marked as "no". And, sure
> enough, while the script runs:
>
>      libwebp not found - WEBP support disabled
>      checking for bin... no
>      checking for sfcgal-config... no
>
> This shows that it did find the file, else it'd show "checking for
> geos-config", but it's not finding the bin dir (which is the same one
> where geos_config is). How might I fix this?
>
> P.S.: it's GEOS 3.6.3, compiled with cygwin, working.

check config.log output for guidance
on 2.3.0 with geos 3.5.1 the output is:

configure:32848: checking for geos-config
configure:32866: found /usr/bin/geos-config
configure:32879: result: /usr/bin/geos-config
configure:32979: checking for GEOS version >= 3.1.0
configure:33002: result: yes
configure:33032: checking for GEOSversion in -lgeos_c
configure:33058: gcc -o conftest.exe -I/usr/include   conftest.c -lgeos_c
        -L/usr/lib -lgeos_c >&5
configure:33058: $? = 0
configure:33067: result: yes
configure:33090: Using C API from GEOS 3.5.1
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev