[gdal-dev] Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

Even Rouault-2

Hi,

 

As you may have noticed from recent emails, support for C++11 in VS 2013 is only partial and kind a bit of a pain to deal with

 

I've created a poll to probe the community how much support for VS 2013 is seen as needed for GDAL 2.3

 

Please cast your vote (doesn't require any account, open to any user / developer / whatever party with at least some interest in GDAL ) at

 

http://www.easypolls.net/poll.html?p=5a399ccfe4b04ebe73ddb454

 

Voting opened until end of this week

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

Kurt Schwehr-2
And if you have a need for MSVC 2013, it would be good to a note or two of why you can't use MSVC 2015 or newer.  I don't remember seeing any requirements for MSVC 2013 in the RFC 68 discussions and the RFC states that MSVC 2015 would be the new minimum required version.

I just took a pass at updating the supported compiler list.  Please add more tested configs.  I mostly just wanted to get statements about supporting old platforms out of there.


On Tue, Dec 19, 2017 at 3:20 PM, Even Rouault <[hidden email]> wrote:

Hi,

 

As you may have noticed from recent emails, support for C++11 in VS 2013 is only partial and kind a bit of a pain to deal with

 

I've created a poll to probe the community how much support for VS 2013 is seen as needed for GDAL 2.3

 

Please cast your vote (doesn't require any account, open to any user / developer / whatever party with at least some interest in GDAL ) at

 

http://www.easypolls.net/poll.html?p=5a399ccfe4b04ebe73ddb454

 

Voting opened until end of this week

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev



--

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

jmckenna
Administrator
On 2017-12-19 7:01 PM, Kurt Schwehr wrote:
>
> I just took a pass at updating the supported compiler list.  Please add
> more tested configs.  I mostly just wanted to get statements about
> supporting old platforms out of there.
>
> https://trac.osgeo.org/gdal/wiki/SupportedCompilers
>

Thanks for this page Kurt.  Can you also make sure that it is linked to
from the main wiki opening page?  (so people can find it)
https://trac.osgeo.org/gdal/wiki   Thanks,

-jeff



_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

Kurt Schwehr-2
I'm hesitant to link that page in the main page.  It's not particularly complete and this was the first update in years.

On Wed, Dec 20, 2017 at 6:41 AM, Jeff McKenna <[hidden email]> wrote:
On 2017-12-19 7:01 PM, Kurt Schwehr wrote:

I just took a pass at updating the supported compiler list.  Please add more tested configs.  I mostly just wanted to get statements about supporting old platforms out of there.

https://trac.osgeo.org/gdal/wiki/SupportedCompilers


Thanks for this page Kurt.  Can you also make sure that it is linked to from the main wiki opening page?  (so people can find it) https://trac.osgeo.org/gdal/wiki   Thanks,

-jeff




_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev



--

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

jmckenna
Administrator
In reply to this post by jmckenna
On 2017-12-20 9:41 AM, Jeff McKenna wrote:
>> https://trac.osgeo.org/gdal/wiki/SupportedCompilers
>>
>
> Thanks for this page Kurt.  Can you also make sure that it is linked to
> from the main wiki opening page?  (so people can find it)
> https://trac.osgeo.org/gdal/wiki   Thanks,
>


ah I found it on BuildHints page.  Great!  Sorry for this noise.   -jeff


https://trac.osgeo.org/gdal/wiki/BuildHints





_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

Even Rouault-2
In reply to this post by Even Rouault-2

Hi,

 

OK so the results are 73 votes:

- 8% cannot use more recent than VS2013

- 55% are OK for VS2015 or later

- 37% don't care

 

So a large majority won't be affected by a requirement for VS2015 and later. Let's go for it, as it was mentionned in RFC 68 as underlined by Kurt.

 

I've replaced the VS2013 32bit AppVeyor target by a VS2017 32bit one (in addition to the existing VS2015 64bit)

 

Even

 

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Poll: is Visual Studio 2013 support needed for GDAL 2.3 ?

Mateusz Loskot
On 22 Dec 2017 17:48, "Even Rouault" <[hidden email]> wrote:

Hi,

 

OK so the results are 73 votes:

- 8% cannot use more recent than VS2013

- 55% are OK for VS2015 or later

- 37% don't care

 

So a large majority won't be affected by a requirement for VS2015 and later. Let's go for it, as it was mentionned in RFC 68 as underlined by Kurt.



Sweet. Thank you for the poll initiative and efforts. 

Mat 

 


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev