[gdal-dev] Issues configurign PostGIS with GDAL 1.11.2

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Issues configurign PostGIS with GDAL 1.11.2

Stefano Iacovella
Hi all,

sorry for the cross-posting, I am not sure whether the issue is more relevant to GDAL or PostGIS.

I tried to compile PostGIS 2.1.6 on my Linux Box but the first step end with an error:

~/sources/postgis-2.1.6 $ ./configure --with-gui
...
TOPOLOGY: Topology support requested
RASTER: Raster support requested
checking for gdal-config... /usr/local/bin/gdal-config
checking GDAL version... 1.11.2
checking for OGR enabled... yes
checking gdal.h usability... yes
checking gdal.h presence... yes
checking for gdal.h... yes
checking ogr_api.h usability... yes
checking ogr_api.h presence... yes
checking for ogr_api.h... yes
checking cpl_conv.h usability... yes
checking cpl_conv.h presence... yes
checking for cpl_conv.h... yes
checking for library containing GDALAllRegister... no
configure: error: could not find GDAL

It is the same Linux Box, Mint 17, on which I had previously successfully configured and compiled PostGIS 2.1.5 on GDAL 1.11.1  
The upgrade to GDAL 1.11.2 was done after the compilation of PostGIS 2.1.5 so I guess the problem may be related to this release.
I have in fact also tried to use the same configure command on sources for PostGIS 2.1.5 but got the same error.

Am I doing something wrong or is it a bug?

Thank you in advance for your help

Stefano
---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

_______________________________________________
gdal-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Issues configurign PostGIS with GDAL 1.11.2

Stefano Iacovella
May be I have found a clue about the issue.

Looking at the config.log I have found these rows:

| #define HAVE_GDAL_H 1
| #define HAVE_OGR_API_H 1
| #define HAVE_CPL_CONV_H 1
| /* end confdefs.h.  */
|
| /* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char GDALAllRegister ();
| int
| main ()
| {
| return GDALAllRegister ();
|   ;
|   return 0;
| }
configure:20670: gcc -o conftest  -I/usr/local/include  conftest.c -lgdal  -L/usr/local/lib -lgdal >&5
//home/stefano/arcsdetools/sdeexe102/lib/libsde.so: undefined reference to `pthread_atfork'
collect2: error: ld returned 1 exit status
configure:20670: $? = 1

could this error be the cause of the previous one?

I can't remember exactly when I installed the ArcSDE SDK and then recompiled GDAL but I am pretty sure it was after compiling PostGIS 2.1.5

Thanks again

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

2015-03-25 12:51 GMT+01:00 Stefano Iacovella <[hidden email]>:
Hi all,

sorry for the cross-posting, I am not sure whether the issue is more relevant to GDAL or PostGIS.

I tried to compile PostGIS 2.1.6 on my Linux Box but the first step end with an error:

~/sources/postgis-2.1.6 $ ./configure --with-gui
...
TOPOLOGY: Topology support requested
RASTER: Raster support requested
checking for gdal-config... /usr/local/bin/gdal-config
checking GDAL version... 1.11.2
checking for OGR enabled... yes
checking gdal.h usability... yes
checking gdal.h presence... yes
checking for gdal.h... yes
checking ogr_api.h usability... yes
checking ogr_api.h presence... yes
checking for ogr_api.h... yes
checking cpl_conv.h usability... yes
checking cpl_conv.h presence... yes
checking for cpl_conv.h... yes
checking for library containing GDALAllRegister... no
configure: error: could not find GDAL

It is the same Linux Box, Mint 17, on which I had previously successfully configured and compiled PostGIS 2.1.5 on GDAL 1.11.1  
The upgrade to GDAL 1.11.2 was done after the compilation of PostGIS 2.1.5 so I guess the problem may be related to this release.
I have in fact also tried to use the same configure command on sources for PostGIS 2.1.5 but got the same error.

Am I doing something wrong or is it a bug?

Thank you in advance for your help

Stefano
---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas


_______________________________________________
gdal-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/gdal-dev