[gdal-dev] Gdalwarp mosaic large GeoTIFF dataset into GeoPackage

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Gdalwarp mosaic large GeoTIFF dataset into GeoPackage

Matsamentet
Hi!

I'm trying to mosaic a large GeoTIFF dataset into a GeoPackage with Gdalwarp
(no reprojection). There are 512 .tif files, each with a single grayscale
band, and 1 meter resolution. I'm using -cutline to clip the dataset to a
slightly smaller extent.

Gdalwarp initially outputs the dimensions as 1 824 323P x 1 662 148L

I expect this operation to take quite some time, but it's now been five days
and there has been no other output than the message about the dimensions.
Gdalwarp.exe has been using 2-3% CPU and 5 GB of memory the entire time.
Since Gdalwarp usually outputs each filename as it's being processed, I'm
suspecting that something has gone wrong.

I'm describing a specific case here, but I've tried this several times in
the past with similar input data, with the same result. It seems that when
the output image is larger than a certain size, the process will not move
forward. Does anyone have experience with creating very large mosaic
GeoPackages in GDAL (performance hints etc.)?

/Command used:/
*gdalwarp --config GDAL_CACHEMAX 35% -multi -of GPKG -wo SKIP_NOSOURCE=YES
-co QUALITY=70 -cutline worldbounds.shp -csql "SELECT * FROM worldbounds
WHERE country='TheCountry'" *.tif output.gpkg*

/Hardware/software:/
Windows Server 2012 R2
Intel Xeon E7 4820
256 GB RAM
GDAL 2.3.0 released 2018/05/04



--
Sent from: http://osgeo-org.1560.x6.nabble.com/GDAL-Dev-f3742093.html
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev