[gdal-dev] Gdal2tiles -z not working

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Gdal2tiles -z not working

Stefano Iacovella
Dear all

I'm trying to use gdal2tiles.py and it seems --zoom parameter is not
working.

The testing configuration is:

Ubuntu 9.10
python 2.6.4
gdal 1.7.1 compiled from source with ECW support

gdal2tiles.py header is

#  $Id: gdal2tiles.py 18194 2009-12-06 20:07:45Z rouault $

If I run gdal2tiles without the --zoom parameter the output image
files are ok and I can preview any level without problem. The syntax
used for the TMS production is

gdal2tiles.py -r cubic -p raster source_dataset.ecw SOURCE_DATASET

If I run with this syntax

gdal2tiles.py -r cubic -p raster --zoom 0 ritaglio.ecw RITAGLIO

the output TMS contains a 0 level with a picture quite different form
those in the previous TMS 0 level. It seems like the image is strtched
up and left.
am I making some error?

Thanks in advance for any hints

Stefano
_______________________________________________
gdal-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/gdal-dev