[gdal-dev] Gdal compatibility to hdf4

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Gdal compatibility to hdf4

ankit yadav
Hello Everyone, 

I am a new user to data visualization tools and currently experiencing this problem with my installed gdal where I am not having hdf4 compatibility and because of this I can not deal with the hdf4 format files obtained from MODIS. 

can anyone help me with this?
I will be indebted to you all. 


thank you 

Ankit 
IISER mohali 

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Gdal compatibility to hdf4

Kurt Schwehr-2
You need to give details about your platform and gdal install.  I have been using gdal with hdf4 for modis for many years, so it is certainly possible

On Fri, Mar 27, 2020, 2:11 AM ankit yadav <[hidden email]> wrote:
Hello Everyone, 

I am a new user to data visualization tools and currently experiencing this problem with my installed gdal where I am not having hdf4 compatibility and because of this I can not deal with the hdf4 format files obtained from MODIS. 

can anyone help me with this?
I will be indebted to you all. 


thank you 

Ankit 
IISER mohali 
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Gdal compatibility to hdf4

Kurt Schwehr-2
+gdal-dev - re-added

There are multiple ways to get gdal on a mac.  Did you build it from source? Did you use macports, fink, homebrew, conda*, or something else?  What version of macosx and gdal do you have?

I use a specific git version of gdal and build with bazel in a custom environment, so you don't want what I have :). I used to be a fink packager, but I gave that up after 18 years

On Sun, Mar 29, 2020 at 10:06 AM ankit yadav <[hidden email]> wrote:
Hello Kurt
I am using a mac having macos catalina (10.15.4). 
i installed the GDAL with osgeo/osgeo4mac with the help of homebrew and it does not have any hdf4 raster driver. 

Could you help me with that?

if you could provide me a way to install the same version you are running on your platform. 
I think linux based platforms are running gdal with hdf4 but not on the mac. 

Thank you 

Ankit 
IISER Mohali 

On Sun, 29 Mar 2020 at 10:14 PM, Kurt Schwehr <[hidden email]> wrote:
You need to give details about your platform and gdal install.  I have been using gdal with hdf4 for modis for many years, so it is certainly possible

On Fri, Mar 27, 2020, 2:11 AM ankit yadav <[hidden email]> wrote:
Hello Everyone, 

I am a new user to data visualization tools and currently experiencing this problem with my installed gdal where I am not having hdf4 compatibility and because of this I can not deal with the hdf4 format files obtained from MODIS. 

can anyone help me with this?
I will be indebted to you all. 


thank you 

Ankit 
IISER mohali 
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev