[gdal-dev] GDAL dependencies

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] GDAL dependencies

Lars
Hello,

Does GDAL have an updated list of required and optional dependencies?

Tried looking on homepage and mailing list archive without any luck.

Thanks for any help.

kind regards, Lars




_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: GDAL dependencies

Even Rouault-2

On mardi 22 mai 2018 07:59:08 CEST Lars wrote:

> Hello,

>

> Does GDAL have an updated list of required and optional dependencies?

 

Lars,

 

Required: none currently, except a C++ compiler

But for usual functionalities, I'd suggest libsqlite3, libcurl, libexpat

 

You an consult the right most column of http://gdal.org/formats_list.html and http://www.gdal.org/ogr_formats.html to see which dependencies are needed to have support for which driver.

 

Looking at

https://github.com/OSGeo/gdal/blob/master/gdal/nmake.opt or

https://github.com/OSGeo/gdal/blob/master/gdal/configure.ac

will also give you the list of all potential dependencies.

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: GDAL dependencies

Ari Jolma-2
Even Rouault kirjoitti 22.05.2018 klo 11:05:

On mardi 22 mai 2018 07:59:08 CEST Lars wrote:

> Hello,

>

> Does GDAL have an updated list of required and optional dependencies?

 

Lars,

 

Required: none currently, except a C++ compiler


With C++ 11 support. I just run into this as I had a Debian 7 machine, whose gcc (4.7) does not support C++ 11.

Debian 7 EOL is next week so it was a reminder to update.

Ari

But for usual functionalities, I'd suggest libsqlite3, libcurl, libexpat

 

You an consult the right most column of http://gdal.org/formats_list.html and http://www.gdal.org/ogr_formats.html to see which dependencies are needed to have support for which driver.

 

Looking at

https://github.com/OSGeo/gdal/blob/master/gdal/nmake.opt or

https://github.com/OSGeo/gdal/blob/master/gdal/configure.ac

will also give you the list of all potential dependencies.

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com



_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: GDAL dependencies

Mateusz Loskot
On 22 May 2018 at 10:13, Ari Jolma <[hidden email]> wrote:
> Even Rouault kirjoitti 22.05.2018 klo 11:05:
>> On mardi 22 mai 2018 07:59:08 CEST Lars wrote:
>>
>> Does GDAL have an updated list of required and optional dependencies?
>
> Required: none currently, except a C++ compiler
>
> With C++ 11 support. I just run into this as I had a Debian 7 machine, whose
> gcc (4.7) does not support C++ 11.

Ari,

You *may* get away with GCC 4.7, since it implements a lot of C++11
https://gcc.gnu.org/gcc-4.7/cxx0x_status.html
Best bet though is to go with at least GCC 4.8.1 or later.

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: GDAL dependencies

Lars
In reply to this post by Even Rouault-2
Even,

Just the information that I needed. Thank you 😊


Fra: Even Rouault <[hidden email]>
Sendt: 22. mai 2018 10:05
Til: [hidden email]
Kopi: Lars
Emne: Re: [gdal-dev] GDAL dependencies
 

On mardi 22 mai 2018 07:59:08 CEST Lars wrote:

> Hello,

>

> Does GDAL have an updated list of required and optional dependencies?

 

Lars,

 

Required: none currently, except a C++ compiler

But for usual functionalities, I'd suggest libsqlite3, libcurl, libexpat

 

You an consult the right most column of http://gdal.org/formats_list.html and http://www.gdal.org/ogr_formats.html to see which dependencies are needed to have support for which driver.

 

Looking at

https://github.com/OSGeo/gdal/blob/master/gdal/nmake.opt or

https://github.com/OSGeo/gdal/blob/master/gdal/configure.ac

will also give you the list of all potential dependencies.

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: GDAL dependencies

Mateusz Loskot
In reply to this post by Lars
On 22 May 2018 at 09:59, Lars <[hidden email]> wrote:
> Hello,
>
> Does GDAL have an updated list of required and optional dependencies?
>
> Tried looking on homepage and mailing list archive without any luck.

Even has already covered the answer.

There is also this wiki, might need some updating love, which may help to derive
list of optional dependencies

https://trac.osgeo.org/gdal/wiki/BuildingOnUnixWithMinimizedDrivers

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev