[gdal-dev] GDAL Linux build / linking issue with ECW support

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[gdal-dev] GDAL Linux build / linking issue with ECW support

Candy, Liam

Hi,

 

I’m trying to build GDAL 2.2.1 with ECW (5.3) support. I’m having the linking issues that are documented on the wiki (https://trac.osgeo.org/gdal/wiki/ECW). I have tried the work around with the CXXFLAGS="-D_GLIBCXX_USE_CXX11_ABI=0" but without success, the issue persists (I’ve made sure the configure script is updating the CXXFLAGS in the make file - it is). Has anyone had a similar issue – and ideally a resolution ?

 

For reference, I’m on Ubuntu 17.04, gcc 6.3, GDAL 2.2.1, ERDAS ECW 5.3.0.

 

Best regards,

Liam.

 


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GDAL Linux build / linking issue with ECW support

Even Rouault-2

On mercredi 5 juillet 2017 09:13:14 CEST Candy, Liam wrote:

> Hi,

>

> I’m trying to build GDAL 2.2.1 with ECW (5.3) support. I’m having the

> linking issues that are documented on the wiki

> (https://trac.osgeo.org/gdal/wiki/ECW). I have tried the work around with

> the CXXFLAGS="-D_GLIBCXX_USE_CXX11_ABI=0" but without success, the issue

> persists (I’ve made sure the configure script is updating the CXXFLAGS in

> the make file - it is). Has anyone had a similar issue – and ideally a

> resolution ?

> For reference, I’m on Ubuntu 17.04, gcc 6.3, GDAL 2.2.1, ERDAS ECW 5.3.0.

>

 

Did you make sure to "make clean" between each of your attempts ?

 

On Ubuntu 16.04 with GCC 5.4, the following works (I have to explictly disable a few C++ libs from the system, since they have been built the CXX11 ABI)

CXXFLAGS="-D_GLIBCXX_USE_CXX11_ABI=0" ./configure --with-ecw=$HOME/hexagon/ERDAS-ECW_JPEG_2000_SDK-5.3.0 --without-libkml --without-armadillo --without-cryptopp

 

I've also tried with GCC 7.1, so I guess that should also work with gcc 6.3

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Loading...