[gdal-dev] Can't build GDAL from Source on Ubuntu Linux 16.04 x64

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Can't build GDAL from Source on Ubuntu Linux 16.04 x64

Alex-5
Hello List,

I'm new, so please bear with me. I'm having issues building GDAL from source-- specifically 2.3.3. I"m just trying to install it with the Extensis MrSID plugin. This seems to be the only pathway to read MrSID files. I have attached my errors and config logs. Any help is truly appreciated. 

I didn't want to post this on github issues, because I can almost guarantee I'm doing something wrong. lol. 

Thank you in advance. All of my system and version information can be gleaned from the configure.txt and make.txt in the links below. 



Thanks!

Alex

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: Can't build GDAL from Source on Ubuntu Linux 16.04 x64

Even Rouault-2
Alex,

GDAL doesn't set the rpath when linking to external libraries, which causes such issue with libtool-based builds
The fix is to define the paths to the MrSID libraries in LD_LIBRARY_PATH

export LD_LIBRARY_PATH=/home/edma/MrSID_DSDK-9.5.4.4709-rhel6.x86-64.gcc531/Raster_DSDK/lib:/home/edma/MrSID_DSDK-9.5.4.4709-rhel6.x86-64.gcc531/Lidar_DSDK/lib:$LD_LIBRARY_PATH

Note: in your make log, you also have unrelated linking issues with libkea. you probably attempted a previous build against it.
I suggest you 'make clean' each time you run ./configure before rebuilding

Even

--
Spatialys - Geospatial professional services
http://www.spatialys.com
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev