[gdal-dev] Building GDAL from source for android under cygwin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] Building GDAL from source for android under cygwin

Arnaldo Torres

Hi Petr Kitashov,

 

I am trying to follow the procedure that you described in http://lists.osgeo.org/pipermail/gdal-dev/2012-April/032485.html for building GDAL for Android, and to run it on an Android tablet. I am having a few problems understanding some of the steps, and I thought to try my luck to see if you still remember the details of this procedure. I am using the latest cygwin for x86 64-bits, with GDAL 2.2.3, on Windows 10. I am new to Android and a bit to Linux, so I hope that my questions are more than me just not digging deep enough to understand these steps (I apologize if that is the case), but I have been at it for a week now. Here are my questions:

a.       In Step 1 of the procedure, you recommend a file be created with the content  described so that g++ can understand Cygwin paths. Do you know what the name and extension of this file should be? I tried several extensions and names but “make” was never able to use Cygwin paths.

b.       On Step 2, you indicated that some text in the GDALMake.opt should be change. In particular, a line to be added with the following text: “CORRECT = correct_path”. I assumed that the correct_path meant the path to the tool-chain bin folder in cygwin format. Please indicate if this is not correct?

c.       When I run the “make” command, I get a .libs folder on the GDAL source file’s folder, which is the directory where I am running the make command in Cygwin. This folder contains libgdal.a, .la, .lai, and .libcmd files. No .so, or .so1, files were created. I am thinking that this may be a consequence of issue a. above. Does that sound correct?

d.       I am running on Windows 10 64-bit, there is no ldconfig executable in Cygwin sbin or the usr/sbin folders. The “make install” does not seem to complete correctly due to this. Any suggestion as to where to get ldconfig? I have not been able to find it yet.

Any help on these would be greatly appreciated. Thank you in advance!

 

Kind regards,

 

Arnaldo Torres

  Senior Software Engineer

 

AeroVironment Inc.

           Proceed with Certainty

 


_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev