[gdal-dev] Anyone interested in resurrecting PHP (7) bindings ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[gdal-dev] Anyone interested in resurrecting PHP (7) bindings ?

Even Rouault-2

Hi,

 

Seeing https://trac.osgeo.org/gdal/ticket/6770, I realized that we have in-tree PHP bindings...

They appear to still build with PHP 5 on an ancient distro, but they are broken with PHP 7.

 

I've tried the attached patch that attempts to use the -php7 flag available in SWIG 3.0.11 but this still results in build failures (see attached log).

 

Failing to find anyone interested, we'll have to disable

./configure --with-php

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
gdal-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/gdal-dev

php7.patch (2K) Download Attachment
build_log.txt (25K) Download Attachment
Loading...