[gdal-dev] 2.4 problem with OGRCoordinateTransformation?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[gdal-dev] 2.4 problem with OGRCoordinateTransformation?

andrew.bell.ia@gmail.com

I'm seeing an issue with OGRCoordinateTransformation where the first point passed to the transform is handled properly, but the second one is not.  I'm just seeing this on version 2.4.  Earlier versions are OK, as is 3.0 with identical code.  I don't know where the old tickets are, so I'm wondering if anyone was aware of an issue that might have been fixed after 2.4.

Thanks,

--
Andrew Bell
[hidden email]

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: 2.4 problem with OGRCoordinateTransformation?

Even Rouault-2
On lundi 15 juillet 2019 11:33:40 CEST Andrew Bell wrote:
> I'm seeing an issue with OGRCoordinateTransformation where the first point
> passed to the transform is handled properly, but the second one is not.
> I'm just seeing this on version 2.4.  Earlier versions are OK, as is 3.0
> with identical code.  I don't know where the old tickets are, so I'm
> wondering if anyone was aware of an issue that might have been fixed after
> 2.4.

Andrew,

Are you really sure about that ? I can't see related differences in
ogr/ogrct.cpp between 2.3 and 2.4 that would have that effect.

Even

--
Spatialys - Geospatial professional services
http://www.spatialys.com
_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev
Reply | Threaded
Open this post in threaded view
|

Re: 2.4 problem with OGRCoordinateTransformation?

andrew.bell.ia@gmail.com


On Mon, Jul 15, 2019 at 11:41 AM Even Rouault <[hidden email]> wrote:
On lundi 15 juillet 2019 11:33:40 CEST Andrew Bell wrote:
> I'm seeing an issue with OGRCoordinateTransformation where the first point
> passed to the transform is handled properly, but the second one is not.
> I'm just seeing this on version 2.4.  Earlier versions are OK, as is 3.0
> with identical code.  I don't know where the old tickets are, so I'm
> wondering if anyone was aware of an issue that might have been fixed after
> 2.4.

Andrew,

Are you really sure about that ? I can't see related differences in
ogr/ogrct.cpp between 2.3 and 2.4 that would have that effect.

I only know what's happening.  I was just trying to check if anyone remembered an issue.  I'll trace things through.

Thanks,
 
--
Andrew Bell
[hidden email]

_______________________________________________
gdal-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/gdal-dev