funny characters in react-viewer

Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

funny characters in react-viewer

pcardinal
mgos3.1 / Windows 2012 R2 / IIS / french language

<http://osgeo-org.1560.x6.nabble.com/file/t191709/Capture0.png>

I have funny characters before the titles like "Legend", "Selection", …. in
the react-viewer. What can it be?






--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: funny characters in react-viewer

Jackie Ng
Are you using the debug version of the viewer bundle (viewer-debug.js) ?

If so, it's a known problem. Webpack screws up font icons somehow in debug
mode, but the rest of the functionality is not compromised.

- Jackie



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: funny characters in react-viewer

pcardinal
No I am not using the debug version.



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: funny characters in react-viewer

Jackie Ng
That's strange. If it's not the debug viewer bundle I'm not sure what's going
on off the top of my head.

The fix is something I've already been planning to do anyways for the next
release, which is to upgrade the underlying Blueprint.js UI toolkit, which
will have the side-effect of switching their icons from fonts to SVG meaning
this scrambled characters in place of the actual icons effect no longer
happens as we won't be using font icons once the upgrade is done.

It may be something specific to Firefox (based on your screenshot). Does it
happen in Chrome or IE as well?

- Jackie



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users