error in WebServiceForm.js

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

error in WebServiceForm.js

italavera
Hi While Trying a sample using that widget whit get method I suppose I've found an error :) in WebServiceForm
Line 61
webServiceUrl += element.name + "=" + element.value + "&";
And replacing   this line with this one
 httpPayload.url += element.name + "=" + element.value + "&";
solves the problem

:D



-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Mapbuilder-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
Reply | Threaded
Open this post in threaded view
|

Re: error in WebServiceForm.js

Andreas Hocevar
Ignacio,

can you please give a bit more detail on your error? Like post the
config and context xmls and your html page, or even better a hosted
live example?

Thanks!
Andreas.

On Thu, Jul 17, 2008 at 9:56 PM, Ignacio Talavera
<[hidden email]> wrote:

> Hi While Trying a sample using that widget whit get method I suppose I've
> found an error :) in WebServiceForm
> Line 61
> webServiceUrl += element.name + "=" + element.value + "&";
> And replacing   this line with this one
>  httpPayload.url += element.name + "=" + element.value + "&";
> solves the problem
>
> :D
>
>
>
> -------------------------------------------------------------------------
> This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
> Build the coolest Linux based applications with Moblin SDK & win great
> prizes
> Grand prize is a trip for two to an Open Source event anywhere in the world
> http://moblin-contest.org/redirect.php?banner_id=100&url=/
> _______________________________________________
> Mapbuilder-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
>
>

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Mapbuilder-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
Reply | Threaded
Open this post in threaded view
|

Component Register off line

Cote, Paul
Hi Folks,

For the past few days I have been trying to access resources from the
MapBuilder site at codehaus.  When trying to access information such as

the component register:
http://nightly.communitymapbuilder.org/mapbuilder/docs/register/ 

as linked from the page:
http://communitymapbuilder.org/display/MAP/Developers+Guide 

I get:
"
Bad Gateway
The proxy server received an invalid response from an upstream server.
------------------------------------------------------------------------
--------
Apache/2.0.54 (Fedora) Server at demo.communitymapbuilder.org Port 80
"

I'm sorry if this is already a known issue.  Any work-arounds would be
appreciated.

Thanks


Paul B. Cote
Geographic Information Systems Specialist
Harvard University Graduate School of Design
http://www.gsd.harvard.edu/~pbcote

 



-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of
Andreas Hocevar
Sent: Thursday, July 17, 2008 5:03 PM
To: Ignacio Talavera
Cc: [hidden email]
Subject: Re: [Mapbuilder-users] error in WebServiceForm.js

Ignacio,

can you please give a bit more detail on your error? Like post the
config and context xmls and your html page, or even better a hosted
live example?

Thanks!
Andreas.

On Thu, Jul 17, 2008 at 9:56 PM, Ignacio Talavera
<[hidden email]> wrote:
> Hi While Trying a sample using that widget whit get method I suppose
I've

> found an error :) in WebServiceForm
> Line 61
> webServiceUrl += element.name + "=" + element.value + "&";
> And replacing   this line with this one
>  httpPayload.url += element.name + "=" + element.value + "&";
> solves the problem
>
> :D
>
>
>
>
------------------------------------------------------------------------
-
> This SF.Net email is sponsored by the Moblin Your Move Developer's
challenge
> Build the coolest Linux based applications with Moblin SDK & win great
> prizes
> Grand prize is a trip for two to an Open Source event anywhere in the
world
> http://moblin-contest.org/redirect.php?banner_id=100&url=/
> _______________________________________________
> Mapbuilder-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
>
>

------------------------------------------------------------------------
-
This SF.Net email is sponsored by the Moblin Your Move Developer's
challenge
Build the coolest Linux based applications with Moblin SDK & win great
prizes
Grand prize is a trip for two to an Open Source event anywhere in the
world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Mapbuilder-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-users

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Mapbuilder-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
Reply | Threaded
Open this post in threaded view
|

Re: error in WebServiceForm.js

italavera
In reply to this post by Andreas Hocevar
HI, sorry if I wasn't clear enough.

This is an extract from my config File and I suppose enough to understand my scenario :D.
.....................................................................
 <WebServiceForm id="webServiceForm">
          <htmlTagId>webServiceForm</htmlTagId>
          <targetModel>ResultModel</targetModel>
          <stylesheet>xsl/NtsForm.xsl</stylesheet>
          <requestStylesheet>xsl/Null.xsl</requestStylesheet>
          <webServiceUrl>http://10.90.0.192:11080/geoserver/wfs</webServiceUrl>
        </WebServiceForm>
      </widgets>
..............................................................................................
The NTsForm (I get it from mapbuilder distribution )
specifies a get method in the definition of the form,(method="get")
so when the scriptFile WebServiceForm.js is executed, the condition (in line 57) (httpPayload.method.toLowerCase() == "get") --> TRUE

(WebServiceForm.js)
Line 57  if (httpPayload.method.toLowerCase() == "get") {
              httpPayload.url = this.webServiceForm.action + "?";
              for (var i=0; i<this.webServiceForm.elements.length; ++i) {
                  var element = this.webServiceForm.elements[i];

Line 61        webServiceUrl += element.name + "=" + element.value + "&";
                  this.formElements[element.name] = element.value;

      }

webServiceUrl 
is an unknow property  (perhaps this.webServiceUrl would work),
but the correct property is httpPayload.url because in line 67 its create a newrequest

Line 67    this.targetModel.newRequest(this.targetModel,httpPayload);

So the error is fixed by replacing  Line 61 by this
httpPayload.url += element.name + "=" + element.value + "&"

I hope I have been clear enough :D
Regards

Nacho

On Thu, Jul 17, 2008 at 6:03 PM, Andreas Hocevar <[hidden email]> wrote:
Ignacio,

can you please give a bit more detail on your error? Like post the
config and context xmls and your html page, or even better a hosted
live example?

Thanks!
Andreas.

On Thu, Jul 17, 2008 at 9:56 PM, Ignacio Talavera
<[hidden email]> wrote:
> Hi While Trying a sample using that widget whit get method I suppose I've
> found an error :) in WebServiceForm
> Line 61
> webServiceUrl += element.name + "=" + element.value + "&";
> And replacing   this line with this one
>  httpPayload.url += element.name + "=" + element.value + "&";
> solves the problem
>
> :D
>
>
>
> -------------------------------------------------------------------------
> This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
> Build the coolest Linux based applications with Moblin SDK & win great
> prizes
> Grand prize is a trip for two to an Open Source event anywhere in the world
> http://moblin-contest.org/redirect.php?banner_id=100&url=/
> _______________________________________________
> Mapbuilder-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
>
>


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Mapbuilder-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
Reply | Threaded
Open this post in threaded view
|

Re: error in WebServiceForm.js

Andreas Hocevar
Thanks Ignacio, you are absolutely right.

Fixed in r4000.

Regards,
Andreas.

On Mon, Jul 21, 2008 at 4:47 PM, Ignacio Talavera
<[hidden email]> wrote:

> HI, sorry if I wasn't clear enough.
>
> This is an extract from my config File and I suppose enough to understand my
> scenario :D.
> .....................................................................
>  <WebServiceForm id="webServiceForm">
>           <htmlTagId>webServiceForm</htmlTagId>
>           <targetModel>ResultModel</targetModel>
>           <stylesheet>xsl/NtsForm.xsl</stylesheet>
>           <requestStylesheet>xsl/Null.xsl</requestStylesheet>
>
> <webServiceUrl>http://10.90.0.192:11080/geoserver/wfs</webServiceUrl>
>         </WebServiceForm>
>       </widgets>
> ..............................................................................................
> The NTsForm (I get it from mapbuilder distribution )
> specifies a get method in the definition of the form,(method="get")
> so when the scriptFile WebServiceForm.js is executed, the condition (in line
> 57) (httpPayload.method.toLowerCase() == "get") --> TRUE
>
> (WebServiceForm.js)
> Line 57  if (httpPayload.method.toLowerCase() == "get") {
>               httpPayload.url = this.webServiceForm.action + "?";
>               for (var i=0; i<this.webServiceForm.elements.length; ++i) {
>                   var element = this.webServiceForm.elements[i];
> Line 61        webServiceUrl += element.name + "=" + element.value + "&";
>                   this.formElements[element.name] = element.value;
>       }
>
> webServiceUrl  is an unknow property  (perhaps this.webServiceUrl would
> work),
> but the correct property is httpPayload.url because in line 67 its create a
> newrequest
>
> Line 67    this.targetModel.newRequest(this.targetModel,httpPayload);
>
> So the error is fixed by replacing  Line 61 by this
> httpPayload.url += element.name + "=" + element.value + "&"
>
> I hope I have been clear enough :D
> Regards
>
> Nacho
>
> On Thu, Jul 17, 2008 at 6:03 PM, Andreas Hocevar <[hidden email]>
> wrote:
>>
>> Ignacio,
>>
>> can you please give a bit more detail on your error? Like post the
>> config and context xmls and your html page, or even better a hosted
>> live example?
>>
>> Thanks!
>> Andreas.
>>
>> On Thu, Jul 17, 2008 at 9:56 PM, Ignacio Talavera
>> <[hidden email]> wrote:
>> > Hi While Trying a sample using that widget whit get method I suppose
>> > I've
>> > found an error :) in WebServiceForm
>> > Line 61
>> > webServiceUrl += element.name + "=" + element.value + "&";
>> > And replacing   this line with this one
>> >  httpPayload.url += element.name + "=" + element.value + "&";
>> > solves the problem
>> >
>> > :D
>> >
>> >
>> >
>> >
>> > -------------------------------------------------------------------------
>> > This SF.Net email is sponsored by the Moblin Your Move Developer's
>> > challenge
>> > Build the coolest Linux based applications with Moblin SDK & win great
>> > prizes
>> > Grand prize is a trip for two to an Open Source event anywhere in the
>> > world
>> > http://moblin-contest.org/redirect.php?banner_id=100&url=/
>> > _______________________________________________
>> > Mapbuilder-users mailing list
>> > [hidden email]
>> > https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
>> >
>> >
>
>

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Mapbuilder-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-users
Reply | Threaded
Open this post in threaded view
|

Re: Component Register off line

Andreas Hocevar
In reply to this post by Cote, Paul
Hi,

On Sun, Jul 20, 2008 at 6:52 PM, Cote, Paul <[hidden email]> wrote:
> For the past few days I have been trying to access resources from the
> MapBuilder site at codehaus.  When trying to access information such as
>
> the component register:
> http://nightly.communitymapbuilder.org/mapbuilder/docs/register/

The new URL is http://nightly.communitymapbuilder.org/1.5-rc1/mapbuilder/docs/register/

> as linked from the page:
> http://communitymapbuilder.org/display/MAP/Developers+Guide

The link there has been updated.

Thanks for spotting this!

Regards,
Andreas.

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Mapbuilder-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbuilder-users