error building libtiff from svn

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

error building libtiff from svn

David Burken
  Hi Frank,

Just fyi was getting build error with latest libgeotiff from svn.

libtool: link: ( cd ".libs" && rm -f "libgeotiff.la" && ln -s
"../libgeotiff.la" "libgeotiff.la" )
make[2]: *** No rule to make target `csv/codes.csv', needed by
`all-am'.  Stop.

Copied "codes.csv" from an old install to csv dir and build good.

This is on:

$ cat /etc/redhat-release
Fedora release 13 (Goddard)

Svn revision:
$ svn update
At revision 1922.

Configure line was(note libtiff from latest cvs, proj from svn):

./configure --prefix=/work/osgeo/local --with-proj=/work/osgeo/local
--with-libtiff=/work/osgeo/local

Prior to this I was getting a proj4 error but I lost that in my
history.  Installed proj and now get the above.

Take care,
Dave

_______________________________________________
Geotiff mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/geotiff
Reply | Threaded
Open this post in threaded view
|

Re: error building libtiff from svn

Frank Warmerdam
David Burken wrote:

>  Hi Frank,
>
> Just fyi was getting build error with latest libgeotiff from svn.
>
> libtool: link: ( cd ".libs" && rm -f "libgeotiff.la" && ln -s
> "../libgeotiff.la" "libgeotiff.la" )
> make[2]: *** No rule to make target `csv/codes.csv', needed by
> `all-am'.  Stop.
>
> Copied "codes.csv" from an old install to csv dir and build good.

Dave,

I can't see any reference to codes.csv in Makefile.am or anywhere in
the libgeotiff directory for that matter.

warmerda@gdal64[190]% pwd
/wrk/home/warmerda/libgeotiff
warmerda@gdal64[191]% grep codes.csv *
warmerda@gdal64[192]%

In particular, I have no csv/codes.csv in dist_csv_DATA in the
Makefile.am.


Is it possible you have an old makefile or are working from a tag or
branch?  You may need to run autogen.sh manually to regenerate the
Makefile.in, etc.

In particular, I have no csv/codes.csv in dist_csv_DATA in the

Best regards,
--
---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, [hidden email]
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

_______________________________________________
Geotiff mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/geotiff
Reply | Threaded
Open this post in threaded view
|

Re: error building libtiff from svn

David Burken
  Frank,

Sorry I didn't realize configure wasn't under svn.  The autogen did it.

Thanks,
Dave


On 10/12/2010 04:43 PM, Frank Warmerdam wrote:

> David Burken wrote:
>>  Hi Frank,
>>
>> Just fyi was getting build error with latest libgeotiff from svn.
>>
>> libtool: link: ( cd ".libs" && rm -f "libgeotiff.la" && ln -s
>> "../libgeotiff.la" "libgeotiff.la" )
>> make[2]: *** No rule to make target `csv/codes.csv', needed by
>> `all-am'.  Stop.
>>
>> Copied "codes.csv" from an old install to csv dir and build good.
>
> Dave,
>
> I can't see any reference to codes.csv in Makefile.am or anywhere in
> the libgeotiff directory for that matter.
>
> warmerda@gdal64[190]% pwd
> /wrk/home/warmerda/libgeotiff
> warmerda@gdal64[191]% grep codes.csv *
> warmerda@gdal64[192]%
>
> In particular, I have no csv/codes.csv in dist_csv_DATA in the
> Makefile.am.
>
>
> Is it possible you have an old makefile or are working from a tag or
> branch?  You may need to run autogen.sh manually to regenerate the
> Makefile.in, etc.
>
> In particular, I have no csv/codes.csv in dist_csv_DATA in the
>
> Best regards,
_______________________________________________
Geotiff mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/geotiff