confused on styling polygon

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

confused on styling polygon

orkun
Hi,
I think I am confused on styling polygon. 
I normally displayed the map without using symbol. When
I used symbol. Nothing is displayed.

here is the relevant code. 


  STATUS OFF 
  TYPE POLYGON 
  OPACITY 80
  CLASS
     STYLE
           SYMBOL "diagonal-auf2"
           COLOR 0 0 252
           SIZE 10
           WIDTH 5
     END
  END

​SYMBOL  
  NAME "diagonal-auf2"
  TYPE vector
  POINTS
    0 0.8
    0.2 1
    1 0.2
    0.8 0
    0 0.8
  END
  FILLED TRUE
END
What am I doing wrong?

regards

--
Ahmet Temiz
Jeoloji Müh.
Afet ve Acil Durum Yönetimi Başkanlığı
Bilgi İşlem  Dairesi Başkanlığı-CBS Grubu


________________________

Ahmet Temiz
Geological Eng.
Information Systems - GIS Group
Disaster and Emergency Management
of Presidency

_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: confused on styling polygon

jratike80

Hi,

 

I could make it to show by removing WIDTH 5.  Mapserver obviously did not like to see it in that place because the error from the server was

 

loadClass(): Unknown identifier. Parsing error near (WIDTH):(line 43)

 

By reading the documentation I do not quite understand what WIDTH should do with your diagonal-auf2 symbol, but I think it should do something, or then nothing, but not to lead to loadClass error. Perhaps you have found a bug.

 

-Jukka Rahkonen-

 

Lähettäjä: mapserver-users [mailto:[hidden email]] Puolesta Ahmet Temiz
Lähetetty: 8. marraskuuta 2016 9:47
Vastaanottaja: mapserver-users <[hidden email]>
Aihe: [mapserver-users] confused on styling polygon

 

Hi,

I think I am confused on styling polygon. 

I normally displayed the map without using symbol. When

I used symbol. Nothing is displayed.

 

here is the relevant code. 

 

 

  STATUS OFF 

  TYPE POLYGON 

  OPACITY 80

  CLASS

     STYLE

           SYMBOL "diagonal-auf2"

           COLOR 0 0 252

           SIZE 10

           WIDTH 5

     END

  END

 

​SYMBOL  

  NAME "diagonal-auf2"

  TYPE vector

  POINTS

    0 0.8

    0.2 1

    1 0.2

    0.8 0

    0 0.8

  END

  FILLED TRUE

END

What am I doing wrong?

 

regards

 

--

Ahmet Temiz
Jeoloji Müh.
Afet ve Acil Durum Yönetimi Başkanlığı
Bilgi İşlem  Dairesi Başkanlığı-CBS Grubu


________________________

Ahmet Temiz
Geological Eng.
Information Systems - GIS Group
Disaster and Emergency Management
of Presidency


_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users
Reply | Threaded
Open this post in threaded view
|

Re: confused on styling polygon

Havard Tveite-3
In reply to this post by orkun
According to the STYLE-> WIDTH documentation, for POLYGON
symbols (filled symbols of type vector) WIDTH refers to
the width of the outline of the symbol:

"If used with SYMBOL and OUTLINECOLOR, WIDTH specifies the width of the
symbol outlines. This applies to SYMBOL TYPE vector (polygons), ellipse
and truetype."

The documentation is probably a bit imprecise in not
including the word "filled" for the vector and ellipse types.

If you add OUTLINECOLOR 255 0 0, you will see the outline
of the symbol in red with a width of 5.

Apparently, leaving out OUTLINECOLOR seems to be equivalent
to OUTLINECOLOR 255 255 255, and since your outline is
thicker than the half the width of the symbol, the outline
will erase the blue (0 0 252) interior of the symbol.

If you want to see some of the interior of the symbol
(blue), you will have to reduce the value of WIDTH or
increase the value of SIZE.

Håvard

On 08. nov. 2016 08:46, Ahmet Temiz wrote:

> Hi,
> I think I am confused on styling polygon.
> I normally displayed the map without using symbol. When
> I used symbol. Nothing is displayed.
>
> here is the relevant code.
>
>
>   STATUS OFF
>   TYPE POLYGON
>   OPACITY 80
>   CLASS
>      STYLE
>            SYMBOL "diagonal-auf2"
>            COLOR 0 0 252
>            SIZE 10
>            WIDTH 5
>      END
>   END
>
> ​SYMBOL
>   NAME "diagonal-auf2"
>   TYPE vector
>   POINTS
>     0 0.8
>     0.2 1
>     1 0.2
>     0.8 0
>     0 0.8
>   END
>   FILLED TRUE
> END
> ​
> What am I doing wrong?
>
> regards
>
> --
> Ahmet Temiz
> Jeoloji Müh.
> Afet ve Acil Durum Yönetimi Başkanlığı
> Bilgi İşlem  Dairesi Başkanlığı-CBS Grubu
>
>
> ________________________
>
> Ahmet Temiz
> Geological Eng.
> Information Systems - GIS Group
> Disaster and Emergency Management
> of Presidency
>
>
> _______________________________________________
> mapserver-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/mapserver-users
>

--
Håvard Tveite
Department of Mathematical Sciences and Technology, NMBU
Drøbakveien 31, POBox 5003, N-1432 Ås, NORWAY
Phone: +47 67231548 Fax: +47 64965401 http://www.nmbu.no/imt/
_______________________________________________
mapserver-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapserver-users