confused on WCS

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

confused on WCS

orkun
Hi,

I am highly confused on WCS.
I need to get one band and its data. But I think I couldn't configure my map file properly:

here are the relavant parts:

  OUTPUTFORMAT
    NAME GEOTIFF_32
    DRIVER "GDAL/GTiff"
    MIMETYPE "image/tiff"
    IMAGEMODE FLOAT32
    #IMAGEMODE BYTE
    EXTENSION "tif"
  END
...

  LAYER
        NAME ivm_gray
        METADATA
          "wcs_label"           "ivnm"  ### required
          "wcs_rangeset_name"   "ivm"  ### required to support DescribeCoverage request
          "wcs_rangeset_label"  "ivm" ### required to support DescribeCoverage request
          "wcs_bandcount" "1"
          "wcs_enable_request" "*"
        END
        TYPE RASTER ### required
        STATUS ON
      
        DATA 'deptiled.tif'
        PROJECTION
          "init=epsg:3857"
        END

       # if you need only the data not to display       
       CLASS
             EXPRESSION ([pixel] >= 0.0 AND [pixel] < 1.0)
             STYLE
               COLORRANGE 255 255 255  0 0 0
               DATARANGE 0.0  1.0 
               RANGEITEM "pixel"
             END #STYLE
       END #end class

   END

---

shp2img gives one band and data . It is ok
But, qgis wcs three band and data is not available.

How can I solve the problem?

--
Ahmet Temiz
Jeoloji Müh.
Afet ve Acil Durum Yönetimi Başkanlığı
Bilgi İşlem  Dairesi Başkanlığı-CBS Grubu


________________________

Ahmet Temiz
Geological Eng.
Information Systems - GIS Group
Disaster and Emergency Management
of Presidency

_______________________________________________
mapserver-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-users