compatible postgis-java tag for postgis-2.2.0 ?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

compatible postgis-java tag for postgis-2.2.0 ?

Bandaru Muralikrishna
Hi,

I want to build postgis jdbc driver with postgis-2.2.0 sources. I
didn't see any postgis-java related files  with postgis-2.2.0 sources.
The statement from http://postgis.net/source/ link is saying "As of
June 2015, PostGIS JDBC development has been split from PostGIS core
and is now on github."  I can see four tags under postgis-java git hub
repository ( https://github.com/postgis/postgis-java/ ). So which one
is compatible tag for me to build  postgis jdbc driver with
postgis-2.2.0 sources.

---
Thanks & Regards
Murali Krishna
_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: compatible postgis-java tag for postgis-2.2.0 ?

Phillip Ross
Hi Bandaru... since the split from core, the postgis jdbc extensions
are no longer versioned along with the PostGIS core.  The latest
release of the the jdbc extensions works fine with postgis-2.2.0.

Hope that helps!

- Phillip

On Tue, Nov 17, 2015 at 8:15 AM, Bandaru Muralikrishna
<[hidden email]> wrote:

> Hi,
>
> I want to build postgis jdbc driver with postgis-2.2.0 sources. I
> didn't see any postgis-java related files  with postgis-2.2.0 sources.
> The statement from http://postgis.net/source/ link is saying "As of
> June 2015, PostGIS JDBC development has been split from PostGIS core
> and is now on github."  I can see four tags under postgis-java git hub
> repository ( https://github.com/postgis/postgis-java/ ). So which one
> is compatible tag for me to build  postgis jdbc driver with
> postgis-2.2.0 sources.
>
> ---
> Thanks & Regards
> Murali Krishna
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/postgis-users
_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: compatible postgis-java tag for postgis-2.2.0 ?

Bandaru Muralikrishna
Hi,

I can see '2.2.2-SNAPSHOT' with version tag in pom.xml from 2.2.1 tag ( https://github.com/postgis/postgis-java/blob/v2.2.1/pom.xml ). SNAPSHOT means it is in development process, then why using this even though 2.2.1 is a stable tag ? is there any reason for this ? 

On Tue, Nov 17, 2015 at 11:28 PM, Phillip Ross <[hidden email]> wrote:
Hi Bandaru... since the split from core, the postgis jdbc extensions
are no longer versioned along with the PostGIS core.  The latest
release of the the jdbc extensions works fine with postgis-2.2.0.

Hope that helps!

- Phillip

On Tue, Nov 17, 2015 at 8:15 AM, Bandaru Muralikrishna
<[hidden email]> wrote:
> Hi,
>
> I want to build postgis jdbc driver with postgis-2.2.0 sources. I
> didn't see any postgis-java related files  with postgis-2.2.0 sources.
> The statement from http://postgis.net/source/ link is saying "As of
> June 2015, PostGIS JDBC development has been split from PostGIS core
> and is now on github."  I can see four tags under postgis-java git hub
> repository ( https://github.com/postgis/postgis-java/ ). So which one
> is compatible tag for me to build  postgis jdbc driver with
> postgis-2.2.0 sources.
>
> ---
> Thanks & Regards
> Murali Krishna
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/postgis-users
_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users



--
Thanks & Regards
Murali Krishna
Configuration Management Team

phone: +919767825021
Website: www.enterprisedb.com
EnterpriseDB Blog: http://blogs.enterprisedb.com/
Follow us on Twitter: http://www.twitter.com/enterprisedb

_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: compatible postgis-java tag for postgis-2.2.0 ?

Phillip Ross
This looks like a tagging problem with github.  I'll have to investigate further, but the tags look to be offset by 1 in the commit history.  Thank you for bringing this to my attention.

- Phillip

On Tue, Aug 9, 2016 at 3:12 AM, Bandaru Muralikrishna <[hidden email]> wrote:
Hi,

I can see '2.2.2-SNAPSHOT' with version tag in pom.xml from 2.2.1 tag ( https://github.com/postgis/postgis-java/blob/v2.2.1/pom.xml ). SNAPSHOT means it is in development process, then why using this even though 2.2.1 is a stable tag ? is there any reason for this ? 

On Tue, Nov 17, 2015 at 11:28 PM, Phillip Ross <[hidden email]> wrote:
Hi Bandaru... since the split from core, the postgis jdbc extensions
are no longer versioned along with the PostGIS core.  The latest
release of the the jdbc extensions works fine with postgis-2.2.0.

Hope that helps!

- Phillip

On Tue, Nov 17, 2015 at 8:15 AM, Bandaru Muralikrishna
<[hidden email]> wrote:
> Hi,
>
> I want to build postgis jdbc driver with postgis-2.2.0 sources. I
> didn't see any postgis-java related files  with postgis-2.2.0 sources.
> The statement from http://postgis.net/source/ link is saying "As of
> June 2015, PostGIS JDBC development has been split from PostGIS core
> and is now on github."  I can see four tags under postgis-java git hub
> repository ( https://github.com/postgis/postgis-java/ ). So which one
> is compatible tag for me to build  postgis jdbc driver with
> postgis-2.2.0 sources.
>
> ---
> Thanks & Regards
> Murali Krishna
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/postgis-users
_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users



--
Thanks & Regards
Murali Krishna
Configuration Management Team

phone: <a href="tel:%2B919767825021" value="+919767825021" target="_blank">+919767825021
Website: www.enterprisedb.com
EnterpriseDB Blog: http://blogs.enterprisedb.com/
Follow us on Twitter: http://www.twitter.com/enterprisedb

_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users


_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users